bluez: added patch to allow dbus to spawn obexd
This commit is contained in:
parent
a2cb1a60aa
commit
7c1b984454
@ -1,6 +1,7 @@
|
||||
untrusted comment: verify with /etc/ports/contrib.pub
|
||||
RWSagIOpLGJF31gSO9xP/Zofy3lNFHS/Yh/I28YEZFyHj0Rt9b0McdtGguJG33CLrRmn1M3kuZ2bqt+tBO+OVol7xtZCMhvJ5AU=
|
||||
SHA256 (Pkgfile) = c937518b55f80eac4811dde486c3c006f21a8b0c0fc37272c5aa4ef2bc88ed93
|
||||
RWSagIOpLGJF31RUo5FSzKmwoSw2UcTHUs1fYTtTgLnEROpwF1uwfVkeymuv9PiprrJs+zb6Qq5479T8CiueRyU3N/Y2dWWECgQ=
|
||||
SHA256 (Pkgfile) = 4ec8fc2535f33ed80f75c7219c27c84ae819a308ed3b21880d430287e1111055
|
||||
SHA256 (.footprint) = 79d2df97507a2bb0d5c4c2a7d36eac2d60214acaf1099fdcc11180d9e2550f0a
|
||||
SHA256 (bluez-5.72.tar.xz) = 499d7fa345a996c1bb650f5c6749e1d929111fa6ece0be0e98687fee6124536e
|
||||
SHA256 (bluetoothd.service) = ab562292d8e226cc1ec809002c39fa99a7813a4157fabbbbe4fd77fc095ab83b
|
||||
SHA256 (bluez-5.72-obexd_without_systemd-1.patch) = 6d97c8cfd7d8ce42a7edfe67dac5f0d4551d290b815226024c55afe8201538d2
|
||||
|
@ -6,13 +6,16 @@
|
||||
|
||||
name=bluez
|
||||
version=5.72
|
||||
release=1
|
||||
release=2
|
||||
source=(https://mirrors.edge.kernel.org/pub/linux/bluetooth/bluez-$version.tar.xz
|
||||
bluetoothd.service)
|
||||
bluetoothd.service
|
||||
bluez-5.72-obexd_without_systemd-1.patch)
|
||||
|
||||
build() {
|
||||
cd bluez-$version
|
||||
|
||||
patch -Np1 -i $SRC/bluez-5.72-obexd_without_systemd-1.patch
|
||||
|
||||
prt-get isinst alsa-lib && PKGMK_BLUEZ+=' --enable-midi'
|
||||
prt-get isinst cups && PKGMK_BLUEZ+=' --enable-cups' || PKGMK_BLUEZ+=' --disable-cups'
|
||||
prt-get isinst docutils || PKGMK_BLUEZ+=' --disable-manpages'
|
||||
|
63
bluez/bluez-5.72-obexd_without_systemd-1.patch
Normal file
63
bluez/bluez-5.72-obexd_without_systemd-1.patch
Normal file
@ -0,0 +1,63 @@
|
||||
Submitted By: Armin K. <krejzi at email dot com>
|
||||
Date: 2013-04-29
|
||||
Initial Package Version: 5.17
|
||||
Upstream Status: unknown
|
||||
Origin: Arch Linux (Giovanni Campagna)
|
||||
Description: Allow using obexd without systemd in the user session
|
||||
|
||||
Not all sessions run systemd --user (actually, the majority
|
||||
doesn't), so the dbus daemon must be able to spawn obexd
|
||||
directly, and to do so it needs the full path of the daemon.
|
||||
|
||||
Updated for bluez-5.60 on 2021-08-17
|
||||
---
|
||||
Makefile.obexd | 4 ++--
|
||||
obexd/src/org.bluez.obex.service | 4 ----
|
||||
obexd/src/org.bluez.obex.service.in | 4 ++++
|
||||
3 files changed, 6 insertions(+), 6 deletions(-)
|
||||
delete mode 100644 obexd/src/org.bluez.obex.service
|
||||
create mode 100644 obexd/src/org.bluez.obex.service.in
|
||||
|
||||
diff --git a/Makefile.obexd b/Makefile.obexd
|
||||
index 3760867..142e7c3 100644
|
||||
--- a/Makefile.obexd
|
||||
+++ b/Makefile.obexd
|
||||
@@ -2,12 +2,12 @@
|
||||
if SYSTEMD
|
||||
systemduserunitdir = $(SYSTEMD_USERUNITDIR)
|
||||
systemduserunit_DATA = obexd/src/obex.service
|
||||
+endif
|
||||
|
||||
dbussessionbusdir = $(DBUS_SESSIONBUSDIR)
|
||||
dbussessionbus_DATA = obexd/src/org.bluez.obex.service
|
||||
-endif
|
||||
|
||||
-EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service
|
||||
+EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service.in
|
||||
|
||||
obex_plugindir = $(libdir)/obex/plugins
|
||||
|
||||
diff --git a/obexd/src/org.bluez.obex.service b/obexd/src/org.bluez.obex.service
|
||||
deleted file mode 100644
|
||||
index a538088..0000000
|
||||
--- a/obexd/src/org.bluez.obex.service
|
||||
+++ /dev/null
|
||||
@@ -1,4 +0,0 @@
|
||||
-[D-BUS Service]
|
||||
-Name=org.bluez.obex
|
||||
-Exec=/bin/false
|
||||
-SystemdService=dbus-org.bluez.obex.service
|
||||
diff --git a/obexd/src/org.bluez.obex.service.in b/obexd/src/org.bluez.obex.service.in
|
||||
new file mode 100644
|
||||
index 0000000..9c815f2
|
||||
--- /dev/null
|
||||
+++ b/obexd/src/org.bluez.obex.service.in
|
||||
@@ -0,0 +1,4 @@
|
||||
+[D-BUS Service]
|
||||
+Name=org.bluez.obex
|
||||
+Exec=@libexecdir@/obexd
|
||||
+SystemdService=dbus-org.bluez.obex.service
|
||||
--
|
||||
1.8.3.1
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user