shaderc: 2020.1 -> 2020.3

This commit is contained in:
Danny Rawlins 2020-10-24 21:58:53 +11:00
parent 2a5c6992c7
commit 7dc753cb0a
7 changed files with 63 additions and 38 deletions

View File

@ -1,12 +1,12 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF30Gq2Ldx64JfnGmOoVC0EXx4KIc0KNtZPACJF3YprNgbX1zKkARoIc3+/uMaujMxJZA7mDOWYMase/qeBn014w0=
SHA256 (Pkgfile) = a09d9d8cd7e84710de36e34047d6bdfc8e1cced4de1417444168548b74e64310
RWSagIOpLGJF3xVATi6Xm3gifhMplCNR6M9pck1CXiWZY7IdH01Ep4YbnXKedLR1dM/olClHLJnOcwb2TG7K4kZXlrfkC/NU+AA=
SHA256 (Pkgfile) = ab7df716fe2c843377b8965b709cfc483ba1a986c03c3822732ea07414bf12f7
SHA256 (.footprint) = a55f4db9a8f36310df010a88256abef6d13753f525ff212c4e7dcb390e6c1e66
SHA256 (shaderc-v2020.1.tar.gz) = fbf49e7c095c1d17ec38a498e340fc49de6400262071f6e1619f50eec1f9e5b7
SHA256 (glslc.1) = 39190580e546e57343b35b2893e1f03df7c1c1c099532e3c5da38648bbac36e3
SHA256 (spvc.1) = e50f63ca1e288b40efadc5c2052c55d86cb915e427c5a87410397bd105a79f2f
SHA256 (shaderc-v2020.3.tar.gz) = e595f71d0db0c37ee959b538cfda16e39e3f0dce8893a0bc0ac0080c342c0275
SHA256 (glslc.1) = 468467ab0ec0eac2b221563ef370826443c22cee55f11f6dc8be81b168e3e492
SHA256 (spvc.1) = 95b9a165ec12d022a58c41ece70f5783abf6127eab1676d4f66c88803e007a85
SHA256 (glslc-asciidoc.patch) = 685d97223af4fcd169921ee5f9b2c49a2df3d84b7bf7df7dd1f6def4361321a6
SHA256 (spvc-asciidoc.patch) = fd0c682186be4231fab5c83bf7625678f3b7905c980e3f7c9ae6cd5e212f9563
SHA256 (shaderc-2020.1-fix-build.patch) = da649ce6c6fd853e7f98f279af1c8329226d138cb07779e0833f3cb88250b4b4
SHA256 (0001-Drop-third-party-code-in-CMakeLists.txt.patch) = 9127adf6f94ababfa8d7aaa10ec8a8f0731a4e074f14b3a431174986dc8b4226
SHA256 (0001-Drop-third-party-code-in-CMakeLists.txt.patch) = 382d0dbd50f691c81d3bd941ef4d85fea1ba0eeed3537a3a9cc7a666ff6504af
SHA256 (shaderc-2020.3-system-glslang.patch) = 39a9e7a18824c255b125ed9af6bca3a732b52162faab716fb52cae994d73c9ce
SHA256 (0001-Fix-SPIRV-includes-location.patch) = dc4a3d51aeb77a6a599921801ff690620167aa0288513b414022e9a40e387cfe

View File

@ -1,7 +1,7 @@
diff -up shaderc-f76bb2f09f858c3014b329961d836964e515095d/CMakeLists.txt.orig shaderc-f76bb2f09f858c3014b329961d836964e515095d/CMakeLists.txt
--- shaderc-f76bb2f09f858c3014b329961d836964e515095d/CMakeLists.txt.orig 2020-01-22 21:15:53.000000000 +0100
+++ shaderc-f76bb2f09f858c3014b329961d836964e515095d/CMakeLists.txt 2020-02-02 21:06:15.193583552 +0100
@@ -92,7 +92,6 @@ endif(MSVC)
@@ -98,7 +98,6 @@ endif(MSVC)
# Configure subdirectories.
# We depend on these for later projects, so they should come first.
@ -9,10 +9,12 @@ diff -up shaderc-f76bb2f09f858c3014b329961d836964e515095d/CMakeLists.txt.orig sh
if(SHADERC_ENABLE_SPVC)
add_subdirectory(libshaderc_spvc)
@@ -103,11 +102,6 @@ add_subdirectory(libshaderc)
@@ -107,13 +106,6 @@ endif()
add_subdirectory(libshaderc_util)
add_subdirectory(libshaderc)
add_subdirectory(glslc)
add_subdirectory(examples)
-add_subdirectory(examples)
-
-add_custom_target(build-version
- ${PYTHON_EXECUTABLE}
- ${CMAKE_CURRENT_SOURCE_DIR}/utils/update_build_version.py

View File

@ -1,16 +1,16 @@
# Description: Collection of tools, libraries and tests for shader compilation.
# Description: A collection of tools, libraries and tests for shader compilation.
# URL: https://github.com/google/shaderc
# Maintainer: Danny Rawlins, crux at romster dot me
# Depends on: glslang
# Optional: asciidoctor
name=shaderc
version=2020.1
version=2020.3
release=1
source=(https://github.com/google/$name/archive/v$version/$name-v$version.tar.gz
glslc.1 spvc.1 glslc-asciidoc.patch spvc-asciidoc.patch
shaderc-2020.1-fix-build.patch
0001-Drop-third-party-code-in-CMakeLists.txt.patch
shaderc-2020.3-system-glslang.patch
0001-Fix-SPIRV-includes-location.patch)
build() {
@ -19,9 +19,9 @@ build() {
patch -d glslc -p0 -i $SRC/glslc-asciidoc.patch
patch -d spvc -p0 -i $SRC/spvc-asciidoc.patch
patch -p1 -i $SRC/shaderc-2020.1-fix-build.patch
patch -p1 -i $SRC/0001-Drop-third-party-code-in-CMakeLists.txt.patch
patch -p1 -i $SRC/0001-Fix-SPIRV-includes-location.patch
patch -p1 -i $SRC/shaderc-2020.3-system-glslang.patch
# de-vendor libs and disable git versioning
sed '/examples/d;/third_party/d' -i CMakeLists.txt

View File

@ -2,12 +2,12 @@
.\" Title: glslc
.\" Author: [see the "AUTHOR(S)" section]
.\" Generator: Asciidoctor 2.0.10
.\" Date: 2020-07-24
.\" Date: 2020-10-24
.\" Manual: \ \&
.\" Source: \ \&
.\" Language: English
.\"
.TH "`GLSLC`" "1" "2020-07-24" "\ \&" "\ \&"
.TH "`GLSLC`" "1" "2020-10-24" "\ \&" "\ \&"
.ie \n(.g .ds Aq \(aq
.el .ds Aq '
.ss \n[.ss] 0
@ -34,6 +34,7 @@
.if n .RS 4
.nf
glslc [\-\-help]
glslc [\-h]
glslc [\-\-show\-limits]
@ -260,9 +261,9 @@ If no compilation stage is selected, the output file will be named \f(CRa.spv\fP
.RE
.SH "COMMAND LINE OPTIONS"
.SS "Overall Options"
.SS "\f(CR\-\-help\fP"
.SS "\f(CR\-\-help\fP, \f(CR\-h\fP"
.sp
\f(CR\-\-help\fP tells the glslc compiler to display all available options and exit.
Option \f(CR\-\-help\fP or \f(CR\-h\fP tells the glslc compiler to display all available options and exit.
.SS "\f(CR\-\-show\-limits\fP"
.sp
\f(CR\-\-show\-limits\fP shows default resource limits for shader compilation. The syntax

View File

@ -1,17 +0,0 @@
This patch is a revert of commit 15a66d72f33a099ec65e0fd37cf14548ed1d2bdb (Rolling 5 dependencies and fixing build (#1057)) because it adds usage of the .maxDualSourceDrawBuffersEXT field which is not available in any tagged release of glslang. The field is added in glslang in https://github.com/KhronosGroup/glslang/commit/e05cc20ec20a154d94256c744a3837c23719c0f9
---
diff --git b/libshaderc_util/src/resources.cc a/libshaderc_util/src/resources.cc
index d64e47f..458a63f 100644
--- b/libshaderc_util/src/resources.cc
+++ a/libshaderc_util/src/resources.cc
@@ -125,7 +125,7 @@ const TBuiltInResource kDefaultTBuiltInResource = {
/* .maxTaskWorkGroupSizeY_NV = */ 1,
/* .maxTaskWorkGroupSizeZ_NV = */ 1,
/* .maxMeshViewCountNV = */ 4,
- /* .maxDualSourceDrawBuffersEXT = */ 1,
+
// This is the glslang TLimits structure.
// It defines whether or not the following features are enabled.
// We want them to all be enabled.
--

View File

@ -0,0 +1,39 @@
Index: shaderc-2020.3/libshaderc_util/CMakeLists.txt
===================================================================
--- shaderc-2020.3/libshaderc_util/CMakeLists.txt
+++ shaderc-2020.3/libshaderc_util/CMakeLists.txt 2020-10-16 23:28:53.405312623 +0200
@@ -46,7 +46,7 @@
find_package(Threads)
target_link_libraries(shaderc_util PRIVATE
- glslang OSDependent OGLCompiler HLSL glslang SPIRV
+ glslang HLSL SPIRV
SPIRV-Tools-opt ${CMAKE_THREAD_LIBS_INIT})
shaderc_add_tests(
Index: shaderc-2020.3/libshaderc/CMakeLists.txt
===================================================================
--- shaderc-2020.3/libshaderc/CMakeLists.txt
+++ shaderc-2020.3/libshaderc/CMakeLists.txt 2020-10-16 23:29:11.120117663 +0200
@@ -62,7 +62,7 @@
find_package(Threads)
set(SHADERC_LIBS
- glslang OSDependent OGLCompiler glslang ${CMAKE_THREAD_LIBS_INIT}
+ glslang ${CMAKE_THREAD_LIBS_INIT}
shaderc_util
SPIRV # from glslang
SPIRV-Tools
Index: shaderc-2020.3/glslc/CMakeLists.txt
===================================================================
--- shaderc-2020.3/glslc/CMakeLists.txt
+++ shaderc-2020.3/glslc/CMakeLists.txt 2020-10-16 23:28:53.405312623 +0200
@@ -43,7 +43,7 @@
endif(SHADERC_ENABLE_WGSL_OUTPUT)
target_link_libraries(glslc PRIVATE
- glslang OSDependent OGLCompiler HLSL glslang SPIRV # Glslang libraries
+ glslang HLSL SPIRV # Glslang libraries
$<$<BOOL:${SHADERC_ENABLE_WGSL_OUTPUT}>:libtint> # Tint libraries, optional
shaderc_util shaderc # internal Shaderc libraries
${CMAKE_THREAD_LIBS_INIT})

View File

@ -2,12 +2,12 @@
.\" Title: spvc
.\" Author: [see the "AUTHOR(S)" section]
.\" Generator: Asciidoctor 2.0.10
.\" Date: 2020-07-24
.\" Date: 2020-10-24
.\" Manual: \ \&
.\" Source: \ \&
.\" Language: English
.\"
.TH "`SPVC`" "1" "2020-07-24" "\ \&" "\ \&"
.TH "`SPVC`" "1" "2020-10-24" "\ \&" "\ \&"
.ie \n(.g .ds Aq \(aq
.el .ds Aq '
.ss \n[.ss] 0