synaptics: removed from repository. Use xorg-xf86-input-synaptics instead.

This commit is contained in:
Mikhail Kolesnik 2008-11-11 17:54:37 +02:00
parent c98c7c7121
commit 83c31fba85
4 changed files with 0 additions and 96 deletions

View File

@ -1,15 +0,0 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/synclient
-rwxr-xr-x root/root usr/bin/syndaemon
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/lib/xorg/
drwxr-xr-x root/root usr/lib/xorg/modules/
drwxr-xr-x root/root usr/lib/xorg/modules/input/
-rw-r--r-- root/root usr/lib/xorg/modules/input/synaptics_drv.so
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man1/
-rw-r--r-- root/root usr/man/man1/synclient.1.gz
-rw-r--r-- root/root usr/man/man1/syndaemon.1.gz
drwxr-xr-x root/root usr/man/man5/
-rw-r--r-- root/root usr/man/man5/synaptics.5.gz

View File

@ -1,2 +0,0 @@
1102cd575045640a064ab6f9b1e391af synaptics-0.14.6.tar.bz2
0a537b564bcbde21c6b0c89b92e48d84 synaptics_input_api.diff

View File

@ -1,17 +0,0 @@
# Description: Synaptics TouchPad driver for XOrg/XFree86
# URL: http://web.telia.com/~u89404340/touchpad/
# Maintainer: Mikhail Kolesnik, mike at openbunker dot org
# Depends on: x11
name=synaptics
version=0.14.6
release=3
source=(http://web.telia.com/~u89404340/touchpad/files/$name-$version.tar.bz2
${name}_input_api.diff)
build() {
cd $name-$version
patch -p1 -i $SRC/${name}_input_api.diff
make
make BINDIR=$PKG/usr/bin MANDIR=$PKG/usr/man DESTDIR=$PKG install
}

View File

@ -1,62 +0,0 @@
diff -u synaptics-0.14.6.orig/Makefile synaptics-0.14.6/Makefile
--- synaptics-0.14.6.orig/Makefile 2006-07-15 17:58:26.000000000 +0200
+++ synaptics-0.14.6/Makefile 2007-09-07 15:03:17.386179198 +0200
@@ -34,10 +34,9 @@
LDCOMBINEFLAGS = -shared -lc
PICFLAG = $(call check_gcc,-fPIC,)
X_INCLUDES_ROOT = $(INSTALLED_X)
- SDKDIR = $(shell pkg-config xorg-server --variable=sdkdir)
ALLINCLUDES = -I. -I$(INSTALLED_X)/include/X11 \
-I$(INSTALLED_X)/include/X11/extensions \
- -I$(SDKDIR)
+ `pkg-config xorg-server --cflags`
else
INSTALLED_X = /usr/X11R6
INPUT_MODULE_DIR = $(DESTDIR)/$(INSTALLED_X)/$(LIBDIR)/modules/input
diff -u synaptics-0.14.6.orig/synaptics.c synaptics-0.14.6/synaptics.c
--- synaptics-0.14.6.orig/synaptics.c 2006-07-15 17:54:29.000000000 +0200
+++ synaptics-0.14.6/synaptics.c 2007-09-07 15:10:24.910542275 +0200
@@ -321,7 +321,9 @@
local->private_flags = 0;
local->flags = XI86_POINTER_CAPABLE | XI86_SEND_DRAG_EVENTS;
local->conf_idev = dev;
+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) == 0
local->motion_history_proc = xf86GetMotionEvents;
+#endif
local->history_size = 0;
local->always_core_feedback = 0;
@@ -613,8 +615,17 @@
InitPointerDeviceStruct((DevicePtr)dev, map,
SYN_MAX_BUTTONS,
- miPointerGetMotionEvents, SynapticsCtrl,
+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) == 0
+ miPointerGetMotionEvents,
+#else
+ GetMotionHistory,
+#endif
+ SynapticsCtrl,
+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) == 0
miPointerGetMotionBufferSize());
+#else
+ GetMotionHistorySize(), 2);
+#endif
/* X valuator */
xf86InitValuatorAxisStruct(dev, 0, 0, -1, 1, 0, 1);
diff -u synaptics-0.14.6.orig/synaptics.h synaptics-0.14.6/synaptics.h
--- synaptics-0.14.6.orig/synaptics.h 2006-07-15 17:54:29.000000000 +0200
+++ synaptics-0.14.6/synaptics.h 2007-09-07 15:10:12.409829887 +0200
@@ -226,5 +226,11 @@
#endif /* SYNAPTICS_PRIVATE */
+/* Previously found in xf86Xinput.h */
+#ifdef DBG
+#undef DBG
+#endif
+
+#define DBG(lvl, f) {if ((lvl) <= xf86GetVerbosity()) f;}
#endif /* _SYNAPTICS_H_ */