yersinia: initial commit, v0.8.2-15d41ff

This commit is contained in:
Alexandr Savca 2020-11-21 15:57:41 +02:00
parent 2bdaa3e432
commit 846748ae7a
4 changed files with 69 additions and 0 deletions

7
yersinia/.footprint Normal file
View File

@ -0,0 +1,7 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/yersinia
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/man/
drwxr-xr-x root/root usr/share/man/man8/
-rw-r--r-- root/root usr/share/man/man8/yersinia.8.gz

6
yersinia/.signature Normal file
View File

@ -0,0 +1,6 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF333kjldimwlKJkjKyFk49d0mvVJTfQD3DY4cC9lHlE39Z9LJkmUWTdK0B3YTmcMRmzr8n4pboFHcmH/+3PDNkwY=
SHA256 (Pkgfile) = bacf380686123c4d273ec1118b397853a4fd89df9a537dc9518d91c674d1c4cc
SHA256 (.footprint) = dfaa95c17b8f1d38c45ed71e4898698e726740b927a2e3902de2f1fba4144a37
SHA256 (yersinia-15d41ffd722eb3510c6b51d878bc52f88fa8b6a8.tar.gz) = 0247c2501bf73193591d2d5fcf987e097d582940d95cabc5389d72ce6e058f49
SHA256 (0001-gtk-interface.c-respect-system-font.patch) = 0fff0da7ee08563c1fc7923c16172948f5af668d418e5a76eb5e6cce46dfd41d

View File

@ -0,0 +1,27 @@
From d317fff06cda63a9f3713f7dee2b3d0788909e2b Mon Sep 17 00:00:00 2001
From: Alexandr Savca <alexandr.savca89@gmail.com>
Date: Tue, 17 Nov 2020 11:47:33 +0200
Subject: [PATCH] gtk-interface.c: respect system font
---
src/gtk-interface.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/gtk-interface.c b/src/gtk-interface.c
index eee367e..486b915 100644
--- a/src/gtk-interface.c
+++ b/src/gtk-interface.c
@@ -1707,8 +1707,8 @@ create_protocol_mwindow(GtkWidget *Main, struct gtk_s_helper *helper, u_int8_t p
gtk_entry_set_editable(GTK_ENTRY(entry[i]), FALSE);
/* Set up a monospaced font */
- font_desc = pango_font_description_from_string ("Monospace 10");
- gtk_widget_modify_font(entry[i], font_desc);
+ /*font_desc = pango_font_description_from_string ("Monospace 10");*/
+ /*gtk_widget_modify_font(entry[i], font_desc);*/
gtk_widget_show(entry[i]);
/* Initialize the values */
--
2.29.2

29
yersinia/Pkgfile Normal file
View File

@ -0,0 +1,29 @@
# Description: Framework for layer 2 attacks
# URL: https://github.com/tomac/yersinia
# Maintainer: Alexandr Savca, alexandrsavca89 at gmail dot com
# Depends on: gtk libdnet xorg-libxdamage
name=yersinia
version=0.8.2-15d41ff
_commit=15d41ffd722eb3510c6b51d878bc52f88fa8b6a8
release=1
source=(https://github.com/tomac/$name/archive/$_commit/$name-$_commit.tar.gz
0001-gtk-interface.c-respect-system-font.patch)
build() {
cd $name-$_commit
# remove default debug/optimization flags
sed -i -e "/CFLAGS=\"/s/-O3 -Wall -g /$CFLAGS -Wall /g" configure.ac
# font-fix
patch -p1 < $SRC/0001-gtk-interface.c-respect-system-font.patch
./autogen.sh \
--prefix=/usr \
--disable-nls \
--disable-admin # Disable the remote admin interface
make
make DESTDIR=$PKG install
}