multimc: dropped unmaintained port
This commit is contained in:
parent
bdfbbdccc4
commit
85dc4ecc19
@ -1,20 +0,0 @@
|
||||
drwxr-xr-x root/root etc/
|
||||
drwxr-xr-x root/root etc/ld.so.conf.d/
|
||||
-rw-r--r-- root/root etc/ld.so.conf.d/multimc5.conf
|
||||
drwxr-xr-x root/root usr/
|
||||
drwxr-xr-x root/root usr/bin/
|
||||
-rwxr-xr-x root/root usr/bin/multimc
|
||||
drwxr-xr-x root/root usr/lib/
|
||||
-rwxr-xr-x root/root usr/lib/libLauncher_iconfix.so
|
||||
-rwxr-xr-x root/root usr/lib/libLauncher_nbt++.so
|
||||
-rwxr-xr-x root/root usr/lib/libLauncher_quazip.so
|
||||
-rwxr-xr-x root/root usr/lib/libLauncher_rainbow.so
|
||||
drwxr-xr-x root/root usr/share/
|
||||
drwxr-xr-x root/root usr/share/applications/
|
||||
-rwxr-xr-x root/root usr/share/applications/multimc.desktop
|
||||
drwxr-xr-x root/root usr/share/multimc/
|
||||
drwxr-xr-x root/root usr/share/multimc/jars/
|
||||
-rw-r--r-- root/root usr/share/multimc/jars/JavaCheck.jar
|
||||
-rw-r--r-- root/root usr/share/multimc/jars/NewLaunch.jar
|
||||
drwxr-xr-x root/root usr/share/pixmaps/
|
||||
-rwxr-xr-x root/root usr/share/pixmaps/multimc.svg
|
@ -1,12 +0,0 @@
|
||||
untrusted comment: verify with /etc/ports/contrib.pub
|
||||
RWSagIOpLGJF36k/uDAjr6D2kRjTLIAB8q2QjgjQYxJzvwk3IgLIKVojyiCrZ4mLU8hPrnUb0sQLo+lztPNU4l3EDx9yMtpiMwk=
|
||||
SHA256 (Pkgfile) = f7542a0a91ef9dd3a6f708d9395c292172ca50ab413f46489828c991845cfbd8
|
||||
SHA256 (.footprint) = 05132b93040aac25bc12b92e5ec5f7e6016511781a199a70243273ffce5bd50e
|
||||
SHA256 (Launcher-0.6.16.tar.gz) = 2ff5a4368a01bf467790667a7a1e7728b4a2639bea2a15b285aa309ff1d8a557
|
||||
SHA256 (b1a72ac0bb5a732bf887a535ab75c6f9bedb6b6b.tar.gz) = 4eb37f558f20f728357c955f14788608679745a0711522d0eeca2578fd4c9c13
|
||||
SHA256 (dc72a20b7efd304d12af2025223fad07b4b78464.tar.gz) = 2ed9dc824007b4f7b12f807f56c98e1248b8a7aba7eca4838085092958dc1595
|
||||
SHA256 (mmc-stable-lin64.tar.gz) = 0585778c3e9e8cd51d324af6c69469439f36a88571ef83be44ae01fcfefdd251
|
||||
SHA256 (0001-Readd-lin-system-and-LAUNCHER_LINUX_DATADIR.patch) = 8d882296b58dece4f09f629ba88a1a54c23911abb26055f4a1fdadd1d0cb61b3
|
||||
SHA256 (fix-jars.patch) = 981cffbafc1827e427b3b86f7dcbbb836d179ef7cd0c6d4a4da92fef562d2c01
|
||||
SHA256 (mmc-brand.patch) = eb5a56bf2b9f7e9e1892bc30cb7d7820137cba4296a177a6cfe74fb6eae8e854
|
||||
SHA256 (multimc.desktop) = 6d12903a5630c9ff7aa35769566f29a8b4b591024cc61be826f4a3b1e8bea3bc
|
@ -1,75 +0,0 @@
|
||||
From 27e3d0174139b99da9e6afad1ba6fffff95ff3a9 Mon Sep 17 00:00:00 2001
|
||||
From: Miko <mikoxyzzz@gmail.com>
|
||||
Date: Sat, 20 Nov 2021 20:10:36 +0100
|
||||
Subject: [PATCH] Readd "lin-system" and LAUNCHER_LINUX_DATADIR
|
||||
|
||||
During the debranding of MultiMC, peterix removed the "lin-system"
|
||||
layout and LAUNCHER_LINUX_DATADIR (previously known as
|
||||
MULTIMC_LINUX_DATADIR.) This patch reverts those two changes.
|
||||
|
||||
Signed-off-by: Miko <mikoxyzzz@gmail.com>
|
||||
---
|
||||
CMakeLists.txt | 20 ++++++++++++++++++--
|
||||
launcher/Application.cpp | 8 +++++++-
|
||||
2 files changed, 25 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 0cf93758..2fc38b59 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -140,8 +140,8 @@ endif()
|
||||
####################################### Install layout #######################################
|
||||
|
||||
# How to install the build results
|
||||
-set(Launcher_LAYOUT "auto" CACHE STRING "The layout for the launcher installation (auto, win-bundle, lin-nodeps, mac-bundle)")
|
||||
-set_property(CACHE Launcher_LAYOUT PROPERTY STRINGS auto win-bundle lin-nodeps mac-bundle)
|
||||
+set(Launcher_LAYOUT "auto" CACHE STRING "The layout for the launcher installation (auto, win-bundle, lin-nodeps, lin-system, mac-bundle)")
|
||||
+set_property(CACHE Launcher_LAYOUT PROPERTY STRINGS auto win-bundle lin-nodeps lin-system mac-bundle)
|
||||
|
||||
if(Launcher_LAYOUT STREQUAL "auto")
|
||||
if(UNIX AND APPLE)
|
||||
@@ -206,6 +206,22 @@ elseif(Launcher_LAYOUT_REAL STREQUAL "lin-nodeps")
|
||||
configure_file(launcher/Launcher.in "${CMAKE_CURRENT_BINARY_DIR}/LauncherScript" @ONLY)
|
||||
install(PROGRAMS "${CMAKE_CURRENT_BINARY_DIR}/LauncherScript" DESTINATION ${BUNDLE_DEST_DIR} RENAME ${Launcher_Name})
|
||||
|
||||
+elseif(Launcher_LAYOUT_REAL STREQUAL "lin-system")
|
||||
+ set(Launcher_APP_BINARY_NAME "devlauncher" CACHE STRING "Name of the Launcher binary")
|
||||
+ set(Launcher_BINARY_DEST_DIR "bin" CACHE STRING "Path to the binary directory")
|
||||
+ set(Launcher_LIBRARY_DEST_DIR "lib${LIB_SUFFIX}" CACHE STRING "Path to the library directory")
|
||||
+ set(Launcher_SHARE_DEST_DIR "share/devlauncher" CACHE STRING "Path to the shard data directory")
|
||||
+ set(JARS_DEST_DIR "${Launcher_SHARE_DEST_DIR}/jars")
|
||||
+
|
||||
+ set(BINARY_DEST_DIR ${Launcher_BINARY_DEST_DIR})
|
||||
+ set(LIBRARY_DEST_DIR ${Launcher_LIBRARY_DEST_DIR})
|
||||
+
|
||||
+ MESSAGE(STATUS "Compiling for linux system with ${Launcher_SHARE_DEST_DIR} and LAUNCHER_LINUX_DATADIR")
|
||||
+ SET(Launcher_APP_BINARY_DEFS "-DMULTIMC_JARS_LOCATION=${CMAKE_INSTALL_PREFIX}/${JARS_DEST_DIR}" "-DLAUNCHER_LINUX_DATADIR")
|
||||
+
|
||||
+ # install as bundle with no dependencies included
|
||||
+ set(INSTALL_BUNDLE "nodeps")
|
||||
+
|
||||
elseif(Launcher_LAYOUT_REAL STREQUAL "win-bundle")
|
||||
set(BINARY_DEST_DIR ".")
|
||||
set(LIBRARY_DEST_DIR ".")
|
||||
diff --git a/launcher/Application.cpp b/launcher/Application.cpp
|
||||
index 8789d096..6ef64762 100644
|
||||
--- a/launcher/Application.cpp
|
||||
+++ b/launcher/Application.cpp
|
||||
@@ -304,7 +304,13 @@ Application::Application(int &argc, char **argv) : QApplication(argc, argv)
|
||||
}
|
||||
else
|
||||
{
|
||||
-#if defined(Q_OS_MAC)
|
||||
+#ifdef LAUNCHER_LINUX_DATADIR
|
||||
+ QString xdgDataHome = QFile::decodeName(qgetenv("XDG_DATA_HOME"));
|
||||
+ if (xdgDataHome.isEmpty())
|
||||
+ xdgDataHome = QDir::homePath() + QLatin1String("/.local/share");
|
||||
+ dataPath = xdgDataHome + "/multimc";
|
||||
+ adjustedBy += "XDG standard " + dataPath;
|
||||
+#elif defined(Q_OS_MAC)
|
||||
QDir foo(FS::PathCombine(applicationDirPath(), "../../Data"));
|
||||
dataPath = foo.absolutePath();
|
||||
adjustedBy += "Fallback to special Mac location " + dataPath;
|
||||
--
|
||||
2.34.0
|
||||
|
@ -1,74 +0,0 @@
|
||||
# Description: Minecraft launcher with ability to manage multiple instances.
|
||||
# URL: https://multimc.org/
|
||||
# Maintainer: unmaintained
|
||||
# Depends on: openjdk17-jdk qt5
|
||||
|
||||
name=multimc
|
||||
_pkgname=multimc
|
||||
version=0.6.16
|
||||
release=1
|
||||
source=(#https://github.com/MultiMC/Launcher/archive/refs/tags/0.6.16.tar.gz
|
||||
https://github.com/MultiMC/Launcher/archive/$version/Launcher-$version.tar.gz
|
||||
https://github.com/MultiMC/quazip/archive/b1a72ac0bb5a732bf887a535ab75c6f9bedb6b6b.tar.gz
|
||||
#https://github.com/MultiMC/quazip/archive/multimc-3.tar.gz
|
||||
#https://github.com/MultiMC/libnbtplusplus/archive/multimc-0.6.1.tar.gz
|
||||
https://github.com/MultiMC/libnbtplusplus/archive/dc72a20b7efd304d12af2025223fad07b4b78464.tar.gz
|
||||
"https://files.multimc.org/downloads/mmc-stable-lin64.tar.gz"
|
||||
"0001-Readd-lin-system-and-LAUNCHER_LINUX_DATADIR.patch"
|
||||
"fix-jars.patch"
|
||||
"mmc-brand.patch"
|
||||
"multimc.desktop"
|
||||
)
|
||||
|
||||
build() {
|
||||
cd Launcher-$version
|
||||
|
||||
patch -p1 < "${SRC}/0001-Readd-lin-system-and-LAUNCHER_LINUX_DATADIR.patch"
|
||||
patch -p1 < "${SRC}/fix-jars.patch"
|
||||
patch -p1 < "${SRC}/mmc-brand.patch"
|
||||
|
||||
# generate microsoft client id (https://aur.archlinux.org/packages/multimc-git)
|
||||
pushd ${SRC}/MultiMC/bin
|
||||
local client_id_asm=$(objdump -j '.text' --no-show-raw-insn -C --disassemble='Secrets::getMSAClientID(unsigned char)' MultiMC)
|
||||
local client_id="$(grep -oP '[a-z0-9]{2}(?=,%r[89]d)' <<< ${client_id_asm} | tac | tr -d '\n')$(grep -oP '(push.+0x)\K[a-z0-9]{2}' <<< ${client_id_asm} | tac | tr -d '\n')"
|
||||
client_id="${client_id:0:8}-${client_id:8:4}-${client_id:12:4}-${client_id:16:4}-${client_id:20}"
|
||||
popd
|
||||
sed -i 's/""/"'"${client_id}"'"/g' notsecrets/Secrets.cpp
|
||||
|
||||
rmdir libraries/libnbtplusplus
|
||||
rmdir libraries/quazip
|
||||
ln -sfT $SRC/libnbtplusplus-dc72a20b7efd304d12af2025223fad07b4b78464/ libraries/libnbtplusplus
|
||||
ln -sfT $SRC/quazip-b1a72ac0bb5a732bf887a535ab75c6f9bedb6b6b/ libraries/quazip
|
||||
|
||||
export JAVA_HOME="/usr/lib/java/openjdk17-jdk/"
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
|
||||
cmake .. \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX="/usr" \
|
||||
-DLauncher_LAYOUT=lin-system \
|
||||
-DLauncher_APP_BINARY_NAME="${_pkgname}" \
|
||||
-DLauncher_SHARE_DEST_DIR="share/${_pkgname}" \
|
||||
-DLauncher_LIBRARAY_DEST_DIR="lib/${_pkgname}"
|
||||
|
||||
make
|
||||
make DESTDIR=$PKG install
|
||||
|
||||
mkdir -p "${PKG}/etc/ld.so.conf.d"
|
||||
echo -e "/usr/lib/${_pkgname}" > "${PKG}/etc/ld.so.conf.d/multimc5.conf"
|
||||
|
||||
|
||||
install -D $SRC/Launcher-$version/launcher/package/ubuntu/multimc/opt/multimc/icon.svg \
|
||||
$PKG/usr/share/pixmaps/multimc.svg
|
||||
|
||||
install -D $SRC/multimc.desktop \
|
||||
$PKG/usr/share/applications/multimc.desktop
|
||||
|
||||
# install -D $SRC/Launcher-$version/build/libMultiMC_quazip.so \
|
||||
# $PKG/usr/lib/libMultiMC_quazip.so
|
||||
|
||||
# install -D $SRC/Launcher-$version/build/libMultiMC_nbt++.so \
|
||||
# $PKG/usr/lib/libMultiMC_nbt++.so
|
||||
}
|
@ -1,15 +0,0 @@
|
||||
diff --git a/launcher/Application.cpp b/launcher/Application.cpp
|
||||
index 2d0c81bb..74f250fb 100644
|
||||
--- a/launcher/Application.cpp
|
||||
+++ b/launcher/Application.cpp
|
||||
@@ -524,6 +524,10 @@ Application::Application(int &argc, char **argv) : QApplication(argc, argv)
|
||||
FS::updateTimestamp(m_rootPath);
|
||||
#endif
|
||||
|
||||
+#ifdef MULTIMC_JARS_LOCATION
|
||||
+ m_jarsPath = TOSTRING(MULTIMC_JARS_LOCATION);
|
||||
+#endif
|
||||
+
|
||||
qDebug() << BuildConfig.LAUNCHER_DISPLAYNAME << ", (c) 2013-2021 " << BuildConfig.LAUNCHER_COPYRIGHT;
|
||||
qDebug() << "Version : " << BuildConfig.printableVersionString();
|
||||
qDebug() << "Git commit : " << BuildConfig.GIT_COMMIT;
|
@ -1,35 +0,0 @@
|
||||
diff --git a/launcher/resources/multimc/multimc.qrc b/launcher/resources/multimc/multimc.qrc
|
||||
index 5b36cb3d..f2322279 100644
|
||||
--- a/launcher/resources/multimc/multimc.qrc
|
||||
+++ b/launcher/resources/multimc/multimc.qrc
|
||||
@@ -282,6 +282,9 @@
|
||||
<file>32x32/instances/herobrine.png</file>
|
||||
<file>128x128/instances/herobrine.png</file>
|
||||
|
||||
+ <file>32x32/instances/infinity.png</file>
|
||||
+ <file>128x128/instances/infinity.png</file>
|
||||
+
|
||||
<file>32x32/instances/magitech.png</file>
|
||||
<file>128x128/instances/magitech.png</file>
|
||||
|
||||
diff --git a/notsecrets/CMakeLists.txt b/notsecrets/CMakeLists.txt
|
||||
index b5dd3cf8..3abd8002 100644
|
||||
--- a/notsecrets/CMakeLists.txt
|
||||
+++ b/notsecrets/CMakeLists.txt
|
||||
@@ -3,14 +3,14 @@ target_link_libraries(secrets Qt5::Core)
|
||||
target_compile_definitions(secrets PUBLIC -DEMBED_SECRETS)
|
||||
target_include_directories(secrets PUBLIC .)
|
||||
|
||||
-set(Launcher_CommonName "DevLauncher")
|
||||
+set(Launcher_CommonName "MultiMC")
|
||||
|
||||
set(Launcher_Copyright "MultiMC Contributors" PARENT_SCOPE)
|
||||
set(Launcher_Domain "multimc.org" PARENT_SCOPE)
|
||||
set(Launcher_Name "${Launcher_CommonName}" PARENT_SCOPE)
|
||||
set(Launcher_DisplayName "${Launcher_CommonName} 5" PARENT_SCOPE)
|
||||
set(Launcher_UserAgent "${Launcher_CommonName}/5.0" PARENT_SCOPE)
|
||||
-set(Launcher_ConfigFile "devlauncher.cfg" PARENT_SCOPE)
|
||||
+set(Launcher_ConfigFile "multimc.cfg" PARENT_SCOPE)
|
||||
set(Launcher_Git "https://github.com/MultiMC/Launcher" PARENT_SCOPE)
|
||||
|
||||
set(Launcher_Branding_ICNS "notsecrets/Launcher.icns" PARENT_SCOPE)
|
@ -1,12 +0,0 @@
|
||||
diff -r -U 0 a/libraries/javacheck/CMakeLists.txt b/libraries/javacheck/CMakeLists.txt
|
||||
--- a/libraries/javacheck/CMakeLists.txt 2019-08-05 00:46:59.000000000 +0200
|
||||
+++ b/libraries/javacheck/CMakeLists.txt 2019-09-27 21:47:16.033545671 +0200
|
||||
@@ -7 +7 @@
|
||||
-set(CMAKE_JAVA_COMPILE_FLAGS -target 1.6 -source 1.6 -Xlint:deprecation -Xlint:unchecked)
|
||||
+set(CMAKE_JAVA_COMPILE_FLAGS -target 8 -source 8 -Xlint:deprecation -Xlint:unchecked)
|
||||
diff -r -U 0 a/libraries/launcher/CMakeLists.txt b/libraries/launcher/CMakeLists.txt
|
||||
--- a/libraries/launcher/CMakeLists.txt 2019-08-05 00:46:59.000000000 +0200
|
||||
+++ b/libraries/launcher/CMakeLists.txt 2019-09-27 21:47:36.803357383 +0200
|
||||
@@ -7 +7 @@
|
||||
-set(CMAKE_JAVA_COMPILE_FLAGS -target 1.6 -source 1.6 -Xlint:deprecation -Xlint:unchecked)
|
||||
+set(CMAKE_JAVA_COMPILE_FLAGS -target 8 -source 8 -Xlint:deprecation -Xlint:unchecked)
|
@ -1,11 +0,0 @@
|
||||
[Desktop Entry]
|
||||
Version=1.0
|
||||
Name=MultiMC
|
||||
GenericName=Minecraft Launcher
|
||||
Comment=Free, open source launcher and instance manager for Minecraft.
|
||||
Type=Application
|
||||
Terminal=false
|
||||
Exec=multimc
|
||||
Icon=multimc
|
||||
Categories=Game
|
||||
Keywords=game;minecraft;
|
@ -1,33 +0,0 @@
|
||||
From 469b97b618314ec009a37cad22e9d2541d6481f7 Mon Sep 17 00:00:00 2001
|
||||
From: Sergey Shatunov <me@prok.pw>
|
||||
Date: Fri, 1 Jun 2018 21:07:13 +0700
|
||||
Subject: [PATCH] Fix build with Qt 5.11+
|
||||
|
||||
---
|
||||
CMakeLists.txt | 6 ++----
|
||||
1 file changed, 2 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 376583c..7c0c6eb 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -44,10 +44,9 @@ endif()
|
||||
|
||||
add_library(MultiMC_quazip SHARED ${QUAZIP_SRC})
|
||||
target_include_directories(MultiMC_quazip PUBLIC "quazip" "${CMAKE_CURRENT_BINARY_DIR}" PRIVATE ${ZLIB_INCLUDE_DIRS})
|
||||
-target_link_libraries(MultiMC_quazip ${ZLIB_LIBRARIES})
|
||||
+target_link_libraries(MultiMC_quazip Qt5::Core ${ZLIB_LIBRARIES})
|
||||
target_compile_definitions(MultiMC_quazip PRIVATE "-DQUAZIP_BUILD")
|
||||
set_target_properties(MultiMC_quazip PROPERTIES CXX_VISIBILITY_PRESET hidden VISIBILITY_INLINES_HIDDEN 1)
|
||||
-qt5_use_modules(MultiMC_quazip Core)
|
||||
|
||||
# Install it
|
||||
install(
|
||||
@@ -84,6 +83,5 @@ set(QUAZIP_TEST_SRC
|
||||
)
|
||||
|
||||
add_executable(MultiMC_quazip_test ${QUAZIP_TEST_SRC})
|
||||
-target_link_libraries(MultiMC_quazip_test MultiMC_quazip)
|
||||
-qt5_use_modules(MultiMC_quazip_test Network Test)
|
||||
+target_link_libraries(MultiMC_quazip_test MultiMC_quazip Qt5::Network Qt5::Test)
|
||||
add_test(NAME quazip_testsuite COMMAND MultiMC_quazip_test)
|
Loading…
x
Reference in New Issue
Block a user