python3-logbook: cherry-picked commit for python3-cython 3.0

This commit is contained in:
Tim Biermann 2023-07-23 17:05:09 +02:00
parent 3fca559361
commit 8885d3f8bd
3 changed files with 34 additions and 4 deletions

View File

@ -1,6 +1,7 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF3wSZaLuBb1u6o9LoV8RPJb5Kvg7419AD7x8aRDKJmNnu+Uu6uSrlqmYJJ0bwP1Qa5HFdBINcSXMtFmbtPDXrrgo=
SHA256 (Pkgfile) = 9434ea3dd6ce862c7bbe1f484b23096243824d804a345688586d486e78e812ae
RWSagIOpLGJF31iwZpqtQpmEVOpUqALZU3aGGTCeKEsw8TeFQmij5etj4/7/A3fFBG2qBoQaXETG/AgzzN5JuZchzt4f8uGzCg8=
SHA256 (Pkgfile) = 6b5bce5d5d51091a29365c38d20e11a9bd0e7ec5a82e4252d540ec50eef186c9
SHA256 (.footprint) = 96d50381486ec969bdd38e9412f4d92d4d10a646a04f8bc119d70828e799d7eb
SHA256 (python3-logbook-1.5.3.tar.gz) = d23a1d2b3dd094adcafb6c7e636f9b88782a6868538f96beb7b10534f9a16557
SHA256 (reproducibility.patch) = 251f9ee2b1302ee5e3690ee95e809e8eb40ab04471a5220bb91f36da7f2baa49
SHA256 (337.patch) = ed54aad21789431d42705662bba92403661d06a2c60feedb02755c0a96577643

25
python3-logbook/337.patch Normal file
View File

@ -0,0 +1,25 @@
From 9dd4e88323909bc33ff6f574b03351a0307ca0a4 Mon Sep 17 00:00:00 2001
From: Frazer McLean <frazer@frazermclean.co.uk>
Date: Sat, 22 Jul 2023 14:21:42 +0100
Subject: [PATCH] group_reflected_property had a __del__ method instead of
__delete__
This was found because Cython 3 complained about __del__ having the
wrong signature.
---
logbook/_speedups.pyx | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/logbook/_speedups.pyx b/logbook/_speedups.pyx
index b85961f..a4bb55a 100644
--- a/logbook/_speedups.pyx
+++ b/logbook/_speedups.pyx
@@ -62,7 +62,7 @@ cdef class group_reflected_property:
def __set__(self, obj, value):
setattr(obj, self._name, value)
- def __del__(self, obj):
+ def __delete__(self, obj):
delattr(obj, self._name)

View File

@ -5,13 +5,17 @@
name=python3-logbook
version=1.5.3
release=1
release=2
source=(https://github.com/mitsuhiko/logbook/archive/$version/$name-$version.tar.gz
reproducibility.patch)
reproducibility.patch
337.patch)
build() {
cd logbook-$version
patch -Np1 -i $SRC/reproducibility.patch
patch -Np1 -i $SRC/337.patch
/usr/bin/cython3 logbook/_speedups.pyx
/usr/bin/python3 setup.py build
/usr/bin/python3 setup.py install --prefix=/usr \