Merge branch '2.4' of crux:/home/crux/scm/ports/contrib into 2.4

This commit is contained in:
Alan Mizrahi 2008-05-16 11:41:41 -04:30
commit 88e8fa7eeb
15 changed files with 30 additions and 2697 deletions

View File

@ -6,6 +6,12 @@ drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/distcc
-rwxr-xr-x root/root usr/bin/distccd
-rwxr-xr-x root/root usr/bin/distccmon-text
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/lib/distcc/
lrwxrwxrwx root/root usr/lib/distcc/c++ -> ../../bin/distcc
lrwxrwxrwx root/root usr/lib/distcc/cc -> ../../bin/distcc
lrwxrwxrwx root/root usr/lib/distcc/g++ -> ../../bin/distcc
lrwxrwxrwx root/root usr/lib/distcc/gcc -> ../../bin/distcc
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man1/
-rw-r--r-- root/root usr/man/man1/distcc.1.gz

View File

@ -6,13 +6,13 @@
name=distcc
version=2.18.3
release=4
release=5
source=(http://distcc.samba.org/ftp/distcc/distcc-$version.tar.bz2 \
distcc-$version-install.patch distccd)
build() {
cd distcc-$version
patch -p 1 -i ../distcc-$version-install.patch
patch -p 1 -i $SRC/distcc-$version-install.patch
./configure \
--prefix=/usr \
@ -23,5 +23,10 @@ build() {
make
make DESTDIR=$PKG install-man install-programs
install -m 0755 -D ../distccd $PKG/etc/rc.d/distccd
install -d $PKG/usr/lib/distcc
for c in cc c++ gcc g++; do
cd $PKG/usr/lib/distcc && ln -s ../../bin/distcc $c
done
}

View File

@ -15,3 +15,5 @@ There's a service to simplify running distccd. By default, it uses allows connec
DISTCC_ALLOW=192.168.1.0/24
DISTCC_USER=otheruser
----
There is more information on the public wiki http://crux.nu/Public/HomePage

View File

@ -1,40 +0,0 @@
#!/usr/bin/env sh
DIRECTORY='/usr/lib/distcc'
SYMLINKS='cc c++ gcc g++'
unset NOT_INSTALLED
if [ ! -d "$DIRECTORY" ]; then
if [ -w '/usr/lib' ]; then
install -d "$DIRECTORY"
if [ $? -gt 0 ]; then
echo "post-install: error creating '$DIRECTORY'."
else
echo "post-install: '$DIRECTORY' created."
fi
cd "$DIRECTORY"
for c in $SYMLINKS; do
if [ ! -e "$DIRECTORY/$c" ]; then
NOT_INSTALLED='yes'
fi
done
if [ "$NOT_INSTALLED" ]; then
echo "post-install: in directory '$DIRECTORY'."
fi
for c in $SYMLINKS; do
if [ ! -e "$DIRECTORY/$c" ]; then
ln -s '../../bin/distcc' "$c"
if [ $? -gt 0 ]; then
echo "post-install: error creating symlink '../../bin/distcc -> $c'."
exit 1
else
echo "post-install: create symlink '../../bin/distcc -> $c'."
fi
fi
done
cd - > /dev/null
else
echo "post-install: error no permission to create directory '$DIRECTORY'."
exit 1
fi
fi
unset NOT_INSTALLED SYMLINKS DIRECTORY
# End of file

View File

@ -1,16 +0,0 @@
#!/usr/bin/env sh
DIRECTORY='/usr/lib/distcc'
if [ -d "$DIRECTORY" ]; then
if [ -w "$DIRECTORY" ]; then
rm -r "$DIRECTORY"
if [ $? -gt 0 ]; then
echo "post-remove: error remove '$DIRECTORY' failed."
else
echo "post-remove: '$DIRECTORY' removed."
fi
else
echo "post-remove: error no permission to remove '$DIRECTORY'."
fi
fi
unset DIRECTORY
# End of file

View File

@ -1,5 +1,6 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/hashdeep
-rwxr-xr-x root/root usr/bin/md5deep
-rwxr-xr-x root/root usr/bin/sha1deep
-rwxr-xr-x root/root usr/bin/sha256deep
@ -7,6 +8,7 @@ drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/whirlpooldeep
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man1/
-rw-r--r-- root/root usr/man/man1/hashdeep.1.gz
-rw-r--r-- root/root usr/man/man1/md5deep.1.gz
-rw-r--r-- root/root usr/man/man1/sha1deep.1.gz
-rw-r--r-- root/root usr/man/man1/sha256deep.1.gz

View File

@ -1 +1 @@
c250d966ff3bf6594a16410b63429af1 md5deep-2.0.1-001.tar.gz
f491729d91632a816a7a4a8dba58b3ca md5deep-3.0.tar.gz

View File

@ -4,14 +4,14 @@
# Maintainer: Brett Goulder, predatorfreak at dcaf-security dot org.
name=md5deep
version=2.0.1
version=3.0
release=1
source=(http://dl.sourceforge.net/${name}/${name}-${version}-001.tar.gz)
source=(http://dl.sourceforge.net/${name}/${name}-${version}.tar.gz)
build() {
cd ${SRC}/$name-$version-001
./configure --prefix=/usr
make || return 1
# make BIN=${PKG}/usr/bin MAN=${PKG}/usr/man/man/man1 install
cd ${SRC}/$name-$version
./configure --prefix=/usr \
--mandir=/usr/man
make
make DESTDIR=$PKG install
}

View File

@ -1 +1 @@
0836c4fad0b8da784ef2ddd7a54e84b4 mkvtoolnix-2.1.0.tar.bz2
57397800c6be11db0b62e7285c8dab82 mkvtoolnix-2.2.0.tar.bz2

View File

@ -1,13 +1,13 @@
# Description: tools to create, alter and inspect Matroska files
# URL: http://www.matroska.org/
# Description: Tools to create, alter and inspect Matroska files
# URL: http://www.bunkus.org/videotools/mkvtoolnix
# Maintainer: Brett Goulder, predatorfreak at dcaf-security dot org.
# Packager: Han Boetes <han@mijncomputer.nl>
# Packager: Han Boetes, han at mijncomputer dot nl.
# Depends on: libmatroska
name=mkvtoolnix
version=2.1.0
version=2.2.0
release=1
source="http://www.bunkus.org/videotools/mkvtoolnix/sources/mkvtoolnix-$version.tar.bz2"
source=(http://www.bunkus.org/videotools/mkvtoolnix/sources/$name-$version.tar.bz2)
build()
{

File diff suppressed because it is too large Load Diff

View File

@ -1,2 +0,0 @@
03ee0deb73908c84a7b4d9ceb5f8b3f6 qt-x11-opensource-src-4.4.0.tar.bz2
a65eb8658114698eaaaa7a4c44443669 qt4-4.4.0-x11-path-fix.patch

View File

@ -1,106 +0,0 @@
# Description: Qt4 Free Edition.
# URL: http://trolltech.com/
# Packager: Johannes Winkelmann, jw at tks6 dot net
# Maintainer: Danny Rawlins, monster dot romster at gmail dot com
# Depends on: dbus freetype glib libmng libpng openssl xorg-libsm xorg-libxcursor xorg-libxinerama xorg-setxkbmap fontconfig xorg-libxi xorg-libxrandr
# Optional: mysql sqlite3 nvidia gtk
name=qt4
version=4.4.0
release=1
source=(ftp://ftp.trolltech.com/pub/qt/source/qt-x11-opensource-src-$version.tar.bz2 \
qt4-$version-x11-path-fix.patch)
mirror=(ftp://ftp.tu-chemnitz.de/pub/Qt/qt/source/qt-x11-opensource-src-$version.tar.gz)
build() {
local file SQL
cd qt-x11-opensource-src-$version
patch -p1 -i $SRC/qt4-$version-x11-path-fix.patch
# don't use distcc as it wont compile but use ccache if installed
if pkginfo -i |grep '^distcc ' > /dev/null; then
if pkginfo -i |grep '^ccache ' > /dev/null; then
if [ $CCACHE_PREFIX = distcc ]; then
unset CCACHE_PREFIX
fi
else
export PATH="`echo $PATH |sed -e 's|/usr/lib/distcc:||'`"
fi
fi
if [ "`pkginfo -i |grep '^mysql '`" ]; then
SQL='-qt-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql'
fi
if [ -d /usr/include/nvidia ]; then
export CFLAGS="$CFLAGS -I/usr/include/nvidia"
export CXXFLAGS="$CXXFLAGS -I/usr/include/nvidia"
fi
# don't link against our currently installed libraries
export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:`pwd`/lib"
# we don't want docs, sample code; please use our optimization flags
sed -i mkspecs/common/g++.conf -e "s|-O2|$CXXFLAGS|"
sed -i qmake/Makefile.unix -e "s|-I. |$CXXFLAGS -I. |"
sed -i configure -e 's|read acceptance|acceptance=yes|'
./configure \
-prefix /usr/share/qt4 \
-bindir /usr/share/qt4/bin \
-headerdir /usr/include/qt4 \
-libdir /usr/lib \
-plugindir /usr/lib/qt4 \
-platform linux-g++ -release -shared -sm \
-tablet -nis -verbose -qt-gif -system-zlib \
-system-lib{png,jpeg} \
-no-{cups,fast,exceptions,nas-sound} \
-x{cursor,inerama,kb,randr,render} \
-nomake demos -nomake examples \
$SQL
make
make INSTALL_ROOT=$PKG install_subtargets install_qmake
# install mkspecs without having to delete more junk than it's worth using make install
install -d $PKG/usr/share/qt4/mkspecs
mv mkspecs/{linux-g++{,-32,-64},common,features} $PKG/usr/share/qt4/mkspecs/
ln -s linux-g++ $PKG/usr/share/qt4/mkspecs/default
# remove junk
rm $PKG/usr/share/qt4/mkspecs/common/mac{,-g++}.conf
find $PKG -name '*.debug' -exec rm {} \;
rm -r \
$PKG/usr/share/qt4/phrasebooks \
$PKG/usr/share/qt4/mkspecs/features/{win32,mac}
# symlinks for qt4
ln -s ../../include/qt4 $PKG/usr/share/qt4/include
ln -s ../../lib $PKG/usr/share/qt4/lib
ln -s ../../lib/qt $PKG/usr/share/qt4/plugins
# fix paths
sed -i $PKG/usr/lib/*.prl -e "s|-L$SRC/qt-x11-opensource-src-$version/lib ||g"
sed -i $PKG/usr/lib/pkgconfig/*.pc \
-e "s|-L$SRC/qt-x11-opensource-src-$version/lib ||g" \
-e "s|$SRC/qt-x11-opensource-src-$version/bin|/usr/share/qt4/bin|g"
# add symlinks for qt4 in /usr/bin
install -d $PKG/usr/bin
pushd $PKG/usr/bin
for file in assistant designer linguist lrelease lupdate moc qmake qtconfig uic; do
ln -s ../share/qt4/bin/$file $file-qt4
done
for file in pixeltool qdbus qdbuscpp2xml qdbusxml2cpp qt3to4 rcc uic3; do
ln -s ../share/qt4/bin/$file $file
done
popd
}

View File

@ -1,3 +0,0 @@
README for qt4
This port of Qt4 will happily coexist with Qt3

View File

@ -1,53 +0,0 @@
diff -pruN qt-x11-opensource-src-4.3.2.orig/mkspecs/common/linux.conf qt-x11-opensource-src-4.3.2/mkspecs/common/linux.conf
--- qt-x11-opensource-src-4.3.2.orig/mkspecs/common/linux.conf 2008-01-29 17:57:54.387185584 +1100
+++ qt-x11-opensource-src-4.3.2/mkspecs/common/linux.conf 2008-01-29 18:00:28.979683952 +1100
@@ -7,12 +7,12 @@ QMAKE_CXXFLAGS_THREAD += $$QMAKE_CFLAGS_
QMAKE_INCDIR =
QMAKE_LIBDIR =
-QMAKE_INCDIR_X11 = /usr/X11R6/include
-QMAKE_LIBDIR_X11 = /usr/X11R6/lib
+QMAKE_INCDIR_X11 = /usr/X11/include
+QMAKE_LIBDIR_X11 = /usr/X11/lib
QMAKE_INCDIR_QT = $$[QT_INSTALL_HEADERS]
QMAKE_LIBDIR_QT = $$[QT_INSTALL_LIBS]
-QMAKE_INCDIR_OPENGL = /usr/X11R6/include
-QMAKE_LIBDIR_OPENGL = /usr/X11R6/lib
+QMAKE_INCDIR_OPENGL = /usr/X11/include
+QMAKE_LIBDIR_OPENGL = /usr/X11/lib
QMAKE_LIBS =
QMAKE_LIBS_DYNLOAD = -ldl
diff -pruN qt-x11-opensource-src-4.3.2.orig/mkspecs/linux-cxx/qmake.conf qt-x11-opensource-src-4.3.2/mkspecs/linux-cxx/qmake.conf
--- qt-x11-opensource-src-4.3.2.orig/mkspecs/linux-cxx/qmake.conf 2008-01-29 17:57:54.353190752 +1100
+++ qt-x11-opensource-src-4.3.2/mkspecs/linux-cxx/qmake.conf 2008-01-29 18:00:21.716788080 +1100
@@ -37,12 +37,12 @@ QMAKE_CXXFLAGS_YACC = $$QMAKE_CFLAGS_YAC
QMAKE_INCDIR =
QMAKE_LIBDIR =
-QMAKE_INCDIR_X11 = /usr/X11R6/include
-QMAKE_LIBDIR_X11 = /usr/X11R6/lib
+QMAKE_INCDIR_X11 = /usr/X11/include
+QMAKE_LIBDIR_X11 = /usr/X11/lib
QMAKE_INCDIR_QT = $$[QT_INSTALL_HEADERS]
QMAKE_LIBDIR_QT = $$[QT_INSTALL_LIBS]
-QMAKE_INCDIR_OPENGL = /usr/X11R6/include
-QMAKE_LIBDIR_OPENGL = /usr/X11R6/lib
+QMAKE_INCDIR_OPENGL = /usr/X11/include
+QMAKE_LIBDIR_OPENGL = /usr/X11/lib
QMAKE_LINK = cxx
QMAKE_LINK_SHLIB = cxx
diff -pruN qt-x11-opensource-src-4.3.2.orig/mkspecs/linux-g++-64/qmake.conf qt-x11-opensource-src-4.3.2/mkspecs/linux-g++-64/qmake.conf
--- qt-x11-opensource-src-4.3.2.orig/mkspecs/linux-g++-64/qmake.conf 2008-01-29 17:57:54.358189992 +1100
+++ qt-x11-opensource-src-4.3.2/mkspecs/linux-g++-64/qmake.conf 2008-01-29 18:00:21.716788080 +1100
@@ -17,7 +17,7 @@ QMAKE_LFLAGS = -m64
include(../common/g++.conf)
include(../common/linux.conf)
-QMAKE_LIBDIR_X11 = /usr/X11R6/lib64
-QMAKE_LIBDIR_OPENGL = /usr/X11R6/lib64
+QMAKE_LIBDIR_X11 = /usr/X11/lib64
+QMAKE_LIBDIR_OPENGL = /usr/X11/lib64
load(qt_config)