clementine: fix compile error
This commit is contained in:
parent
8eeff4738c
commit
8c1b2d60f0
@ -1 +1,2 @@
|
|||||||
725b92ad4699de1b2ffdf48fe01ed092 1.2.3.tar.gz
|
725b92ad4699de1b2ffdf48fe01ed092 1.2.3.tar.gz
|
||||||
|
2384a994ecce0823a2bf57a9a5a5bd8b udisks-namespace.patch
|
||||||
|
@ -6,11 +6,15 @@
|
|||||||
|
|
||||||
name=clementine
|
name=clementine
|
||||||
version=1.2.3
|
version=1.2.3
|
||||||
release=1
|
release=2
|
||||||
source=(https://github.com/clementine-player/Clementine/archive/$version.tar.gz)
|
source=(https://github.com/clementine-player/Clementine/archive/$version.tar.gz
|
||||||
|
udisks-namespace.patch)
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd Clementine-$version
|
cd Clementine-$version
|
||||||
|
|
||||||
|
patch -p1 -i $SRC/udisks-namespace.patch
|
||||||
|
|
||||||
cmake -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_WERROR=OFF
|
cmake -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_WERROR=OFF
|
||||||
make
|
make
|
||||||
make DESTDIR=$PKG install
|
make DESTDIR=$PKG install
|
||||||
|
38
clementine/udisks-namespace.patch
Normal file
38
clementine/udisks-namespace.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
From ec580cb815c16ec1ab43a469d5af7d51d8d03082 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Chocobozzz <florian.chocobo@gmail.com>
|
||||||
|
Date: Wed, 16 Jul 2014 15:57:25 +0200
|
||||||
|
Subject: [PATCH] No namespaces for DBus interfaces. Fixes #4401
|
||||||
|
|
||||||
|
---
|
||||||
|
src/CMakeLists.txt | 9 ++++-----
|
||||||
|
1 file changed, 4 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
||||||
|
index 650fa74..775b0a5 100644
|
||||||
|
--- a/src/CMakeLists.txt
|
||||||
|
+++ b/src/CMakeLists.txt
|
||||||
|
@@ -892,11 +892,6 @@ optional_source(LINUX SOURCES widgets/osd_x11.cpp)
|
||||||
|
if(HAVE_DBUS)
|
||||||
|
file(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/dbus)
|
||||||
|
|
||||||
|
- # Hack to get it to generate interfaces without namespaces - required
|
||||||
|
- # because otherwise org::freedesktop::UDisks and
|
||||||
|
- # org::freedesktop::UDisks::Device conflict.
|
||||||
|
- list(APPEND QT_DBUSXML2CPP_EXECUTABLE -N)
|
||||||
|
-
|
||||||
|
# MPRIS DBUS interfaces
|
||||||
|
qt4_add_dbus_adaptor(SOURCES
|
||||||
|
dbus/org.freedesktop.MediaPlayer.player.xml
|
||||||
|
@@ -964,6 +959,10 @@ if(HAVE_DBUS)
|
||||||
|
|
||||||
|
# DeviceKit DBUS interfaces
|
||||||
|
if(HAVE_DEVICEKIT)
|
||||||
|
+ set_source_files_properties(dbus/org.freedesktop.UDisks.xml
|
||||||
|
+ PROPERTIES NO_NAMESPACE dbus/udisks)
|
||||||
|
+ set_source_files_properties(dbus/org.freedesktop.UDisks.Device.xml
|
||||||
|
+ PROPERTIES NO_NAMESPACE dbus/udisksdevice)
|
||||||
|
qt4_add_dbus_interface(SOURCES
|
||||||
|
dbus/org.freedesktop.UDisks.xml
|
||||||
|
dbus/udisks)
|
||||||
|
--
|
||||||
|
2.0.3
|
Loading…
x
Reference in New Issue
Block a user