atanks: 3.2 -> 3.5

This commit is contained in:
Danny Rawlins 2009-03-22 21:25:21 +11:00
parent 76823e1b65
commit 8d15415ffe
4 changed files with 57 additions and 10 deletions

View File

@ -18,12 +18,19 @@ drwxr-xr-x root/root usr/share/atanks/
-rw-r--r-- root/root usr/share/atanks/instr.txt
-rw-r--r-- root/root usr/share/atanks/instr_de.txt
-rw-r--r-- root/root usr/share/atanks/instr_fr.txt
-rw-r--r-- root/root usr/share/atanks/instr_sk.txt
-rw-r--r-- root/root usr/share/atanks/kamikaze.pt_BR.txt
-rw-r--r-- root/root usr/share/atanks/kamikaze.txt
-rw-r--r-- root/root usr/share/atanks/kamikaze_de.txt
-rw-r--r-- root/root usr/share/atanks/kamikaze_fr.txt
-rw-r--r-- root/root usr/share/atanks/kamikaze_sk.txt
-rw-r--r-- root/root usr/share/atanks/misc.dat
-rw-r--r-- root/root usr/share/atanks/missile.dat
-rw-r--r-- root/root usr/share/atanks/retaliation.pt_BR.txt
-rw-r--r-- root/root usr/share/atanks/retaliation.txt
-rw-r--r-- root/root usr/share/atanks/retaliation_de.txt
-rw-r--r-- root/root usr/share/atanks/retaliation_fr.txt
-rw-r--r-- root/root usr/share/atanks/retaliation_sk.txt
-rw-r--r-- root/root usr/share/atanks/revenge.pt_BR.txt
-rw-r--r-- root/root usr/share/atanks/revenge.txt
-rw-r--r-- root/root usr/share/atanks/revenge_de.txt
@ -39,6 +46,10 @@ drwxr-xr-x root/root usr/share/atanks/
-rw-r--r-- root/root usr/share/atanks/tank.dat
-rw-r--r-- root/root usr/share/atanks/tankgun.dat
-rw-r--r-- root/root usr/share/atanks/title.dat
-rw-r--r-- root/root usr/share/atanks/weapons.pt_BR.txt
-rw-r--r-- root/root usr/share/atanks/weapons.txt
-rw-r--r-- root/root usr/share/atanks/weapons_de.txt
-rw-r--r-- root/root usr/share/atanks/weapons_fr.txt
-rw-r--r-- root/root usr/share/atanks/weapons_sk.txt
drwxr-xr-x root/root usr/share/pixmaps/
-rw-r--r-- root/root usr/share/pixmaps/atanks.png

View File

@ -1,3 +1,2 @@
8bc373f835bc325e86b978d635d5adc9 atanks-3.1-install.patch
6f3d0920f2ea74419bd3339b07855de8 atanks-3.2-version-fix.patch
bb1c47c04b157b1abc8033ca11975b1c atanks-3.2.tar.gz
22d442513d56ecdc3a0b785460545f8d atanks-3.5-install.patch
2817a43b17f0d2510979fffefaa36f50 atanks-3.5.tar.gz

View File

@ -5,17 +5,14 @@
# Depends on: allegro
name=atanks
version=3.2
version=3.5
release=1
source=(http://dl.sourceforge.net/sourceforge/$name/$name-$version.tar.gz
$name-3.1-install.patch
$name-3.2-version-fix.patch)
$name-3.5-install.patch)
build() {
cd $name
patch -p 1 -i $SRC/$name-3.1-install.patch
patch -p 1 -i $SRC/$name-3.2-version-fix.patch
cd sed/PrydeWorX/$name-$version
patch -p 1 -i $SRC/$name-3.5-install.patch
make
make DESTDIR=$PKG install
}

View File

@ -0,0 +1,40 @@
diff -pruN atanks-3.5.orig/Makefile atanks-3.5/Makefile
--- atanks-3.5.orig/Makefile 2009-03-22 10:17:05.981639742 +0000
+++ atanks-3.5/Makefile 2009-03-22 10:19:28.861598138 +0000
@@ -4,17 +4,19 @@ BINPREFIX = $(PREFIX)games/bin/
export VERSION
export PREFIX
FILENAME=atanks-${VERSION}
-INSTALL=$(PREFIX)bin/install -c
+INSTALL=$(PREFIX)bin/install
DISTCOMMON=atanks/*.dat atanks/COPYING atanks/README atanks/TODO atanks/Changelog atanks/BUGS atanks/*.txt
-INCOMMON=*.dat COPYING README TODO Changelog *.txt
+INCOMMON=*.dat *.txt
all:
$(MAKE) -C src
install: all
- $(INSTALL) -g 0 -m 755 -o 0 atanks ${BINPREFIX}bin
- mkdir -p ${PREFIX}share/games/atanks
- $(INSTALL) -g 0 -m 644 -o 0 $(INCOMMON) ${PREFIX}share/games/atanks
+ $(INSTALL) -d $(DESTDIR)/usr/share/atanks
+ $(INSTALL) -m 0644 -t $(DESTDIR)/usr/share/atanks $(INCOMMON)
+ $(INSTALL) -m 0755 -D atanks $(DESTDIR)/usr/bin/atanks
+ $(INSTALL) -m 0644 -D atanks.desktop $(DESTDIR)/usr/share/applications/atanks.desktop
+ $(INSTALL) -m 0644 -D atanks.png $(DESTDIR)/usr/share/pixmaps/atanks.png
clean:
rm -f atanks
$(MAKE) -C src clean
diff -pruN atanks-3.5.orig/src/Makefile atanks-3.5/src/Makefile
--- atanks-3.5.orig/src/Makefile 2009-03-22 10:17:05.986639745 +0000
+++ atanks-3.5/src/Makefile 2009-03-22 10:20:56.244524779 +0000
@@ -9,7 +9,7 @@ LD=g++
LIB=ar
WINDRES=
-FLAGS = -DLINUX -DDATA_DIR=\".\"
+FLAGS = -DLINUX -DDATA_DIR=\"/usr/share/atanks\"
OUTPUT = ../atanks
WFLAGS =
OFLAGS =