kvm: updated to 33

This commit is contained in:
Mikhail Kolesnik 2007-07-24 16:17:22 +03:00
parent 54c48cfb70
commit 8daa43f78b
5 changed files with 15 additions and 14 deletions

View File

@ -7,8 +7,9 @@ drwxr-xr-x root/root lib/modules/<kernel-version>/extra/
-rw-r--r-- root/root lib/modules/<kernel-version>/extra/kvm.ko -rw-r--r-- root/root lib/modules/<kernel-version>/extra/kvm.ko
drwxr-xr-x root/root usr/ drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/ drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/qemu lrwxrwxrwx root/root usr/bin/qemu -> /usr/bin/qemu-system-x86_64
-rwxr-xr-x root/root usr/bin/qemu-img -rwxr-xr-x root/root usr/bin/qemu-img
-rwxr-xr-x root/root usr/bin/qemu-system-x86_64
drwxr-xr-x root/root usr/include/ drwxr-xr-x root/root usr/include/
-rwxr-xr-x root/root usr/include/kvmctl.h -rwxr-xr-x root/root usr/include/kvmctl.h
drwxr-xr-x root/root usr/include/linux/ drwxr-xr-x root/root usr/include/linux/

View File

@ -1,2 +1,2 @@
0344ca089d2720042a6b23986b8fc81c kvm-28.tar.gz aafb33231101cbb6a8533baf781345bd kvm-33.tar.gz
62b1748a3a18ad60cf27911af5127ad0 kvm-depmod.diff b695f1cb3c753903839a79ae0dc0b0e7 kvm-depmod.diff

View File

@ -4,10 +4,10 @@
# Depends on: gcc34 # Depends on: gcc34
name=kvm name=kvm
version=28 version=33
release=1 release=1
source=(http://dl.sourceforge.net/sourceforge/$name/$name-$version.tar.gz source=(http://dl.sourceforge.net/sourceforge/$name/$name-$version.tar.gz
$name-depmod.diff) $name-depmod.diff)
build () { build () {
cd $name-$version cd $name-$version
@ -15,4 +15,5 @@ build () {
./configure --prefix=/usr ./configure --prefix=/usr
make make
make DESTDIR=$PKG install make DESTDIR=$PKG install
ln -s /usr/bin/qemu-system-x86_64 $PKG/usr/bin/qemu
} }

View File

@ -13,5 +13,5 @@ Update modules dependencies:
RESOURCES RESOURCES
PRECAUTION PRECAUTION
This port installs kvm binary as /usr/bin/qemu. This would give a file This port installs symbolik link to kvm binary as /usr/bin/qemu. This would give a file
conflict with (at least) opt/qemu-bin. conflict with (at least) opt/qemu-bin.

View File

@ -1,12 +1,11 @@
diff -Nru kvm-20-orig/kernel/Makefile kvm-20/kernel/Makefile diff -Nru kvm-31-orig/kernel/Makefile kvm-31/kernel/Makefile
--- kvm-20-orig/kernel/Makefile 2007-04-25 14:34:35.000000000 +0300 --- kvm-31-orig/kernel/Makefile 2007-07-19 17:43:11.000000000 +0300
+++ kvm-20/kernel/Makefile 2007-04-25 14:40:45.000000000 +0300 +++ kvm-31/kernel/Makefile 2007-07-24 15:46:52.467788741 +0300
@@ -33,7 +33,7 @@ @@ -44,7 +44,6 @@
install: for i in $(ORIGMODDIR)/drivers/kvm/*.ko; do \
mkdir -p $(DESTDIR)/$(INSTALLDIR) if [ -f "$$i" ]; then mv "$$i" "$$i.orig"; fi; \
cp *.ko $(DESTDIR)/$(INSTALLDIR) done
- /sbin/depmod -a - /sbin/depmod -a
+#/sbin/depmod -a
tmpspec = .tmp.kvm-kmod.spec tmpspec = .tmp.kvm-kmod.spec
RPMDIR = $$(pwd)/../RPMS RPMDIR = $$(pwd)/../RPMS