gtkspell: ->

This commit is contained in:
Danny Rawlins 2018-01-31 22:38:54 +11:00
parent 0ec04fb6c2
commit 9241ec9def
4 changed files with 33 additions and 11 deletions

View File

@ -1,2 +1,2 @@
08bc50960521fca03383285b4d781239 enchant-2.patch
dd61ece853fcd3aae1d5cd7dc4a90f8c enchant-2.patch
f75dcc9338f182c571b321d37c606a94 gtkspell-2.0.16.tar.gz

View File

@ -1,6 +1,6 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF39nt/RuN7NRGmwGuprgmyTm2+TJ8fxn51YT5Jk8CO5kz9+qlP/3IB+dEveym/plFgeq0QEx+wAHPz/gkmuNdiAc=
SHA256 (Pkgfile) = 9c774bce1d1705a8beb01de108c57993ba58c881d86f23fe46cd32807c61d1a0
RWSagIOpLGJF30asxk79FfiMjxjyEZJALWJea2xuFJuvxrEH/r1sCCJeHrwAK4COIFSW++c9ApraErjHhm0RvGfovI9g0Vntfw4=
SHA256 (Pkgfile) = ff246c90fab82c3f09cefa0e9300ecd688cd92e84db7e07fdeaefdd2e92210b9
SHA256 (.footprint) = 05ecfb3dce58d3587abbd43ed2027c15abb23789f52892c465af466cd2e5c46e
SHA256 (gtkspell-2.0.16.tar.gz) = 8fc7dc560167b2cb7193e76aca625a152dc19b0ebf49816b78539cbb90d80d02
SHA256 (enchant-2.patch) = edeecf8e1cb9c524fdf800026c2b9c91c60faba637185302167909dd234453e9
SHA256 (enchant-2.patch) = 52e693590161bc285ec46a2beece802f47c7ede65ec0b72ffa224ab0db176bad

View File

@ -1,18 +1,22 @@
# Description: Spell checking utility for GTK+ applications.
# URL: https://gtkspell.sourceforge.net/
# Maintainer: Danny Rawlins, crux at romster dot me
# Packager: Brett Goulder, predatorfreak at dcaf-security dot org
# Depends on: aspell-en enchant gtk xorg-libxdamage
# Depends on: aspell-en enchant gtk gtk-doc xorg-libxdamage
name=gtkspell
version=2.0.16
release=2
release=3
source=(https://downloads.sourceforge.net/project/$name/$version/$name-$version.tar.gz
enchant-2.patch)
build() {
cd $name-$version
patch -p1 -i $SRC/enchant-2.patch
gtkdocize
autoreconf -fvi
rm -f $SRC/po/*.{po,gmo}
sed -i \
@ -21,9 +25,8 @@ build() {
sed -i -e 's/SUBDIRS = gtkspell examples docs po/SUBDIRS = gtkspell examples po/' Makefile.in
patch -p1 -i $SRC/enchant-2.patch
./configure --prefix=/usr
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
make DESTDIR=$PKG install
}

View File

@ -1,5 +1,24 @@
--- gtkspell-2.0.16/gtkspell/gtkspell.c.orig 2009-10-09 19:01:47.000000000 +0000
+++ gtkspell-2.0.16/gtkspell/gtkspell.c 2017-11-22 12:02:07.638601094 +0000
diff -u -r gtkspell-2.0.16/configure.ac gtkspell-2.0.16-enchant2/configure.ac
--- gtkspell-2.0.16/configure.ac 2009-10-23 04:52:31.000000000 +0200
+++ gtkspell-2.0.16-enchant2/configure.ac 2018-01-18 12:42:06.366410232 +0100
@@ -12,12 +12,12 @@
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
AC_CONFIG_HEADERS([config.h])
-SPELLER_LIB=-lenchant
+SPELLER_LIB=-lenchant-2
AC_SUBST(SPELLER_LIB)
GTKSPELL_PACKAGES=gtk+-2.0
AC_SUBST(GTKSPELL_PACKAGES)
-PKG_CHECK_MODULES(GTKSPELL, $GTKSPELL_PACKAGES enchant >= 0.4.0 )
+PKG_CHECK_MODULES(GTKSPELL, $GTKSPELL_PACKAGES enchant-2 >= 2.2.0 )
AC_SUBST(GTKSPELL_CFLAGS)
AC_SUBST(GTKSPELL_LIBS)
diff -u -r gtkspell-2.0.16/gtkspell/gtkspell.c gtkspell-2.0.16-enchant2/gtkspell/gtkspell.c
--- gtkspell-2.0.16/gtkspell/gtkspell.c 2009-10-09 21:01:47.000000000 +0200
+++ gtkspell-2.0.16-enchant2/gtkspell/gtkspell.c 2018-01-18 12:41:37.146338802 +0100
@@ -277,7 +277,7 @@
get_word_extents_from_mark(spell->buffer, &start, &end, spell->mark_click);
word = gtk_text_buffer_get_text(spell->buffer, &start, &end, FALSE);