rasqal: pulled patches from libreoffice

This commit is contained in:
Tim Biermann 2023-01-28 15:19:39 +01:00
parent 20ccc84558
commit 93f962cb98
Signed by: tb
GPG Key ID: 42F8B4E30B673606
8 changed files with 117 additions and 10 deletions

View File

@ -1,22 +1,20 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/rasqal-config
-rwxr-xr-x root/root usr/bin/roqet
drwxr-xr-x root/root usr/include/
drwxr-xr-x root/root usr/include/rasqal/
-rw-r--r-- root/root usr/include/rasqal/rasqal.h
drwxr-xr-x root/root usr/lib/
lrwxrwxrwx root/root usr/lib/librasqal-lo.so.3 -> librasqal-lo.so.3.0.0
-rwxr-xr-x root/root usr/lib/librasqal-lo.so.3.0.0
-rw-r--r-- root/root usr/lib/librasqal.a
-rwxr-xr-x root/root usr/lib/librasqal.la
lrwxrwxrwx root/root usr/lib/librasqal.so -> librasqal.so.3.0.0
lrwxrwxrwx root/root usr/lib/librasqal.so.3 -> librasqal.so.3.0.0
-rwxr-xr-x root/root usr/lib/librasqal.so.3.0.0
lrwxrwxrwx root/root usr/lib/librasqal.so -> librasqal-lo.so.3.0.0
drwxr-xr-x root/root usr/lib/pkgconfig/
-rw-r--r-- root/root usr/lib/pkgconfig/rasqal.pc
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/man/
drwxr-xr-x root/root usr/share/man/man1/
-rw-r--r-- root/root usr/share/man/man1/rasqal-config.1.gz
-rw-r--r-- root/root usr/share/man/man1/roqet.1.gz
drwxr-xr-x root/root usr/share/man/man3/
-rw-r--r-- root/root usr/share/man/man3/librasqal.3.gz

View File

@ -1,5 +1,10 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF3wTS1bQVYRl+5M5K1VqvrffqvybTcq7MZN6lQXTBclNjJrqk68Co79Kimwxr186esXJ4Lm1xqWm+iyC8tg93sQg=
SHA256 (Pkgfile) = 712c8285cc7be90475602cc817e5a4662d2f529c12b7e2d8646f3cf212c96320
SHA256 (.footprint) = dadbb856226835ee48f72a8dde14b13c1076ada2ac112dfa742f9c46d9b3023d
RWSagIOpLGJF38FVLqXQzTcFHtUo6MGNKfQd1I0nQgePHzRC0asu5JREH3L0gAVD0v/uyhFUngIaVQcasyG/tyAiKeAe2n0f5Aw=
SHA256 (Pkgfile) = c1932c5262f3fab5f611072edcbb1fd5ae5f7808dcc205bcc43d20bd214cfa46
SHA256 (.footprint) = ec47b218f0058c44f9a9184ce0bf161f7a69d2c922dee3282324e3178f93e395
SHA256 (rasqal-0.9.33.tar.gz) = 6924c9ac6570bd241a9669f83b467c728a322470bf34f4b2da4f69492ccfd97c
SHA256 (libtool.patch) = 6234df68001f6b8df208f1c8604a5521515396dfc9da6a554e8bfacf8b4b002b
SHA256 (rasqal-bundled-soname.patch.1) = cd0a1cb8c59c269aef4440c3a3dc9377aca42a96d641d1debdc08108d6b79452
SHA256 (rasqal-pkgconfig.patch.1) = 32bec67772c9cfa157ae00491a04300a40f8ff98a8ac1624a312daa3373564fb
SHA256 (rasqal-xcompile.patch.1) = 96efd4610d1a369a950bc84e0da7bb593466a838df1271082f143f0b951be5d3
SHA256 (rpath.patch) = 6e65e8a2ef126bd5a1321164f28d02c0fe45464bc6ea8b66b7419206d66d2ce1

View File

@ -5,14 +5,27 @@
name=rasqal
version=0.9.33
release=2
source=(http://download.librdf.org/source/$name-$version.tar.gz)
release=3
source=(http://download.librdf.org/source/$name-$version.tar.gz
libtool.patch
rasqal-bundled-soname.patch.1
rasqal-pkgconfig.patch.1
rasqal-xcompile.patch.1
rpath.patch)
build() {
cd $name-$version
patch -Np0 -i $SRC/libtool.patch
patch -Np1 -i $SRC/rasqal-bundled-soname.patch.1
patch -Np1 -i $SRC/rasqal-pkgconfig.patch.1
patch -Np1 -i $SRC/rasqal-xcompile.patch.1
patch -Np0 -i $SRC/rpath.patch
./configure --prefix=/usr \
--enable-release
make
make DESTDIR=$PKG install
rm -r $PKG/usr/share/gtk-doc
}

27
rasqal/libtool.patch Normal file
View File

@ -0,0 +1,27 @@
--- build/ltmain.sh
+++ build/ltmain.sh
@@ -5301,6 +5301,12 @@
prev=
continue
;;
+ mllvm)
+ # Clang does not use LLVM to link, so we can simply discard any
+ # '-mllvm $arg' options when doing the link step.
+ prev=
+ continue
+ ;;
objectlist)
if test -f "$arg"; then
save_arg=$arg
@@ -5639,6 +5645,11 @@
continue
;;
+ -mllvm)
+ prev=mllvm
+ continue
+ ;;
+
-module)
module=yes
continue

View File

@ -0,0 +1,13 @@
rhbz#809466 change soname of bundled redland libs
--- a/src/Makefile.in 2013-03-29 21:44:58.115840724 +0100
+++ b/src/Makefile.in 2013-03-29 21:45:01.252840697 +0100
@@ -621,7 +621,7 @@
$(am__append_2) $(am__append_3) $(am__append_4) \
$(am__append_5) $(am__append_6) $(am__append_7)
nodist_librasqal_la_SOURCES = $(am__append_8)
-librasqal_la_LDFLAGS = -version-info @RASQAL_LIBTOOL_VERSION@
+librasqal_la_LDFLAGS = -version-info @RASQAL_LIBTOOL_VERSION@ -release lo
librasqal_la_LIBADD = @LTLIBOBJS@ @RASQAL_INTERNAL_LIBS@ \
@RASQAL_EXTERNAL_LIBS@ $(MEM_LIBS) \
$(top_builddir)/libsv/libsv.la $(am__append_10)

View File

@ -0,0 +1,14 @@
Let the pkg-config stuff be overridden by variables
--- a/configure
+++ b/configure
@@ -14119,7 +14119,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
$as_echo "yes" >&6; }
- RAPTOR_VERSION=`$PKG_CONFIG raptor2 --modversion 2>/dev/null`
+ RAPTOR_VERSION=2.0.15
raptor_too_old=0
as_arg_v1=$RAPTOR_VERSION
as_arg_v2=$RAPTOR_MIN_VERSION

View File

@ -0,0 +1,16 @@
No point in creating util or test executables when cross-compiling.
(Especially as doing it anyway wouldn't work without tweaks to have it find
libxml2 and libm, at least for Android.)
--- a/Makefile.in
+++ b/Makefile.in
@@ -358,7 +358,7 @@
top_srcdir = @top_srcdir@
noinst_SCRIPTS = rasqal-src-config
ACLOCAL_AMFLAGS = -I build
-SUBDIRS = libsv $(am__append_1) $(am__append_2) src utils tests docs \
+SUBDIRS = libsv $(am__append_1) $(am__append_2) src docs \
data win32 scripts
DIST_SUBDIRS = libsv libmtwist getopt src utils tests docs data win32 scripts
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = rasqal.pc

21
rasqal/rpath.patch Normal file
View File

@ -0,0 +1,21 @@
--- configure
+++ configure
@@ -9843,6 +9843,7 @@
else
ld_shlibs=no
fi
+hardcode_libdir_flag_spec=
;;
netbsd* | netbsdelf*-gnu)
--- utils/Makefile.in
+++ utils/Makefile.in
@@ -373,7 +373,7 @@
$(man_MANS) \
roqet.html
-all: all-am
+all:
.SUFFIXES:
.SUFFIXES: .c .lo .o .obj