[notify] libetonyek: dropped boost-1.80 dependency, depend on contrib/boost
This commit is contained in:
parent
4ef9896c73
commit
9470b4ebe8
@ -15,7 +15,6 @@ drwxr-xr-x root/root usr/include/libetonyek-0.1/libetonyek/
|
||||
-rw-r--r-- root/root usr/include/libetonyek-0.1/libetonyek/EtonyekDocument.h
|
||||
-rw-r--r-- root/root usr/include/libetonyek-0.1/libetonyek/libetonyek.h
|
||||
drwxr-xr-x root/root usr/lib/
|
||||
-rwxr-xr-x root/root usr/lib/libetonyek-0.1.la
|
||||
lrwxrwxrwx root/root usr/lib/libetonyek-0.1.so -> libetonyek-0.1.so.1.0.10
|
||||
lrwxrwxrwx root/root usr/lib/libetonyek-0.1.so.1 -> libetonyek-0.1.so.1.0.10
|
||||
-rwxr-xr-x root/root usr/lib/libetonyek-0.1.so.1.0.10
|
||||
|
@ -1,7 +1,7 @@
|
||||
untrusted comment: verify with /etc/ports/contrib.pub
|
||||
RWSagIOpLGJF36EaeuK0D2C9vEcHnK/QN71F+y3mZvefLSTKFnYfZvfRl9MunxGbKZDeG9uxTY5sEHUcfxYmjoYV1FQ15AZABQQ=
|
||||
SHA256 (Pkgfile) = 317c4bbe5270ce99d4d23778be1865ff5a7a401569355d42ebf475c9b4a7ffd6
|
||||
SHA256 (.footprint) = 57ee578ffca9a5b5be3eedf3917c93dddd88357e5a4e5859a8e7b32d0634f111
|
||||
RWSagIOpLGJF31tq8X+TLXYOpfDltaW4X6QzRjwANWIXUaMVKK9v/DLT7ildJwfwHVcyeJRMOG+/dd8i/HNB/c1dm8IvrJrSiAA=
|
||||
SHA256 (Pkgfile) = 6e3fb0fdcceb31783627aba3b9f31c9f59660dc8e8c7bf8ec574fb18848a537e
|
||||
SHA256 (.footprint) = eb56d9ffd779b394632588dac96dba30cde7c8b262907e05358d8f0c45926f59
|
||||
SHA256 (libetonyek-0.1.10.tar.xz) = b430435a6e8487888b761dc848b7981626eb814884963ffe25eb26a139301e9a
|
||||
SHA256 (0001-allow-0-size-message.patch.1) = 805673f9d4dec4f6533c9811cd88ddf8b379ca281f417ebe5bbea4f93ce67fb5
|
||||
SHA256 (libetonyek-bundled-soname.patch.0) = 48d1167d8cd3f16d355d253ee6c4f4b25e0c581b77d6cafcd62f013d3431d584
|
||||
|
@ -1,11 +1,11 @@
|
||||
# Description: Library and a set of tools for reading and converting Apple Keynote presentations
|
||||
# Description: a library that parses the file format of Apple iWork documents
|
||||
# URL: https://wiki.documentfoundation.org/DLP/Libraries/libetonyek
|
||||
# Maintainer: Tim Biermann, tbier at posteo dot de
|
||||
# Depends on: boost-1.80 glm liblangtag librevenge mdds
|
||||
# Depends on: glm liblangtag librevenge mdds
|
||||
|
||||
name=libetonyek
|
||||
version=0.1.10
|
||||
release=3
|
||||
release=4
|
||||
source=(https://dev-www.libreoffice.org/src/$name/$name-$version.tar.xz
|
||||
0001-allow-0-size-message.patch.1
|
||||
libetonyek-bundled-soname.patch.0
|
||||
@ -22,10 +22,6 @@ build() {
|
||||
patch -Np0 -i $SRC/ubsan.patch
|
||||
patch -Np0 -i $SRC/warnings.patch
|
||||
|
||||
# boost 1.81.0 breaks libetonyek
|
||||
CXXFLAGS="-I/usr/opt/boost-1.80/include $CFLAGS"
|
||||
CPPFLAGS="-I/usr/opt/boost-1.80/include $CFLAGS"
|
||||
|
||||
autoreconf -fvi
|
||||
|
||||
./configure --prefix=/usr \
|
||||
@ -36,4 +32,6 @@ build() {
|
||||
--without-docs
|
||||
make
|
||||
make DESTDIR=$PKG install
|
||||
|
||||
find $PKG -iname '*.la' -delete
|
||||
}
|
||||
|
@ -1,36 +0,0 @@
|
||||
diff -Naur libetonyek-0.1.10.orig/configure.ac libetonyek-0.1.10/configure.ac
|
||||
--- libetonyek-0.1.10.orig/configure.ac 2023-01-28 15:58:44.501436820 +0100
|
||||
+++ libetonyek-0.1.10/configure.ac 2023-01-28 16:39:38.681363319 +0100
|
||||
@@ -102,7 +102,7 @@
|
||||
boost/none.hpp \
|
||||
boost/numeric/conversion/cast.hpp \
|
||||
boost/optional.hpp \
|
||||
- boost/spirit/include/phoenix.hpp \
|
||||
+ boost/phoenix.hpp \
|
||||
boost/spirit/include/qi.hpp \
|
||||
boost/variant/recursive_variant.hpp \
|
||||
boost/variant/variant.hpp \
|
||||
diff -Naur libetonyek-0.1.10.orig/src/lib/contexts/KEY1DivElement.cpp libetonyek-0.1.10/src/lib/contexts/KEY1DivElement.cpp
|
||||
--- libetonyek-0.1.10.orig/src/lib/contexts/KEY1DivElement.cpp 2023-01-28 15:58:44.474769901 +0100
|
||||
+++ libetonyek-0.1.10/src/lib/contexts/KEY1DivElement.cpp 2023-01-28 16:39:07.884404770 +0100
|
||||
@@ -8,7 +8,7 @@
|
||||
*/
|
||||
|
||||
#include <boost/spirit/include/qi.hpp>
|
||||
-#include <boost/spirit/include/phoenix.hpp>
|
||||
+#include <boost/phoenix.hpp>
|
||||
#include <memory>
|
||||
|
||||
#include "KEY1DivElement.h"
|
||||
diff -Naur libetonyek-0.1.10.orig/src/lib/contexts/KEY1StringConverter.cpp libetonyek-0.1.10/src/lib/contexts/KEY1StringConverter.cpp
|
||||
--- libetonyek-0.1.10.orig/src/lib/contexts/KEY1StringConverter.cpp 2023-01-28 15:58:44.478103266 +0100
|
||||
+++ libetonyek-0.1.10/src/lib/contexts/KEY1StringConverter.cpp 2023-01-28 16:39:23.404551864 +0100
|
||||
@@ -11,7 +11,7 @@
|
||||
|
||||
#include <boost/fusion/include/std_pair.hpp>
|
||||
#include <boost/spirit/include/qi.hpp>
|
||||
-#include <boost/spirit/include/phoenix.hpp>
|
||||
+#include <boost/phoenix.hpp>
|
||||
|
||||
#include "KEY1StringConverter.h"
|
||||
|
Loading…
x
Reference in New Issue
Block a user