gimp: moved from opt

This commit is contained in:
Tim Biermann 2023-02-25 20:20:45 +01:00
parent 9115c611ef
commit 9d08a197aa
Signed by: tb
GPG Key ID: 42F8B4E30B673606
4 changed files with 4786 additions and 0 deletions

4732
gimp/.footprint Normal file

File diff suppressed because it is too large Load Diff

6
gimp/.signature Normal file
View File

@ -0,0 +1,6 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF37mlBpl693hwOeCxw3fA3xK7c4s5DTWZMsOjNNXuU5VP9vAXxbZ1gnLsN0o/DPmzWuVpGPvDnE6yavg/Ci0AEgA=
SHA256 (Pkgfile) = 5a31ec617f2c4195668c9a0078b6cf43a486a852d32e86be4c76d78c399e3f3a
SHA256 (.footprint) = fad42718641e67629c9fb931db3d677d97d47018c64a6c6504560468ca49df17
SHA256 (gimp-2.10.34.tar.bz2) = 84004642d351b398a4293cd7fd3592044a944f05bb52850ee6068f247c657aa3
SHA256 (0001-no-check-update.patch) = 0695e23b343289d48074e57268012d620b249c670e98f489176c707020785dcb

View File

@ -0,0 +1,14 @@
diff --git a/app/dialogs/about-dialog.c b/app/dialogs/about-dialog.c
index d767d830f0..4352f021ca 100644
--- a/app/dialogs/about-dialog.c
+++ b/app/dialogs/about-dialog.c
@@ -163,7 +163,9 @@ about_dialog_create (GimpCoreConfig *config)
#ifdef GIMP_UNSTABLE
about_dialog_add_unstable_message (children->data);
#endif /* GIMP_UNSTABLE */
+#ifdef CHECK_UPDATE
about_dialog_add_update (&dialog, config);
+#endif /* CHECK_UPDATE */
}
else
g_warning ("%s: ooops, no box in this container?", G_STRLOC);

34
gimp/Pkgfile Normal file
View File

@ -0,0 +1,34 @@
# Description: The GIMP
# URL: https://www.gimp.org/
# Maintainer: Tim Biermann, tbier at posteo dot de
# Depends on: gegl glib-networking gtk gtk3 libart_lgpl mypaint-brushes poppler-data xorg-libxmu xorg-libxpm
# Optional: ghostscript gimp-print libmng libsdl
name=gimp
version=2.10.34
release=1
source=(https://download.gimp.org/pub/gimp/v${version%.*}/$name-$version.tar.bz2
0001-no-check-update.patch)
build() {
cd $name-$version
patch -Np1 -i $SRC/0001-no-check-update.patch
sed -i -e '/$(helpbrowser)/d' plug-ins/Makefile.in
./configure --prefix=/usr \
--libexecdir=/usr/bin \
--with-bug-report-url=https://crux.nu/bugs \
--enable-mp \
--disable-static \
--disable-python \
--disable-nls \
--disable-check-update \
--without-webkit
make
make DESTDIR=$PKG install
mv $PKG/usr/share/man/man1/gimp-console{-${version%.*}.1,.1}
rm -r $PKG/usr/share/{gtk-doc,locale}
}