rstudio: 1.4.1106 -> 1.4.1717; new dependency: yaml-cpp

This commit is contained in:
Tim Biermann 2021-06-14 09:54:03 +00:00
parent 886466d7f4
commit 9dc1ca5db6
Signed by: tb
GPG Key ID: 42F8B4E30B673606
7 changed files with 138 additions and 65 deletions

View File

@ -1,7 +1,4 @@
untrusted comment: verify with /etc/ports/contrib.pub untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF396kXPIMRcrW8Pyx/+4mIT4QtMaT9UBi6yuoy+5/kl6IBpSrpd90IkcRrA6CY0t/Z3dICF34mnK3V9kZUu31NQk= RWSagIOpLGJF33mK/vlImM6cU8z/0l7RIVPGi9wIwtIpxROIKC/wZHpAFSTqt3369mUIbVvmE8nY8TcEUUEIB24FIIiyar5GgwQ=
SHA256 (Pkgfile) = ce065fbc10fe1452aa4622f868b354c043de3cfb300f1a8652b7047e3d5219a6 SHA256 (Pkgfile) = 62d4417ed7ebda212f15f03bf41962518f7446851412b329336e142ac4255477
SHA256 (.footprint) = ce05501698260ee12ebf829749120c1d7d6abd6315a0210da2598c65b45a7bd4 SHA256 (.footprint) = ce05501698260ee12ebf829749120c1d7d6abd6315a0210da2598c65b45a7bd4
SHA256 (rstudio-1.4.1106.tar.gz) = ac84f77529501ea13f0708f0e8726b0bdfb592cd9217e869a0099031f9a888b8
SHA256 (rstudio-1.2.5042-boost-1.73.0.patch) = 5d282059731b64579c0f8c8eeb280b4c4efe810ce829ad7332385b0a92e1215e
SHA256 (rstudio-1.3.1056-boost-1.74.0.patch) = e952b6f55b0ffa7eab7ba6fca8126dd8202f37b84687d97bbd1d9d324a099065

View File

@ -0,0 +1,52 @@
From 4b9b0aa10768df68e80eb8eb03b41b937bc45e9e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?I=C3=B1aki=20=C3=9Acar?= <iucar@fedoraproject.org>
Date: Sat, 5 Jun 2021 18:21:24 +0200
Subject: [PATCH] unbundle dependencies common
---
src/cpp/session/CMakeLists.txt | 22 ----------------------
1 file changed, 22 deletions(-)
diff --git a/src/cpp/session/CMakeLists.txt b/src/cpp/session/CMakeLists.txt
index 54d15d9..a6b41cb 100644
--- a/src/cpp/session/CMakeLists.txt
+++ b/src/cpp/session/CMakeLists.txt
@@ -48,14 +48,6 @@ else()
endif()
-foreach(DEP "${RSTUDIO_DEPENDENCIES_DICTIONARIES_DIR}"
- "${RSTUDIO_DEPENDENCIES_MATHJAX_DIR}"
- "${RSTUDIO_DEPENDENCIES_PANDOC_DIR}")
- if(NOT EXISTS "${DEP}")
- message(FATAL_ERROR "${DEP} not found (re-run install-dependencies script to install")
- endif()
-endforeach()
-
# verify embedded packages are available
foreach(PKG ${RSTUDIO_EMBEDDED_PACKAGES})
file(GLOB PKG_FILES "${RSTUDIO_DEPENDENCIES_DIR}/common/${PKG}*.tar.gz")
@@ -570,20 +562,6 @@ if(NOT RSTUDIO_SESSION_WIN32 AND NOT RSESSION_ALTERNATE_BUILD)
install(DIRECTORY "resources/dependencies"
DESTINATION ${RSTUDIO_INSTALL_SUPPORTING}/resources)
- # install hunspell dictionaries
- install(DIRECTORY "${RSTUDIO_DEPENDENCIES_DICTIONARIES_DIR}"
- DESTINATION "${RSTUDIO_INSTALL_SUPPORTING}/resources")
-
- # install mathjax for local html preview
- install(DIRECTORY "${RSTUDIO_DEPENDENCIES_MATHJAX_DIR}"
- DESTINATION "${RSTUDIO_INSTALL_SUPPORTING}/resources")
-
- # install pandoc
- file(GLOB PANDOC_FILES "${RSTUDIO_DEPENDENCIES_PANDOC_DIR}/pandoc*")
- install(FILES ${PANDOC_FILES}
- PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
- DESTINATION "${RSTUDIO_INSTALL_BIN}/pandoc")
-
# install embedded packages
foreach(PKG ${RSTUDIO_EMBEDDED_PACKAGES})
file(GLOB PKG_FILES "${RSTUDIO_DEPENDENCIES_DIR}/common/${PKG}*.tar.gz")
--
2.31.1

View File

@ -0,0 +1,32 @@
From 521eff4cfbbfed2ab51dcbf4cfb3cb1fc2ceb417 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?I=C3=B1aki=20=C3=9Acar?= <iucar@fedoraproject.org>
Date: Wed, 11 Nov 2020 12:43:46 +0100
Subject: [PATCH] fix resources path
---
src/cpp/desktop/DesktopOptions.cpp | 6 ------
1 file changed, 6 deletions(-)
diff --git a/src/cpp/desktop/DesktopOptions.cpp b/src/cpp/desktop/DesktopOptions.cpp
index 673870d..d49c141 100644
--- a/src/cpp/desktop/DesktopOptions.cpp
+++ b/src/cpp/desktop/DesktopOptions.cpp
@@ -464,15 +464,9 @@ FilePath Options::resourcesPath() const
{
if (resourcesPath_.isEmpty())
{
-#ifdef RSTUDIO_PACKAGE_BUILD
// release configuration: the 'resources' folder is
// part of the supporting files folder
resourcesPath_ = supportingFilePath().completePath("resources");
-#else
- // developer configuration: the 'resources' folder is
- // a sibling of the RStudio executable
- resourcesPath_ = scriptsPath().completePath("resources");
-#endif
}
return resourcesPath_;
--
2.28.0

View File

@ -0,0 +1,40 @@
From d947a9e537fd5c0b2c1e9dd28867747b9bffa8fa Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?I=C3=B1aki=20=C3=9Acar?= <iucar@fedoraproject.org>
Date: Sat, 5 Jun 2021 18:32:16 +0200
Subject: [PATCH] use system node
---
src/gwt/build.xml | 17 +----------------
1 file changed, 1 insertion(+), 16 deletions(-)
diff --git a/src/gwt/build.xml b/src/gwt/build.xml
index 8092344..d7889d1 100644
--- a/src/gwt/build.xml
+++ b/src/gwt/build.xml
@@ -82,22 +82,7 @@
</target>
<!-- panmirror typescript library -->
- <property name="node.version" value="10.19.0"/>
- <property name="node.dir" value="../../dependencies/common/node/${node.version}"/>
- <condition property="node.bin" value="../../../${node.dir}/bin/node">
- <not>
- <os family="windows" />
- </not>
- </condition>
- <condition property="node.bin" value="${node.dir}/node.exe">
- <os family="windows" />
- </condition>
-
- <!-- use node from /opt/rstudio-tools if installed (typical for Docker) -->
- <available
- property="node.bin"
- value="/opt/rstudio-tools/dependencies/common/node/${node.version}/bin/node"
- file="/opt/rstudio-tools/dependencies/common/node/${node.version}/bin/node"/>
+ <property name="node.bin" value="/usr/bin/node"/>
<property name="panmirror.dir" value="./panmirror/src/editor"/>
<property name="panmirror.build.dir" value="./www/js/panmirror"/>
--
2.31.1

View File

@ -1,15 +1,16 @@
# Description: RStudio - an Interface for GNU R # Description: RStudio - an Interface for GNU R
# URL: https://www.rstudio.com/ # URL: https://www.rstudio.com/
# Maintainer: Tim Biermann, tbier at posteo dot de # Maintainer: Tim Biermann, tbier at posteo dot de
# Depends on: ant boost hyphen libevent libsoci mathjax nodejs openjdk8 pandoc-bin qtwebengine r # Depends on: ant boost hyphen libevent libsoci mathjax nodejs openjdk8 pandoc-bin qtwebengine r yaml-cpp yarn
name=rstudio name=rstudio
version=1.4.1106 version=1.4.1717
release=1 release=1
source=(https://github.com/rstudio/rstudio/archive/v$version/$name-$version.tar.gz source=(https://github.com/rstudio/rstudio/archive/v$version/$name-$version.tar.gz
# https://gitweb.gentoo.org/repo/gentoo.git/tree/sci-mathematics/rstudio/files # https://src.fedoraproject.org/rpms/rstudio/tree/rawhide
rstudio-1.2.5042-boost-1.73.0.patch rstudio-1.3.1056-boost-1.74.0.patch) 0000-unbundle-dependencies-common.patch 0003-fix-resources-path.patch
0004-use-system-node.patch)
git=(https://github.com/rstudio/rstudio.git) git=(https://github.com/rstudio/rstudio.git)
build() { build() {
@ -17,9 +18,6 @@ build() {
## uncomment below and change every occurance of $name-$version to $name ## uncomment below and change every occurance of $name-$version to $name
#git checkout v$version $name #git checkout v$version $name
patch -Np1 -d $name-$version -i $SRC/rstudio-1.2.5042-boost-1.73.0.patch
patch -Np1 -d $name-$version -i $SRC/rstudio-1.3.1056-boost-1.74.0.patch
export R_LIBS_USER="$PKG/usr/lib/R/library/" export R_LIBS_USER="$PKG/usr/lib/R/library/"
(pushd $name-$version/dependencies/common (pushd $name-$version/dependencies/common
@ -28,20 +26,26 @@ build() {
ln -sfT /usr/share/mathjax mathjax-27 ln -sfT /usr/share/mathjax mathjax-27
ln -sfT /usr/bin/ "pandoc/2.11.4" ln -sfT /usr/bin/ "pandoc/2.11.4"
ln -sfT /usr/bin/node node/10.19.0/bin/node ln -sfT /usr/bin/node node/10.19.0/bin/node
ln -sfT /usr/include/yaml-cpp yaml-cpp
bash install-packages bash install-packages
unset pandoc_version) unset pandoc_version)
patch -Np1 -d $name-$version -i $SRC/0000-unbundle-dependencies-common.patch
patch -Np1 -d $name-$version -i $SRC/0003-fix-resources-path.patch
patch -Np1 -d $name-$version -i $SRC/0004-use-system-node.patch
export PATH="/usr/lib/java/openjdk8/jre/bin/:${PATH}" export PATH="/usr/lib/java/openjdk8/jre/bin/:${PATH}"
cmake -S $name-$version -B build -G Ninja \ cmake -S $name-$version -B build -G Ninja \
-D CMAKE_INSTALL_PREFIX=/usr/lib/rstudio \ -D CMAKE_INSTALL_PREFIX=/usr/lib/rstudio \
-D CMAKE_BUILD_TYPE=Release \ -D CMAKE_BUILD_TYPE=Release \
-D CMAKE_CXX_FLAGS_RELEASE="$CXXFLAGS" \ -D CMAKE_CXX_FLAGS_RELEASE="$CXXFLAGS" \
-D CMAKE_C_FLAGS_RELEASE="$CFLAGS" \ -D CMAKE_C_FLAGS_RELEASE="$CFLAGS" \
-D QT_QMAKE_EXECUTABLE=/usr/lib/qt5/bin/qmake \
-D RSTUDIO_TARGET=Desktop \ -D RSTUDIO_TARGET=Desktop \
-D RSTUDIO_USE_SYSTEM_BOOST=ON \ -D RSTUDIO_USE_SYSTEM_BOOST=ON \
-D RSTUDIO_USE_SYSTEM_SOCI=ON \ -D RSTUDIO_USE_SYSTEM_SOCI=ON \
-D RSTUDIO_USE_SYSTEM_YAML_CPP=ON \
-D Boost_NO_BOOST_CMAKE=ON \ -D Boost_NO_BOOST_CMAKE=ON \
-D QT_QMAKE_EXECUTABLE=/usr/lib/qt5/bin/qmake \
-D RSTUDIO_BUNDLE_QT=FALSE \ -D RSTUDIO_BUNDLE_QT=FALSE \
-Wno-dev -Wno-dev

View File

@ -1,22 +0,0 @@
--- rstudio-1.2.5042-orig/src/cpp/core/system/PosixChildProcessTracker.cpp 2020-04-02 03:16:24.000000000 +1100
+++ rstudio-1.2.5042/src/cpp/core/system/PosixChildProcessTracker.cpp 2020-04-28 15:36:44.839368084 +1000
@@ -19,6 +19,8 @@
#include <boost/format.hpp>
+using namespace boost::placeholders;
+
namespace rstudio {
namespace core {
namespace system {
--- rstudio-1.2.5042-orig/src/cpp/core/system/PosixOutputCapture.cpp 2020-04-02 03:16:24.000000000 +1100
+++ rstudio-1.2.5042/src/cpp/core/system/PosixOutputCapture.cpp 2020-04-28 15:35:50.869185435 +1000
@@ -28,6 +28,8 @@
#include <core/system/System.hpp>
+using namespace boost::placeholders;
+
namespace rstudio {
namespace core {
namespace system {

View File

@ -1,30 +0,0 @@
--- rstudio-1.3.1056-orig/src/cpp/core/file_lock/FileLock.cpp 2020-07-08 08:25:03.000000000 +1000
+++ rstudio-1.3.1056/src/cpp/core/file_lock/FileLock.cpp 2020-07-17 18:01:57.016882590 +1000
@@ -26,6 +26,7 @@
#include <core/system/Environment.hpp>
#include <boost/algorithm/string.hpp>
+#include <boost/bind.hpp>
// borrowed from SessionConstants.hpp
#define kRStudioSessionRoute "RSTUDIO_SESSION_ROUTE"
--- rstudio-1.3.1056-orig/src/cpp/core/HtmlUtils.cpp 2020-07-08 08:25:03.000000000 +1000
+++ rstudio-1.3.1056/src/cpp/core/HtmlUtils.cpp 2020-07-17 18:01:58.129886387 +1000
@@ -19,6 +19,7 @@
#include <boost/format.hpp>
#include <boost/algorithm/string/predicate.hpp>
+#include <boost/bind.hpp>
#include <core/Base64.hpp>
#include <core/FileSerializer.hpp>
--- rstudio-1.3.1056-orig/src/cpp/r/session/RStdCallbacks.cpp 2020-07-08 08:25:03.000000000 +1000
+++ rstudio-1.3.1056/src/cpp/r/session/RStdCallbacks.cpp 2020-07-17 18:32:09.044071640 +1000
@@ -19,6 +19,7 @@
#include <boost/function.hpp>
#include <boost/regex.hpp>
+#include <boost/bind.hpp>
#include <r/RExec.hpp>
#include <r/ROptions.hpp>