mailman-web: cherry-picked django5 support

This commit is contained in:
Tim Biermann 2024-07-11 17:59:01 +02:00
parent 130bd932dd
commit a471b36779
Signed by: tb
GPG Key ID: 42F8B4E30B673606
3 changed files with 34 additions and 3 deletions

View File

@ -1,9 +1,10 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF3zvuXvyOf8SIMJaa/t028ZJu0aBjhWFx5G9ZEc1Y4cU78UE9a9skySWyUCXxM6nXXDJfA7CJsR0pKZf3OcvsQwM=
SHA256 (Pkgfile) = 923c3840d4fdee79e1d86a51edfa3a246c040acb15907cdac817fb69383b9fa1
RWSagIOpLGJF31TXwgGXrqEcvVYVYyi1Av0+2qH1v2k2UUM+hzts4WdgEkA1nfIpfz0kA5h0c4xiS8c/DhkcsOnYV5QVfsudogs=
SHA256 (Pkgfile) = 788bc67d986aafcbfaf8dbc0944006820968cc211d261b60bfdf641085296d51
SHA256 (.footprint) = f204d51c0880203623aa1d0d8e6a68c4b5b8407aff838ef18d389ee4c59acdfd
SHA256 (mailman_web-0.0.9.tar.gz) = df09ddb9e8fac4c433ae31a11974339df26e77f528cb704376eba444979a84bf
SHA256 (mailman-web.service) = f9ae706a1df0a7d454fde6d8df76decd090246a591d31447e44f6e0f07a0d1f6
SHA256 (mailman-qcluster.service) = 0e7ce0ccaeaffb49faf6a5188150ebd82d3835069ff7f5c1ffcf02b52d37a56b
SHA256 (settings.py) = cc93831cffbbd67527f984d2698e04aeae115a1d5a696395de0f25d887ad96c0
SHA256 (55.patch) = 40e88146a01f36dc8e704bc49af6af1bc4e33645f198a8df7f6aed35bf5f0b84
SHA256 (mailman-web-0.0.5-fhs.patch) = 026ab5afcd530f7ce0655211613d9ec1d0c26cc1b87057d85ee0619e5f377a65

28
mailman-web/55.patch Normal file
View File

@ -0,0 +1,28 @@
From 246b6f0a2ef0583ecb780ef9b1eac13a6604d284 Mon Sep 17 00:00:00 2001
From: Jelle van der Waa <jelle@vdwaa.nl>
Date: Sat, 1 Jun 2024 11:44:53 +0200
Subject: [PATCH] Add django 5.0 support
---
.gitlab-ci.yml | 5 +++++
README.rst | 1 +
pyproject.toml | 2 +-
tox.ini | 3 ++-
4 files changed, 9 insertions(+), 2 deletions(-)
diff --git a/pyproject.toml b/pyproject.toml
index 74c8812..6852b16 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -18,7 +18,7 @@ classifiers = [
]
requires-python = ">=3.9"
dependencies = [
- "django>=4.0,<4.3",
+ "django>=4.0,<5.1",
"hyperkitty",
"postorius",
"whoosh",
--
GitLab

View File

@ -6,11 +6,12 @@
name=mailman-web
version=0.0.9
release=1
release=2
source=(https://pypi.org/packages/source/m/mailman_web/mailman_web-$version.tar.gz
mailman-web.service
mailman-qcluster.service
settings.py
55.patch
mailman-web-0.0.5-fhs.patch)
build() {
@ -18,6 +19,7 @@ build() {
local site_packages=$(/usr/bin/python3 -c "import site; print(site.getsitepackages()[0])")
patch -Np1 -i $SRC/mailman-web-0.0.5-fhs.patch
patch -Np1 -i $SRC/55.patch
/usr/bin/python3 -m build --wheel --skip-dependency-check --no-isolation
/usr/bin/python3 -m installer --compile-bytecode 2 --destdir=$PKG dist/*.whl