ceph: initial import

This commit is contained in:
Danny Rawlins 2021-10-31 14:20:32 +11:00
parent bb8a4ee707
commit ae770203bc
17 changed files with 98935 additions and 0 deletions

98141
ceph/.footprint Normal file

File diff suppressed because it is too large Load Diff

19
ceph/.signature Normal file
View File

@ -0,0 +1,19 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF35w503rUdeLNFsqRDovXnhNDlNZZ7+AMcqkuACcBA1/7zeqMSeBfuqXvEgvs5U0GIShoQErQdPaZlN/UCh4/lg8=
SHA256 (Pkgfile) = 649b0563541907483b41da35bbd29203aa9087dba49c8e86b39fe9a4e78db8fb
SHA256 (.footprint) = d2079a7a35ef217a50a8bd4f328beb944b8113c387ede11221f40c5f332dc9c3
SHA256 (ceph_16.2.5.orig.tar.gz) = b8206916fa7993e0394a0c31a09564b866fd13af6968aaecdea75ae51a6c46de
SHA256 (ceph.confd) = 96e5e3c23764005622e94bbd69216bdf514b6674c6652bcf0843cec84970890e
SHA256 (ceph.initd) = 0c6a68cf217531ee3e556a6da81d7f950c342cfdc219cd36d866928ec695538e
SHA256 (0001-src-common-crc32c_intel_fast.patch) = 9d79caa39a217bad7d2356f5278e796a8f6548a2e8d12fcaafe7ded896ee8827
SHA256 (0002-src-common-CMakeLists.txt.patch) = 9f71a7f2142c6e9b10713c665c137db816ac9e3661d7d5521331cb80addfef77
SHA256 (0003-src-common-bitstr.h.patch) = a0f4eb6aa8039bfea51e0165822dc64ccd79088c63a86b646838accdd22ee0ac
SHA256 (0006-src-blk-CMakeLists.txt.patch) = fcdb83016bc0dc9ad6e458f490a7642db0df28142b483e63ddaf8e4b42ab9091
SHA256 (0007-src-test-neorados-CMakeLists.txt.patch) = c3fd1ee199134b2020fe8b0981d59e8f98550cc9df3869a8123370504bcae0d8
SHA256 (0008-cmake-modules-Finduring.cmake.patch) = 3d4526c82d043803be0b7150a9740bd903f4c5c7c0498544ff9a0dd7ee934989
SHA256 (0009-librgw-notifications-initialize-kafka-and-amqp.patch) = 0d750ebe1cb8e49006d3a546bd592c6a42cece6d910b8d07085bdd25c08061c4
SHA256 (0011-src-test-rgw-amqp_mock.cc.patch) = 3c0f593d3d93a250dda373e38806274e37ca37c0f5b032ec6b03851514441efd
SHA256 (0012-src-compressor-snappy-SnappyCompressor.h.patch) = c388504bb77e25124259e9e2a9e440404a67a4c747500acd4ca2a39319ee422c
SHA256 (0013-src-common-Formatter.cc.patch) = 82abf19d94e35d26907467c5bc565fc4ffd91c7b28cc0bfff8836b104a6ff745
SHA256 (0014-rgw-Replace-boost-string_ref-view-with-std-string_vi.patch) = ee04208ed9ef90552b2ad40fd39a2e7829f03e80af2a4ab69b777a4809b26c93
SHA256 (0015-src-kv-rocksdb_cache.patch) = bd8a80ee3ab7855225ef91431cd8b036e23c95074f469ffb999a0e52ca0bfa6d

View File

@ -0,0 +1,55 @@
--- ceph-15.2.2/src/common/crc32c_intel_fast_zero_asm.s.orig 2020-05-26 08:34:32.226201974 -0400
+++ ceph-15.2.2/src/common/crc32c_intel_fast_zero_asm.s 2020-05-26 17:19:32.497201974 -0400
@@ -1,5 +1,5 @@
;
-; Copyright 2012-2013 Intel Corporation All Rights Reserved.
+; Copyright 2012-2015 Intel Corporation All Rights Reserved.
; All rights reserved.
;
; http://opensource.org/licenses/BSD-3-Clause
@@ -59,6 +59,19 @@
xor rbx, rbx ;; rbx = crc1 = 0;
xor r10, r10 ;; r10 = crc2 = 0;
+ cmp len, %%bSize*3*2
+ jbe %%non_prefetch
+
+ %assign i 0
+ %rep %%bSize/8 - 1
+ crc32 rax, bufptmp ;; update crc0
+ crc32 rbx, bufptmp ;; update crc1
+ crc32 r10, bufptmp ;; update crc2
+ %assign i (i+8)
+ %endrep
+ jmp %%next %+ %1
+
+%%non_prefetch:
%assign i 0
%rep %%bSize/8 - 1
crc32 rax, bufptmp ;; update crc0
@@ -66,6 +79,8 @@
crc32 r10, bufptmp ;; update crc2
%assign i (i+8)
%endrep
+
+%%next %+ %1:
crc32 rax, bufptmp ;; update crc0
crc32 rbx, bufptmp ;; update crc1
; SKIP ;crc32 r10, bufptmp ;; update crc2
@@ -180,12 +195,15 @@
%define crc_init_dw r8d
%endif
-
+ endbranch
push rdi
push rbx
mov rax, crc_init ;; rax = crc_init;
+ cmp len, 8
+ jb less_than_8
+
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; 1) ALIGN: ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

View File

@ -0,0 +1,13 @@
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 65ba10b0f1..eeedc29c37 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -165,7 +165,7 @@ elseif(HAVE_ARMV8_CRC)
crc32c_aarch64.c)
endif(HAVE_INTEL)
-add_library(crc32 ${crc32_srcs})
+add_library(crc32 STATIC ${crc32_srcs})
if(HAVE_ARMV8_CRC)
set_target_properties(crc32 PROPERTIES
COMPILE_FLAGS "${CMAKE_C_FLAGS} ${ARMV8_CRC_COMPILE_FLAGS}")

View File

@ -0,0 +1,21 @@
--- ceph-15.1.0/src/common/bit_str.h.orig 2020-02-03 09:47:20.047149798 -0500
+++ ceph-15.1.0/src/common/bit_str.h 2020-02-03 09:47:50.213149798 -0500
@@ -17,6 +17,7 @@
#include <cstdint>
#include <iosfwd>
#include <functional>
+#include <ostream>
namespace ceph {
class Formatter;
--- ceph-15.2.4/src/global/signal_handler.h.orig 2020-07-17 12:57:54.763628429 -0400
+++ ceph-15.2.4/src/global/signal_handler.h 2020-07-17 12:58:10.610628429 -0400
@@ -16,6 +16,8 @@
#define CEPH_GLOBAL_SIGNAL_HANDLER_H
#include <signal.h>
+#include <string>
+
#include "acconfig.h"
typedef void (*signal_handler_t)(int);

View File

@ -0,0 +1,11 @@
--- ceph-16.1.0-43-g6b74fb5c/src/blk/CMakeLists.txt.orig 2021-02-01 08:16:26.719517641 -0500
+++ ceph-16.1.0-43-g6b74fb5c/src/blk/CMakeLists.txt 2021-02-01 08:16:47.810092341 -0500
@@ -25,7 +25,7 @@
zoned/HMSMRDevice.cc)
endif()
-add_library(blk ${libblk_srcs})
+add_library(blk STATIC ${libblk_srcs})
target_include_directories(blk PRIVATE "./")
if(HAVE_LIBAIO)

View File

@ -0,0 +1,11 @@
--- ceph-16.1.0-43-g6b74fb5c/src/test/neorados/CMakeLists.txt.orig 2021-02-01 08:25:18.006965821 -0500
+++ ceph-16.1.0-43-g6b74fb5c/src/test/neorados/CMakeLists.txt 2021-02-01 08:25:34.244407147 -0500
@@ -19,7 +19,7 @@
target_link_libraries(ceph_test_neorados_op_speed
libneorados fmt::fmt ${unittest_libs})
-add_library(neoradostest-support common_tests.cc)
+add_library(neoradostest-support STATIC common_tests.cc)
target_link_libraries(neoradostest-support
libneorados fmt::fmt)

View File

@ -0,0 +1,11 @@
--- ceph-16.1.0-43-g6b74fb5c/cmake/modules/Finduring.cmake.orig 2021-02-01 08:45:39.316108287 -0500
+++ ceph-16.1.0-43-g6b74fb5c/cmake/modules/Finduring.cmake 2021-02-01 08:45:59.813665378 -0500
@@ -5,7 +5,7 @@
# uring_FOUND - True if uring found.
find_path(URING_INCLUDE_DIR liburing.h)
-find_library(URING_LIBRARIES liburing.a liburing)
+find_library(URING_LIBRARIES liburing.so liburing)
include(FindPackageHandleStandardArgs)
find_package_handle_standard_args(uring DEFAULT_MSG URING_LIBRARIES URING_INCLUDE_DIR)

View File

@ -0,0 +1,63 @@
From 178f6bdac97b57300bbe0956633cf686a7e3ccee Mon Sep 17 00:00:00 2001
From: Yuval Lifshitz <ylifshit@redhat.com>
Date: Fri, 12 Mar 2021 08:56:45 +0200
Subject: [PATCH] librgw/notifications: initialize kafka and amqp
Fixes: https://tracker.ceph.com/issues/49738
Signed-off-by: Yuval Lifshitz <ylifshit@redhat.com>
---
src/rgw/librgw.cc | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
diff --git a/src/rgw/librgw.cc b/src/rgw/librgw.cc
index 012cc54c3b..a5351dbe7c 100644
--- a/src/rgw/librgw.cc
+++ b/src/rgw/librgw.cc
@@ -53,6 +53,12 @@
#include "rgw_http_client.h"
#include "rgw_http_client_curl.h"
#include "rgw_perf_counters.h"
+#ifdef WITH_RADOSGW_AMQP_ENDPOINT
+#include "rgw_amqp.h"
+#endif
+#ifdef WITH_RADOSGW_KAFKA_ENDPOINT
+#include "rgw_kafka.h"
+#endif
#include "services/svc_zone.h"
@@ -617,6 +623,17 @@ namespace rgw {
/* ignore error */
}
+#ifdef WITH_RADOSGW_AMQP_ENDPOINT
+ if (!rgw::amqp::init(cct.get())) {
+ derr << "ERROR: failed to initialize AMQP manager" << dendl;
+ }
+#endif
+#ifdef WITH_RADOSGW_KAFKA_ENDPOINT
+ if (!rgw::kafka::init(cct.get())) {
+ derr << "ERROR: failed to initialize Kafka manager" << dendl;
+ }
+#endif
+
return 0;
} /* RGWLib::init() */
@@ -645,6 +662,12 @@ namespace rgw {
rgw_shutdown_resolver();
rgw_http_client_cleanup();
rgw::curl::cleanup_curl();
+#ifdef WITH_RADOSGW_AMQP_ENDPOINT
+ rgw::amqp::shutdown();
+#endif
+#ifdef WITH_RADOSGW_KAFKA_ENDPOINT
+ rgw::kafka::shutdown();
+#endif
rgw_perf_stop(g_ceph_context);
--
2.26.2

View File

@ -0,0 +1,23 @@
--- a/src/test/rgw/amqp_mock.cc
+++ b/src/test/rgw/amqp_mock.cc
@@ -291,7 +291,11 @@ amqp_confirm_select_ok_t* amqp_confirm_select(amqp_connection_state_t state, amq
return state->confirm;
}
-int amqp_simple_wait_frame_noblock(amqp_connection_state_t state, amqp_frame_t *decoded_frame, struct timeval* tv) {
+extern "C" {
+
+int amqp_simple_wait_frame_noblock(amqp_connection_state_t state,
+ amqp_frame_t *decoded_frame,
+ const struct timeval* tv) {
if (state->socket && state->socket->open_called &&
state->login_called && state->channel1 && state->channel2 && state->exchange &&
state->queue && state->consume && state->confirm && !FAIL_NEXT_READ) {
@@ -345,6 +349,7 @@ int amqp_simple_wait_frame_noblock(amqp_connection_state_t state, amqp_frame_t *
}
return AMQP_STATUS_CONNECTION_CLOSED;
}
+} // extern "C"
amqp_basic_consume_ok_t* amqp_basic_consume(
amqp_connection_state_t state, amqp_channel_t channel, amqp_bytes_t queue,

View File

@ -0,0 +1,11 @@
--- ceph-16.2.4/src/compressor/snappy/SnappyCompressor.h.orig 2021-05-26 08:30:26.205447315 -0400
+++ ceph-16.2.4/src/compressor/snappy/SnappyCompressor.h 2021-05-26 08:31:22.570443033 -0400
@@ -97,7 +97,7 @@
if (qat_enabled)
return qat_accel.decompress(p, compressed_len, dst, compressor_message);
#endif
- snappy::uint32 res_len = 0;
+ std::uint32_t res_len = 0;
BufferlistSource source_1(p, compressed_len);
if (!snappy::GetUncompressedLength(&source_1, &res_len)) {
return -1;

View File

@ -0,0 +1,10 @@
--- ceph-16.2.4/src/common/Formatter.cc.orig 2021-07-07 09:32:25.513818420 -0400
+++ ceph-16.2.4/src/common/Formatter.cc 2021-07-07 09:44:42.007373294 -0400
@@ -21,6 +21,7 @@
#include <fmt/format.h>
#include <set>
#include <limits>
+#include <algorithm>
// -----------------------
namespace ceph {

View File

@ -0,0 +1,13 @@
diff --git a/src/rgw/rgw_string.h b/src/rgw/rgw_string.h
index 257daa9c1fe..90e64f98a25 100644
--- a/src/rgw/rgw_string.h
+++ b/src/rgw/rgw_string.h
@@ -8,6 +8,8 @@
#include <stdlib.h>
#include <limits.h>
#include <string_view>
+#include <string>
+#include <stdexcept>
#include <boost/container/small_vector.hpp>

View File

@ -0,0 +1,296 @@
diff --git a/src/kv/rocksdb_cache/BinnedLRUCache.cc b/src/kv/rocksdb_cache/BinnedLRUCache.cc
index 0d657883e92de..47c56e2ddd769 100644
--- a/src/kv/rocksdb_cache/BinnedLRUCache.cc
+++ b/src/kv/rocksdb_cache/BinnedLRUCache.cc
@@ -151,13 +151,20 @@ void BinnedLRUCacheShard::EraseUnRefEntries() {
}
}
-void BinnedLRUCacheShard::ApplyToAllCacheEntries(void (*callback)(void*, size_t),
- bool thread_safe) {
+void BinnedLRUCacheShard::ApplyToAllCacheEntries(
+ const std::function<void(const rocksdb::Slice& key,
+ void* value,
+ size_t charge,
+ DeleterFn)>& callback,
+ bool thread_safe)
+{
if (thread_safe) {
mutex_.lock();
}
table_.ApplyToAllCacheEntries(
- [callback](BinnedLRUHandle* h) { callback(h->value, h->charge); });
+ [callback](BinnedLRUHandle* h) {
+ callback(h->key(), h->value, h->charge, h->deleter);
+ });
if (thread_safe) {
mutex_.unlock();
}
@@ -345,7 +352,7 @@ bool BinnedLRUCacheShard::Release(rocksdb::Cache::Handle* handle, bool force_era
rocksdb::Status BinnedLRUCacheShard::Insert(const rocksdb::Slice& key, uint32_t hash, void* value,
size_t charge,
- void (*deleter)(const rocksdb::Slice& key, void* value),
+ DeleterFn deleter,
rocksdb::Cache::Handle** handle, rocksdb::Cache::Priority priority) {
auto e = new BinnedLRUHandle();
rocksdb::Status s;
@@ -464,6 +471,12 @@ std::string BinnedLRUCacheShard::GetPrintableOptions() const {
return std::string(buffer);
}
+DeleterFn BinnedLRUCacheShard::GetDeleter(rocksdb::Cache::Handle* h) const
+{
+ auto* handle = reinterpret_cast<BinnedLRUHandle*>(h);
+ return handle->deleter;
+}
+
BinnedLRUCache::BinnedLRUCache(CephContext *c,
size_t capacity,
int num_shard_bits,
@@ -519,6 +532,13 @@ void BinnedLRUCache::DisownData() {
#endif // !__SANITIZE_ADDRESS__
}
+#if (ROCKSDB_MAJOR >= 6 && ROCKSDB_MINOR >= 22)
+DeleterFn BinnedLRUCache::GetDeleter(Handle* handle) const
+{
+ return reinterpret_cast<const BinnedLRUHandle*>(handle)->deleter;
+}
+#endif
+
size_t BinnedLRUCache::TEST_GetLRUSize() {
size_t lru_size_of_all_shards = 0;
for (int i = 0; i < num_shards_; i++) {
diff --git a/src/kv/rocksdb_cache/BinnedLRUCache.h b/src/kv/rocksdb_cache/BinnedLRUCache.h
index 85608be0e5734..88bf4502e8927 100644
--- a/src/kv/rocksdb_cache/BinnedLRUCache.h
+++ b/src/kv/rocksdb_cache/BinnedLRUCache.h
@@ -56,7 +56,7 @@ std::shared_ptr<rocksdb::Cache> NewBinnedLRUCache(
struct BinnedLRUHandle {
void* value;
- void (*deleter)(const rocksdb::Slice&, void* value);
+ DeleterFn deleter;
BinnedLRUHandle* next_hash;
BinnedLRUHandle* next;
BinnedLRUHandle* prev;
@@ -189,7 +189,7 @@ class alignas(CACHE_LINE_SIZE) BinnedLRUCacheShard : public CacheShard {
// Like Cache methods, but with an extra "hash" parameter.
virtual rocksdb::Status Insert(const rocksdb::Slice& key, uint32_t hash, void* value,
size_t charge,
- void (*deleter)(const rocksdb::Slice& key, void* value),
+ DeleterFn deleter,
rocksdb::Cache::Handle** handle,
rocksdb::Cache::Priority priority) override;
virtual rocksdb::Cache::Handle* Lookup(const rocksdb::Slice& key, uint32_t hash) override;
@@ -205,13 +205,19 @@ class alignas(CACHE_LINE_SIZE) BinnedLRUCacheShard : public CacheShard {
virtual size_t GetUsage() const override;
virtual size_t GetPinnedUsage() const override;
- virtual void ApplyToAllCacheEntries(void (*callback)(void*, size_t),
- bool thread_safe) override;
+ virtual void ApplyToAllCacheEntries(
+ const std::function<void(const rocksdb::Slice& key,
+ void* value,
+ size_t charge,
+ DeleterFn)>& callback,
+ bool thread_safe) override;
virtual void EraseUnRefEntries() override;
virtual std::string GetPrintableOptions() const override;
+ virtual DeleterFn GetDeleter(rocksdb::Cache::Handle* handle) const override;
+
void TEST_GetLRUList(BinnedLRUHandle** lru, BinnedLRUHandle** lru_low_pri);
// Retrieves number of elements in LRU, for unit test purpose only
@@ -304,7 +310,9 @@ class BinnedLRUCache : public ShardedCache {
virtual size_t GetCharge(Handle* handle) const override;
virtual uint32_t GetHash(Handle* handle) const override;
virtual void DisownData() override;
-
+#if (ROCKSDB_MAJOR >= 6 && ROCKSDB_MINOR >= 22)
+ virtual DeleterFn GetDeleter(Handle* handle) const override;
+#endif
// Retrieves number of elements in LRU, for unit test purpose only
size_t TEST_GetLRUSize();
// Sets the high pri pool ratio
diff --git a/src/kv/rocksdb_cache/ShardedCache.cc b/src/kv/rocksdb_cache/ShardedCache.cc
index 367140a94d8be..6cbd89ad6472c 100644
--- a/src/kv/rocksdb_cache/ShardedCache.cc
+++ b/src/kv/rocksdb_cache/ShardedCache.cc
@@ -44,7 +44,7 @@ void ShardedCache::SetStrictCapacityLimit(bool strict_capacity_limit) {
}
rocksdb::Status ShardedCache::Insert(const rocksdb::Slice& key, void* value, size_t charge,
- void (*deleter)(const rocksdb::Slice& key, void* value),
+ DeleterFn deleter,
rocksdb::Cache::Handle** handle, Priority priority) {
uint32_t hash = HashSlice(key);
return GetShard(Shard(hash))
@@ -109,13 +109,36 @@ size_t ShardedCache::GetPinnedUsage() const {
return usage;
}
+#if (ROCKSDB_MAJOR >= 6 && ROCKSDB_MINOR >= 22)
+DeleterFn ShardedCache::GetDeleter(Handle* handle) const
+{
+ uint32_t hash = GetHash(handle);
+ return GetShard(Shard(hash))->GetDeleter(handle);
+}
+
+void ShardedCache::ApplyToAllEntries(
+ const std::function<void(const rocksdb::Slice& key, void* value, size_t charge,
+ DeleterFn deleter)>& callback,
+ const ApplyToAllEntriesOptions& opts)
+{
+ int num_shards = 1 << num_shard_bits_;
+ for (int s = 0; s < num_shards; s++) {
+ GetShard(s)->ApplyToAllCacheEntries(callback, true /* thread_safe */);
+ }
+}
+#else
void ShardedCache::ApplyToAllCacheEntries(void (*callback)(void*, size_t),
bool thread_safe) {
int num_shards = 1 << num_shard_bits_;
for (int s = 0; s < num_shards; s++) {
- GetShard(s)->ApplyToAllCacheEntries(callback, thread_safe);
+ GetShard(s)->ApplyToAllCacheEntries(
+ [callback](const rocksdb::Slice&, void* value, size_t charge, DeleterFn) {
+ callback(value, charge);
+ },
+ thread_safe);
}
}
+#endif
void ShardedCache::EraseUnRefEntries() {
int num_shards = 1 << num_shard_bits_;
@@ -131,7 +154,7 @@ std::string ShardedCache::GetPrintableOptions() const {
char buffer[kBufferSize];
{
std::lock_guard<std::mutex> l(capacity_mutex_);
- snprintf(buffer, kBufferSize, " capacity : %" ROCKSDB_PRIszt "\n",
+ snprintf(buffer, kBufferSize, " capacity : %zu\n",
capacity_);
ret.append(buffer);
snprintf(buffer, kBufferSize, " num_shard_bits : %d\n", num_shard_bits_);
diff --git a/src/kv/rocksdb_cache/ShardedCache.h b/src/kv/rocksdb_cache/ShardedCache.h
index 4d64893ab1c7b..f98421a09a33a 100644
--- a/src/kv/rocksdb_cache/ShardedCache.h
+++ b/src/kv/rocksdb_cache/ShardedCache.h
@@ -14,6 +14,7 @@
#include <string>
#include <mutex>
+#include "rocksdb/version.h"
#include "rocksdb/cache.h"
#include "include/ceph_hash.h"
#include "common/PriorityCache.h"
@@ -22,10 +23,11 @@
#ifndef CACHE_LINE_SIZE
#define CACHE_LINE_SIZE 64 // XXX arch-specific define
#endif
-#define ROCKSDB_PRIszt "zu"
namespace rocksdb_cache {
+using DeleterFn = void (*)(const rocksdb::Slice& key, void* value);
+
// Single cache shard interface.
class CacheShard {
public:
@@ -34,7 +36,7 @@ class CacheShard {
virtual rocksdb::Status Insert(const rocksdb::Slice& key, uint32_t hash, void* value,
size_t charge,
- void (*deleter)(const rocksdb::Slice& key, void* value),
+ DeleterFn deleter,
rocksdb::Cache::Handle** handle, rocksdb::Cache::Priority priority) = 0;
virtual rocksdb::Cache::Handle* Lookup(const rocksdb::Slice& key, uint32_t hash) = 0;
virtual bool Ref(rocksdb::Cache::Handle* handle) = 0;
@@ -44,10 +46,15 @@ class CacheShard {
virtual void SetStrictCapacityLimit(bool strict_capacity_limit) = 0;
virtual size_t GetUsage() const = 0;
virtual size_t GetPinnedUsage() const = 0;
- virtual void ApplyToAllCacheEntries(void (*callback)(void*, size_t),
- bool thread_safe) = 0;
+ virtual void ApplyToAllCacheEntries(
+ const std::function<void(const rocksdb::Slice& key,
+ void* value,
+ size_t charge,
+ DeleterFn)>& callback,
+ bool thread_safe) = 0;
virtual void EraseUnRefEntries() = 0;
virtual std::string GetPrintableOptions() const { return ""; }
+ virtual DeleterFn GetDeleter(rocksdb::Cache::Handle* handle) const = 0;
};
// Generic cache interface which shards cache by hash of keys. 2^num_shard_bits
@@ -57,34 +64,43 @@ class ShardedCache : public rocksdb::Cache, public PriorityCache::PriCache {
public:
ShardedCache(size_t capacity, int num_shard_bits, bool strict_capacity_limit);
virtual ~ShardedCache() = default;
+ // rocksdb::Cache
virtual const char* Name() const override = 0;
- virtual CacheShard* GetShard(int shard) = 0;
- virtual const CacheShard* GetShard(int shard) const = 0;
- virtual void* Value(Handle* handle) override = 0;
- virtual size_t GetCharge(Handle* handle) const = 0;
- virtual uint32_t GetHash(Handle* handle) const = 0;
- virtual void DisownData() override = 0;
-
- virtual void SetCapacity(size_t capacity) override;
- virtual void SetStrictCapacityLimit(bool strict_capacity_limit) override;
-
virtual rocksdb::Status Insert(const rocksdb::Slice& key, void* value, size_t charge,
- void (*deleter)(const rocksdb::Slice& key, void* value),
+ DeleterFn,
rocksdb::Cache::Handle** handle, Priority priority) override;
virtual rocksdb::Cache::Handle* Lookup(const rocksdb::Slice& key, rocksdb::Statistics* stats) override;
virtual bool Ref(rocksdb::Cache::Handle* handle) override;
virtual bool Release(rocksdb::Cache::Handle* handle, bool force_erase = false) override;
+ virtual void* Value(Handle* handle) override = 0;
virtual void Erase(const rocksdb::Slice& key) override;
virtual uint64_t NewId() override;
- virtual size_t GetCapacity() const override;
+ virtual void SetCapacity(size_t capacity) override;
+ virtual void SetStrictCapacityLimit(bool strict_capacity_limit) override;
virtual bool HasStrictCapacityLimit() const override;
+ virtual size_t GetCapacity() const override;
virtual size_t GetUsage() const override;
virtual size_t GetUsage(rocksdb::Cache::Handle* handle) const override;
virtual size_t GetPinnedUsage() const override;
+ virtual size_t GetCharge(Handle* handle) const = 0;
+#if (ROCKSDB_MAJOR >= 6 && ROCKSDB_MINOR >= 22)
+ virtual DeleterFn GetDeleter(Handle* handle) const override;
+#endif
+ virtual void DisownData() override = 0;
+#if (ROCKSDB_MAJOR >= 6 && ROCKSDB_MINOR >= 22)
+ virtual void ApplyToAllEntries(
+ const std::function<void(const rocksdb::Slice& key, void* value, size_t charge,
+ DeleterFn deleter)>& callback,
+ const ApplyToAllEntriesOptions& opts) override;
+#else
virtual void ApplyToAllCacheEntries(void (*callback)(void*, size_t),
bool thread_safe) override;
+#endif
virtual void EraseUnRefEntries() override;
virtual std::string GetPrintableOptions() const override;
+ virtual CacheShard* GetShard(int shard) = 0;
+ virtual const CacheShard* GetShard(int shard) const = 0;
+ virtual uint32_t GetHash(Handle* handle) const = 0;
int GetNumShardBits() const { return num_shard_bits_; }
@@ -120,7 +136,7 @@ class ShardedCache : public rocksdb::Cache, public PriorityCache::PriCache {
// return Hash(s.data(), s.size(), 0);
}
- uint32_t Shard(uint32_t hash) {
+ uint32_t Shard(uint32_t hash) const {
// Note, hash >> 32 yields hash in gcc, not the zero we expect!
return (num_shard_bits_ > 0) ? (hash >> (32 - num_shard_bits_)) : 0;
}

102
ceph/Pkgfile Normal file
View File

@ -0,0 +1,102 @@
# Description: Ceph is a distributed object store and file system
# URL: https://ceph.com/
# Maintainer: Danny Rawlins, crux at romster dot me
# Depends on: curl libdevmapper libgmp npm
name=ceph
version=16.2.5
release=1
source=(https://download.ceph.com/tarballs/ceph_$version.orig.tar.gz
ceph.confd
ceph.initd
0001-src-common-crc32c_intel_fast.patch
0002-src-common-CMakeLists.txt.patch
0003-src-common-bitstr.h.patch
0006-src-blk-CMakeLists.txt.patch
0007-src-test-neorados-CMakeLists.txt.patch
0008-cmake-modules-Finduring.cmake.patch
0009-librgw-notifications-initialize-kafka-and-amqp.patch
0011-src-test-rgw-amqp_mock.cc.patch
0012-src-compressor-snappy-SnappyCompressor.h.patch
0013-src-common-Formatter.cc.patch
0014-rgw-Replace-boost-string_ref-view-with-std-string_vi.patch
0015-src-kv-rocksdb_cache.patch)
build() {
export NPM_CONFIG_USERCONFIG=$SRC/.npm
export NPM_CONFIG_CACHE=$SRC/.npm/cache
export GATSBY_TELEMETRY_DISABLED="1"
export CEPH_BUILD_VIRTUALENV="$name-$version/build"
[ ! -d "$PKGMK_SOURCE_DIR/yarn_cache" ] && mkdir "$PKGMK_SOURCE_DIR/yarn_cache"
export YARN_CACHE_FOLDER="$PKGMK_SOURCE_DIR/yarn_cache"
[ ! -d "$PKGMK_SOURCE_DIR/npm_cache" ] && mkdir "$PKGMK_SOURCE_DIR/npm_cache"
export npm_config_cache="$PKGMK_SOURCE_DIR/npm_cache"
[ ! -d "$PKGMK_SOURCE_DIR/rust" ] && mkdir "$PKGMK_SOURCE_DIR/rust"
export CARGO_HOME="$PKGMK_SOURCE_DIR/rust"
for p in *.patch; do
patch -d $name-$version -p1 -i $SRC/$p
done
# npm-fsevents-optional.patch
pushd $name-$version/src/pybind/mgr/dashboard/frontend
npm i fsevents@2.1.3 -f --save-optional
popd
# using system boost
rm -r $name-$version/src/boost
[[ -e $name-$version/usr/bin/ninja ]] && PKGMK_CEPH+=' -G Ninja'
cmake -S $name-$version -B build $PKGMK_CEPH \
-D CMAKE_INSTALL_PREFIX=/usr \
-D CMAKE_INSTALL_LIBDIR=/usr/lib \
-D CMAKE_INSTALL_LIBEXECDIR=lib/$name \
-D CMAKE_BUILD_TYPE=Release \
-D CMAKE_CXX_FLAGS_RELEASE="$CXXFLAGS" \
-D CMAKE_C_FLAGS_RELEASE="$CFLAGS" \
-D WITH_SYSTEM_BOOST=ON \
-D WITH_MANPAGE=ON \
-D WITH_SYSTEM_NPM=ON \
-D WITH_LIBURING=ON \
-D WITH_SYSTEM_LIBURING=ON \
-D WITH_SYSTEM_ROCKSDB:BOOL=ON \
-D WITH_PYTHON3=3 \
-D WITH_LTTNG=OFF \
-D WITH_RDMA=OFF \
-D WITH_SYSTEMD=OFF \
-D WITH_SPDK=OFF \
-D WITH_BABELTRACE=OFF \
-D WITH_RADOSGW_AMQP_ENDPOINT=OFF \
-D WITH_TESTS=OFF \
-D WITH_REENTRANT_STRSIGNAL:BOOL=ON \
-Wno-dev
cmake --build build
DESTDIR=$PKG cmake --install build
find $PKG -name README.md -exec rm '{}' \+
# remove the upstream init file
rm -f $PKG/etc/init.d/ceph
rm -r $PKG/usr/share/ceph/mgr/dashboard/frontend/node_modules/.cache
rm -r $PKG/usr/share/ceph/mgr/dashboard/frontend/node_modules/.cli-ngcc
# move mount.* binaries to /sbin
install -d $PKG/sbin
mv $PKG/usr/sbin/mount.* $PKG/sbin
install -m 644 -D $name-$version/src/etc-rbdmap $PKG/etc/ceph/rbdmap
install -m 644 -D $name-$version/src/logrotate.conf $PKG/etc/logrotate.d/ceph
install -m 644 -D $name-$version/etc/sysctl/90-ceph-osd.conf $PKG/etc/sysctl.d/90-ceph-osd.conf
# udev rules
install -m 644 -D $name-$version/udev/50-rbd.rules $PKG/etc/udev/rules.d/50-rbd.rules
# sudoers.d
install -m 600 -D $name-$version/sudoers.d/ceph-osd-smartctl $PKG/etc/sudoers.d/ceph-osd-smartctl
}

17
ceph/ceph.confd Normal file
View File

@ -0,0 +1,17 @@
# Original source: https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-cluster/ceph/files/ceph.confd-r5
# Example
# default ceph conf file
#ceph_conf="/etc/ceph/ceph.conf"
# Set RADOSGW_WANT_NAME_PARAM=y in order to make the init script add
# a --name=client.${RC_SVCNAME} parameter to command_args for radosgw.*
# service instances. This will make the service use a key by the name
# of client.${RC_SVCNAME} instead of the default client.admin key.
# A setting like this in the ceph config file can be used to customize
# the rgw_data and keyring paths used by radosgw instances:
# [client]
# rgw_data = /var/lib/ceph/radosgw/$cluster-$id
# keyring = /var/lib/ceph/radosgw/$cluster-$id/keyring
RADOSGW_WANT_NAME_PARAM=n

118
ceph/ceph.initd Normal file
View File

@ -0,0 +1,118 @@
#!/sbin/openrc-run
# Original source: https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-cluster/ceph/files/ceph.initd-r12
# make sure /etc/conf.d/ceph gets loaded for ceph-mon etc
_CONFD_FILE="${RC_SERVICE%/*}/../conf.d/${RC_SVCNAME%-*}"
if [ -r "${_CONFD_FILE}" ]; then
. "${_CONFD_FILE}" || exit 1
fi
: "${ceph_conf:=/etc/ceph/ceph.conf}"
daemon_type="${RC_SVCNAME#ceph-}"
daemon_type="${daemon_type%%.*}"
daemon_id="${RC_SVCNAME#ceph-*.}"
daemon_id="${daemon_id:-0}"
: "${rundir:=/run/ceph}"
: "${user:=ceph}"
: "${group:=ceph}"
: "${rc_ulimit:=-n 1048576 -u 1048576}"
pidfile="${rundir}/supervisor-${daemon_type}.${daemon_id}.pid"
daemon_pidfile="${rundir}/${daemon_type}.${daemon_id}.pid"
command="/usr/bin/${RC_SVCNAME%%.*}"
command_args="-i ${daemon_id} --pid-file ${daemon_pidfile} -c ${ceph_conf}"
extra_commands="${extra_commands} reload"
command_args_foreground="--foreground"
retry="${CEPH_TERMTIMEOUT:-TERM/120/KILL/5}"
start_stop_daemon_args="--user ${user} --group ${group}"
supervise_daemon_args="--user ${user} --group ${group}"
: "${supervisor:=supervise-daemon}"
: "${stdout:=/var/log/ceph/ceph}"
: "${stderr:=/var/log/ceph/ceph}"
: "${respawn_delay:=10}"
: "${respawn_max:=5}"
: "${respawn_period:=1800}"
: "${osd_respawn_delay:=15}"
: "{osd_respawn_max:=10}"
: "{radosgw_respawn_max:=5}"
: "${radosgw_respawn_period:=30}"
depend() {
use dns logger
after net ntpd ntp-client chronyd
before netmount
}
is_type_valid() {
case ${daemon_type} in
mon|mds|osd|mgr|radosgw) return 0;;
*) return 1;;
esac
}
start_pre() {
local log_dir
export CEPH_CONF="${ceph_conf}"
checkpath -d -q -o "${user}:${group}" "${rundir}"
if ! is_type_valid ;then
eerror "Please give valid Ceph Server Type: mds, mon, osd"
return 1
elif pgrep -f "[c]eph-${daemon_type} -i ${daemon_id} "; then
eerror "${daemon_type}.${daemon_id} is still running, refusing to start"
return 1
fi
if [ -n "${bluestore_osd_fsid}" ]; then
einfo "Mounting Bluestore"
ceph-volume lvm activate "${daemon_id}" "${bluestore_osd_fsid}" --no-systemd
fi
if [ "${daemon_type}" = radosgw ] && [ "${RADOSGW_WANT_NAME_PARAM}" = y ]; then
command_args="${command_args} --name client.${daemon_id}"
fi
local arg_name arg_val repl_arg_name
for arg_name in stdout stderr respawn_delay respawn_max respawn_period; do
eval arg_val="\${${daemon_type}_${arg_name}}"
if [ -z "${arg_val}" ]; then
eval arg_val="\${${arg_name}}"
else
eval "${arg_name}=\"${arg_val}\""
fi
if [ "${arg_name}" = "stderr" ] || [ "${arg_name}" = "stdout" ]; then
local log_file log_postfix
log_postfix=".${daemon_id}-${arg_name}.log"
log_file="${arg_val}"
if [ "${log_file}" != /dev/null ]; then
log_file="${log_file}${log_postfix}"
log_dir="$(dirname "${log_file}")"
checkpath -m 0755 -o "${user}:${group}" -d "${log_dir}"
fi
repl_arg_name="$(printf -- "%s\n" "${arg_name}" | tr _ -)"
supervise_daemon_args="${supervise_daemon_args} --${repl_arg_name}=${log_file}"
fi
done
}
reload() {
ebegin "Reloading Ceph ${daemon_type}.${daemon_id}"
start-stop-daemon --signal 1 "${start_stop_daemon_args}"
eend ${?}
}
# vim:ft=gentoo-init-d:ts=4:sts=4:sw=4:noet: