libidn133: initial commit, version 1.33
This commit is contained in:
parent
cc8643afb8
commit
ba9d94dfea
4
libidn133/.footprint
Normal file
4
libidn133/.footprint
Normal file
@ -0,0 +1,4 @@
|
||||
drwxr-xr-x root/root usr/
|
||||
drwxr-xr-x root/root usr/lib/
|
||||
lrwxrwxrwx root/root usr/lib/libidn.so.11 -> libidn.so.11.6.16
|
||||
-rwxr-xr-x root/root usr/lib/libidn.so.11.6.16
|
7
libidn133/.signature
Normal file
7
libidn133/.signature
Normal file
@ -0,0 +1,7 @@
|
||||
untrusted comment: verify with /etc/ports/contrib.pub
|
||||
RWSagIOpLGJF30hdlJS4km8ghEjaoBmbj8eSa/qTebSGa0hXnvsM3vJtjsXYMqzwENd1WTf3n4lXzK9/OFkJO94OhPAbM5AiBws=
|
||||
SHA256 (Pkgfile) = f4144f7c043c5726947b5b64f078414264278524e74ab6a3867efde4d7e11f28
|
||||
SHA256 (.footprint) = 7347d922e01c1b64aed7e707e7e528c539f66c5a22703ba8dc9e161b1da33cdc
|
||||
SHA256 (libidn-1.33.tar.gz) = 44a7aab635bb721ceef6beecc4d49dfd19478325e1b47f3196f7d2acc4930e19
|
||||
SHA256 (libidn11-subdirs.patch) = 4531cc290bcdbae8a87c135634f2928576521bfa4d259b1eea4c2c8e36e65692
|
||||
SHA256 (makefile.patch) = a6cf1164263ec020af9dec7703b06c56874dbcd9324b1670c0425204dc5acc20
|
23
libidn133/Pkgfile
Normal file
23
libidn133/Pkgfile
Normal file
@ -0,0 +1,23 @@
|
||||
# Description: Provides support for IETF Internationalized Domain Names (IDN).
|
||||
# URL: https://www.gnu.org/software/libidn/
|
||||
# Maintainer: Tim Biermann, tbier at posteo dot de
|
||||
# Depends on: automake-114
|
||||
|
||||
name=libidn133
|
||||
version=1.33
|
||||
release=1
|
||||
source=(https://ftp.gnu.org/gnu/libidn/libidn-$version.tar.gz
|
||||
libidn11-subdirs.patch makefile.patch)
|
||||
|
||||
build() {
|
||||
cd libidn-$version
|
||||
|
||||
./configure \
|
||||
--prefix='/usr' \
|
||||
--disable-nls \
|
||||
--disable-static
|
||||
make
|
||||
make DESTDIR=$PKG install
|
||||
|
||||
rm -r $PKG/usr/{bin,include,lib/{libidn.so,libidn.la,pkgconfig},share}
|
||||
}
|
13
libidn133/libidn11-subdirs.patch
Normal file
13
libidn133/libidn11-subdirs.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -rupN libidn.orig/Makefile.am libidn/Makefile.am
|
||||
--- libidn.orig/Makefile.am 2018-10-16 20:36:07.230954718 +0200
|
||||
+++ libidn/Makefile.am 2018-10-16 20:38:19.038641175 +0200
|
||||
@@ -16,8 +16,7 @@
|
||||
# You should have received a copy of the GNU General Public License
|
||||
# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
|
||||
-SUBDIRS = gl lib/gl lib po src doc gltests lib/gltests tests examples \
|
||||
- java csharp
|
||||
+SUBDIRS = gl lib/gl lib
|
||||
|
||||
EXTRA_DIST = cfg.mk maint.mk .clcopying
|
||||
EXTRA_DIST += COPYING.LESSERv2 COPYING.LESSERv3 COPYINGv2 COPYINGv3
|
42
libidn133/makefile.patch
Normal file
42
libidn133/makefile.patch
Normal file
@ -0,0 +1,42 @@
|
||||
diff -Naur libidn-1.33.orig/Makefile.am libidn-1.33/Makefile.am
|
||||
--- libidn-1.33.orig/Makefile.am 2021-09-06 15:02:37.335225836 +0200
|
||||
+++ libidn-1.33/Makefile.am 2021-09-06 15:03:12.460226448 +0200
|
||||
@@ -16,8 +16,7 @@
|
||||
# You should have received a copy of the GNU General Public License
|
||||
# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
|
||||
-SUBDIRS = gl lib/gl lib po src doc gltests lib/gltests tests examples \
|
||||
- java csharp
|
||||
+SUBDIRS = gl lib/gl lib
|
||||
|
||||
EXTRA_DIST = cfg.mk maint.mk .clcopying
|
||||
EXTRA_DIST += COPYING.LESSERv2 COPYING.LESSERv3 COPYINGv2 COPYINGv3
|
||||
diff -Naur libidn-1.33.orig/cfg.mk libidn-1.33/cfg.mk
|
||||
--- libidn-1.33.orig/cfg.mk 2021-09-06 15:02:37.323225836 +0200
|
||||
+++ libidn-1.33/cfg.mk 2021-09-06 15:06:00.011229365 +0200
|
||||
@@ -39,25 +39,6 @@
|
||||
exclude_file_name_regexp--sc_useless_cpp_parens = ^lib/nfkc.c$$
|
||||
exclude_file_name_regexp--sc_prohibit_strncpy = ^src/idn.c$$
|
||||
|
||||
-doc/Makefile.gdoc:
|
||||
- printf "gdoc_MANS =\ngdoc_TEXINFOS =\n" > doc/Makefile.gdoc
|
||||
-
|
||||
-autoreconf: doc/Makefile.gdoc
|
||||
- for f in po/*.po.in; do \
|
||||
- cp $$f `echo $$f | sed 's/.in//'`; \
|
||||
- done
|
||||
- touch ChangeLog
|
||||
- mv build-aux/config.rpath build-aux/config.rpath-
|
||||
- test -f ./configure || autoreconf --install
|
||||
- mv build-aux/config.rpath- build-aux/config.rpath
|
||||
-
|
||||
-update-po: refresh-po
|
||||
- for f in `ls po/*.po | grep -v quot.po`; do \
|
||||
- cp $$f $$f.in; \
|
||||
- done
|
||||
- git add po/*.po.in
|
||||
- git commit -m "Sync with TP." po/LINGUAS po/*.po.in
|
||||
-
|
||||
bootstrap: autoreconf
|
||||
./configure $(CFGFLAGS)
|
||||
|
Loading…
x
Reference in New Issue
Block a user