pjsua: 2.6 -> 2.10

This commit is contained in:
Tim Biermann 2020-05-25 18:59:17 +00:00
parent 9b821ff4ad
commit c2b214b321
6 changed files with 80 additions and 57 deletions

View File

@ -1,3 +1,12 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/pjsua
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/lib/python3.7/
drwxr-xr-x root/root usr/lib/python3.7/site-packages/
drwxr-xr-x root/root usr/lib/python3.7/site-packages/__pycache__/
-rw-r--r-- root/root usr/lib/python3.7/site-packages/__pycache__/pjsua2.cpython-37.opt-1.pyc
-rw-r--r-- root/root usr/lib/python3.7/site-packages/__pycache__/pjsua2.cpython-37.pyc
-rwxr-xr-x root/root usr/lib/python3.7/site-packages/_pjsua2.cpython-37m-x86_64-linux-gnu.so
-rw-r--r-- root/root usr/lib/python3.7/site-packages/pjsua2-2.10-py3.7.egg-info
-rw-r--r-- root/root usr/lib/python3.7/site-packages/pjsua2.py

View File

@ -1,6 +1,7 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF338a/NrlzHcl2v0s1i8NAmhz+yb2yB4KzPI8fpGwBlxF2IfDwUSInnKmVtQDO/MqMfSSvYTyywPShGUWnCdcyw8=
SHA256 (Pkgfile) = 43e10065bd24e7aee6480a449be303c75887db7a13a8fcd95bf5b285855e8c98
SHA256 (.footprint) = 6d1a04bb5133176434b03f3bca387a46b0ea84f759a937aa5e5bb9a53108d9dd
SHA256 (pjproject-2.6.tar.bz2) = 2f5a1da1c174d845871c758bd80fbb580fca7799d3cfaa0d3c4e082b5161c7b4
SHA256 (config_site.h) = ed96788ee5309c9be6decb20bd5e8f53224a75fee59d8dcfce2f746207a3fd05
RWSagIOpLGJF32UZqkEkQ3dAGkpT33NBoDIMYChEN6/amhygea61QeEgHRzicV+wOu/Rgnv+XMTuOeXsfHnIFpZFCkw6PHsNYgk=
SHA256 (Pkgfile) = 813f7d00eb1e3c8f5ee1bf840fd9fd454c363202b4e56ab3d3818577f74146b3
SHA256 (.footprint) = 355ab182d0044fcfd7b0ff8b008f885f6d85118efcb473efde1a5b1fc21327a3
SHA256 (pjproject-2.10.tar.gz) = 936a4c5b98601b52325463a397ddf11ab4106c6a7b04f8dc7cdd377efbb597de
SHA256 (config_site.h) = 61fa2a76d069aa5c95b6e2c539f7b20e2ccf0b126fc60c18117762541d0a7472
SHA256 (0001-Don-t-build-Java-bindings.patch) = c6673d97185c2383140b6d915aeaa7e525c9cfb5f51c097472cf4773b4f87ab4

View File

@ -0,0 +1,26 @@
From c80630d6923f50b29fc136e75a8bed5de4ae50dd Mon Sep 17 00:00:00 2001
From: Caleb Maclennan <caleb@alerque.com>
Date: Sat, 22 Feb 2020 04:54:58 +0000
Subject: [PATCH] Don't build Java bindings
Signed-off-by: Caleb Maclennan <caleb@alerque.com>
---
pjsip-apps/src/swig/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/pjsip-apps/src/swig/Makefile b/pjsip-apps/src/swig/Makefile
index abb317b..1f4759f 100644
--- a/pjsip-apps/src/swig/Makefile
+++ b/pjsip-apps/src/swig/Makefile
@@ -7,7 +7,7 @@ else
ifneq ($(findstring ios,$(TARGET_NAME)),)
LANG = csharp
else
- LANG = python java
+ LANG = python
endif
endif
--
2.25.1

View File

@ -1,15 +1,13 @@
# Description: Multimedia communication library
# URL: http://www.pjsip.org/
# Packager: Alan Mizrahi, alan at mizrahi dot com dot ve
# Depends on: pjproject
# Description: Multimedia communication library
# URL: http://www.pjsip.org/
# Packager: Alan Mizrahi, alan at mizrahi dot com dot ve
# Depends on: pjproject swig
name=pjsua
version=2.6
release=2
source=(
http://www.pjsip.org/release/$version/pjproject-$version.tar.bz2
config_site.h
)
version=2.10
release=1
source=(https://github.com/pjsip/pjproject/archive/$version/pjproject-$version.tar.gz
config_site.h 0001-Don-t-build-Java-bindings.patch)
# Related ports:
# pjsua: Standalone user-agent.
@ -17,34 +15,38 @@ config_site.h
# pjproject: Libraries with most things enabled. Static and dynamic libraries.
build() {
cd pjproject-$version
cd pjproject-$version
patch -Np1 -i $SRC/0001-Don-t-build-Java-bindings.patch
export CFLAGS="$CFLAGS -DNDEBUG"
export CFLAGS+=" -fPIC -DNDEBUG -Wno-error=deprecated-declarations"
export CXXFLAGS+=" -fPIC -DNDEBUG -Wno-error=deprecated-declarations"
# pjsua will be dynamically linked as long as pjproject is installed beforehand.
# otherwise it will be statically linked.
./configure \
--prefix=/usr \
--with-external-pa \
--with-external-gsm \
--with-external-speex \
--with-external-srtp \
--with-sdl=/usr \
--disable-openh264 \
--enable-libsamplerate \
--disable-resample_dll \
$( [ -f /usr/lib/libpjsua.so ] && echo --enable-shared )
# pjsua will be dynamically linked as long as pjproject is installed beforehand.
# otherwise it will be statically linked.
./configure \
--prefix=/usr \
--with-external-pa \
--with-external-gsm \
--with-external-speex \
--with-external-srtp \
--with-sdl=/usr \
--disable-openh264 \
--enable-libsamplerate \
--disable-resample_dll \
$( [ -f /usr/lib/libpjsua.so ] && echo --enable-shared )
cp $SRC/config_site.h pjlib/include/pj/config_site.h
cp $SRC/config_site.h pjlib/include/pj/config_site.h
make dep
make -j1 dep
make -j1
# would be nice if something like this worked:
# make -j1 -C pjsip-apps/build pjsua-`./config.guess`
make -j1 -C pjsip-apps/src/swig
pushd pjsip-apps/src/swig/python
python3 setup.py build
python3 setup.py install --root=$PKG --optimize=1 --skip-build
popd
make DESTDIR=$PKG -j1 -C pjsip-apps/src/swig
# but for now:
make
# install pjsua only
install -D -m755 pjsip-apps/bin/pjsua-`./config.guess` $PKG/usr/bin/pjsua
# install pjsua only
install -D -m755 pjsip-apps/bin/pjsua-`./config.guess` $PKG/usr/bin/pjsua
}

View File

@ -1,6 +1,3 @@
#define PJMEDIA_HAS_VIDEO 1
// #define PJMEDIA_AUDIO_DEV_HAS_PORTAUDIO 1
// #define PJMEDIA_AUDIO_DEV_HAS_ALSA 1
#define PJMEDIA_HAS_FFMPEG 1
#define PJMEDIA_HAS_OPENH264_CODEC 0
// #include <pj/config_site_sample.h>
#define PJ_DEBUG 0
#define PJ_TIMER_DEBUG 0
#define PJ_HAS_IPV6 1

View File

@ -1,12 +0,0 @@
diff -ru pjproject-2.4.orig/pjmedia/src/pjmedia/resample_libsamplerate.c pjproject-2.4/pjmedia/src/pjmedia/resample_libsamplerate.c
--- pjproject-2.4.orig/pjmedia/src/pjmedia/resample_libsamplerate.c 2015-08-05 09:37:02.714255339 +0900
+++ pjproject-2.4/pjmedia/src/pjmedia/resample_libsamplerate.c 2015-08-05 09:38:44.601257767 +0900
@@ -33,7 +33,7 @@
#if PJMEDIA_RESAMPLE_IMP==PJMEDIA_RESAMPLE_LIBSAMPLERATE
-#include "../../third_party/libsamplerate/src/samplerate.h"
+#include <samplerate.h>
#define THIS_FILE "resample_libsamplerate.c"