scribus: deleted unmaintained port

This commit is contained in:
Tim Biermann 2021-03-04 09:38:44 +00:00
parent 8a022df9f5
commit c7e439a266
Signed by: tb
GPG Key ID: 42F8B4E30B673606
5 changed files with 0 additions and 2161 deletions

File diff suppressed because it is too large Load Diff

View File

@ -1,6 +0,0 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF313m6c4k1hmQ4N4WX6W5eXikeBuJPJrJRpU2a5Jgb10zrUjU85LYxICvKa1iknGqCvwn3801/qkNKKvQVMQKgg0=
SHA256 (Pkgfile) = b8e44e47d7209bdcf909c5441c71615a9c57f20fe12aae0a1a7b5d2787372838
SHA256 (.footprint) = 833e7fc010236a1ab333bd103b2d72b50fa75565c720ad10b54274d6de0678a1
SHA256 (scribus-1.5.6.1.tar.xz) = d4257695539cfa40dead8abdaf04c51e34d4d74bcad5a2c934d08e6e9d43b7ab
SHA256 (poppler-0.90.0.tar.xz) = 94edb0ad3330b74d22caac807aa501e9cc61cbf45a8010625670428b51989685

View File

@ -1,70 +0,0 @@
# Description: layout tool
# URL: http://scribus.net
# Maintainer: Thomas Penteker, tek at serverop dot de
# Depends on: boost cups harfbuzz-icu hunspell libart_lgpl poppler qt5
name=scribus
version=1.5.6.1
release=1
source=(https://downloads.sourceforge.net/$name/$name-$version.tar.xz
https://poppler.freedesktop.org/poppler-0.90.0.tar.xz)
# snatched from contrib/inkscape, thx romster :>
poppler() {
cmake -Spoppler-0.90.0 -Bbuild-poppler -GNinja \
-D CMAKE_INSTALL_PREFIX=$SRC/poppler \
-D CMAKE_INSTALL_LIBDIR=$SRC/poppler/lib \
-D CMAKE_BUILD_TYPE=Release \
-D CMAKE_CXX_FLAGS_RELEASE="$CXXFLAGS" \
-D CMAKE_C_FLAGS_RELEASE="$CFLAGS" \
-D ENABLE_UNSTABLE_API_ABI_HEADERS=ON \
-D ENABLE_UTILS=ON \
-D ENABLE_SPLASH=ON \
-D ENABLE_CPP=ON \
-D ENABLE_GLIB=ON \
-D ENABLE_QT5=OFF \
-D ENABLE_ZLIB=ON \
-D ENABLE_CMS=lcms2 \
-D ENABLE_LIBOPENJPEG=none \
-D WITH_NSS3=OFF \
-Wno-dev
cmake --build build-poppler
cmake --install build-poppler
install -D -t $PKG/usr/lib/ $SRC/poppler/lib/libpoppler.so.101
export CXXFLAGS+=" -I$SRC/poppler/include -I$SRC/poppler/include/poppler"
export PKG_CONFIG_PATH="$SRC/poppler/lib/pkgconfig:$PKG_CONFIG_PATH"
cd $SRC
}
build() {
# build a static poppler to use with the build
# scribus is using the internal poppler api which
# is known to break every other release
[ ! -e '/usr/lib/libpoppler.so.101' ] && poppler
sed \
-e 's|#!/usr/bin/python|#!/usr/bin/python3|' \
-e 's|#!/usr/bin/env python|#!/usr/bin/env python3|' \
-i $name-$version/scribus/plugins/scriptplugin/{samples,scripts}/*
cmake -S $name-$version -B build -G Ninja \
-D CMAKE_INSTALL_PREFIX=/usr \
-D CMAKE_BUILD_TYPE=Release \
-D CMAKE_CXX_FLAGS_RELEASE="$CXXFLAGS" \
-D CMAKE_C_FLAGS_RELEASE="$CFLAGS" \
-Wno-dev
cmake --build build
DESTDIR=$PKG cmake --install build
rm -r $PKG/usr/share/man/??
rm -r $PKG/usr/share/doc
find $PKG \( \
-iname '*changelog*' -o \
-iname '*news*' -o \
-iname '*todo*' -o \
-iname '*readme*' -o \
-iname '*copying*' \) -exec rm -fr '{}' \+
}

View File

@ -1,12 +0,0 @@
diff --git a/scribus/plugins/tools/2geomtools/CMakeLists.txt b/scribus/plugins/tools/2geomtools/CMakeLists.txt
index 9b6683cbb..d2e1ee5ea 100644
--- a/scribus/plugins/tools/2geomtools/CMakeLists.txt
+++ b/scribus/plugins/tools/2geomtools/CMakeLists.txt
@@ -3,6 +3,6 @@ include_directories(
${CMAKE_SOURCE_DIR}/scribus
)
-include_directories( ${Boost_INCLUDE_DIR} )
+include_directories( ${Boost_INCLUDE_DIRS} )
add_subdirectory (meshdistortion)
add_subdirectory (pathalongpath)

View File

@ -1,186 +0,0 @@
diff --git a/scribus/plugins/import/pdf/importpdf.cpp b/scribus/plugins/import/pdf/importpdf.cpp
index 427cd66ef..7fe18d86b 100644
--- a/scribus/plugins/import/pdf/importpdf.cpp
+++ b/scribus/plugins/import/pdf/importpdf.cpp
@@ -792,13 +792,13 @@ bool PdfPlug::convert(const QString& fn)
if (names.isDict())
{
LinkAction *linkAction = nullptr;
- linkAction = LinkAction::parseAction(&names, pdfDoc->getCatalog()->getBaseURI());
+ linkAction = LinkAction::parseAction(&names, pdfDoc->getCatalog()->getBaseURI()).get();
if (linkAction)
{
LinkJavaScript *jsa = (LinkJavaScript*)linkAction;
if (jsa->isOk())
{
- QString script = UnicodeParsedString(jsa->getScript());
+ QString script = QString::fromStdString(jsa->getScript());
if (script.startsWith("this."))
{
script.remove(0, 5);
diff --git a/scribus/plugins/import/pdf/slaoutput.cpp b/scribus/plugins/import/pdf/slaoutput.cpp
index 93ceb1e30..d14dfa1d9 100644
--- a/scribus/plugins/import/pdf/slaoutput.cpp
+++ b/scribus/plugins/import/pdf/slaoutput.cpp
@@ -289,7 +289,7 @@ LinkAction* SlaOutputDev::SC_getAdditionalAction(const char *key, AnnotWidget *a
{
Object actionObject = additionalActionsObject.dictLookup(key);
if (actionObject.isDict())
- linkAction = LinkAction::parseAction(&actionObject, pdfDoc->getCatalog()->getBaseURI());
+ linkAction = LinkAction::parseAction(&actionObject, pdfDoc->getCatalog()->getBaseURI()).get();
}
}
return linkAction;
@@ -420,7 +420,7 @@ bool SlaOutputDev::handleLinkAnnot(Annot* annota, double xCoor, double yCoor, do
POPPLER_CONST GooString *ndst = gto->getNamedDest();
if (ndst)
{
- LinkDest *dstn = pdfDoc->findDest(ndst);
+ LinkDest *dstn = pdfDoc->findDest(ndst).get();
if (dstn)
{
if (dstn->getKind() == destXYZ)
@@ -464,7 +464,7 @@ bool SlaOutputDev::handleLinkAnnot(Annot* annota, double xCoor, double yCoor, do
POPPLER_CONST GooString *ndst = gto->getNamedDest();
if (ndst)
{
- LinkDest *dstn = pdfDoc->findDest(ndst);
+ LinkDest *dstn = pdfDoc->findDest(ndst).get();
if (dstn)
{
if (dstn->getKind() == destXYZ)
@@ -482,7 +482,7 @@ bool SlaOutputDev::handleLinkAnnot(Annot* annota, double xCoor, double yCoor, do
{
LinkURI *gto = (LinkURI*)act;
validLink = true;
- fileName = UnicodeParsedString(gto->getURI());
+ fileName = QString::fromStdString(gto->getURI());
}
if (validLink)
{
@@ -895,7 +895,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
if (jsa->isOk())
{
ite->annotation().setActionType(1);
- ite->annotation().setAction(UnicodeParsedString(jsa->getScript()));
+ ite->annotation().setAction(QString::fromStdString(jsa->getScript()));
}
}
else if (Lact->getKind() == actionGoTo)
@@ -932,7 +932,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
POPPLER_CONST GooString *ndst = gto->getNamedDest();
if (ndst)
{
- LinkDest *dstn = pdfDoc->findDest(ndst);
+ LinkDest *dstn = pdfDoc->findDest(ndst).get();
if (dstn)
{
if (dstn->getKind() == destXYZ)
@@ -984,7 +984,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
POPPLER_CONST GooString *ndst = gto->getNamedDest();
if (ndst)
{
- LinkDest *dstn = pdfDoc->findDest(ndst);
+ LinkDest *dstn = pdfDoc->findDest(ndst).get();
if (dstn)
{
if (dstn->getKind() == destXYZ)
@@ -1004,7 +1004,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
else if (Lact->getKind() == actionUnknown)
{
LinkUnknown *uno = (LinkUnknown*)Lact;
- QString actString = UnicodeParsedString(uno->getAction());
+ QString actString = QString::fromStdString(uno->getAction());
if (actString == "ResetForm")
{
ite->annotation().setActionType(4);
@@ -1048,7 +1048,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
{
LinkNamed *uno = (LinkNamed*)Lact;
ite->annotation().setActionType(10);
- ite->annotation().setAction(UnicodeParsedString(uno->getName()));
+ ite->annotation().setAction(QString::fromStdString(uno->getName()));
}
else
qDebug() << "Found unsupported Action of type" << Lact->getKind();
@@ -1061,7 +1061,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
if (jsa->isOk())
{
- ite->annotation().setD_act(UnicodeParsedString(jsa->getScript()));
+ ite->annotation().setD_act(QString::fromStdString(jsa->getScript()));
ite->annotation().setAAact(true);
}
}
@@ -1075,7 +1075,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
if (jsa->isOk())
{
- ite->annotation().setE_act(UnicodeParsedString(jsa->getScript()));
+ ite->annotation().setE_act(QString::fromStdString(jsa->getScript()));
ite->annotation().setAAact(true);
}
}
@@ -1089,7 +1089,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
if (jsa->isOk())
{
- ite->annotation().setX_act(UnicodeParsedString(jsa->getScript()));
+ ite->annotation().setX_act(QString::fromStdString(jsa->getScript()));
ite->annotation().setAAact(true);
}
}
@@ -1103,7 +1103,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
if (jsa->isOk())
{
- ite->annotation().setFo_act(UnicodeParsedString(jsa->getScript()));
+ ite->annotation().setFo_act(QString::fromStdString(jsa->getScript()));
ite->annotation().setAAact(true);
}
}
@@ -1117,7 +1117,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
if (jsa->isOk())
{
- ite->annotation().setBl_act(UnicodeParsedString(jsa->getScript()));
+ ite->annotation().setBl_act(QString::fromStdString(jsa->getScript()));
ite->annotation().setAAact(true);
}
}
@@ -1131,7 +1131,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
if (jsa->isOk())
{
- ite->annotation().setC_act(UnicodeParsedString(jsa->getScript()));
+ ite->annotation().setC_act(QString::fromStdString(jsa->getScript()));
ite->annotation().setAAact(true);
}
}
@@ -1145,7 +1145,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
if (jsa->isOk())
{
- ite->annotation().setF_act(UnicodeParsedString(jsa->getScript()));
+ ite->annotation().setF_act(QString::fromStdString(jsa->getScript()));
ite->annotation().setAAact(true);
ite->annotation().setFormat(5);
}
@@ -1160,7 +1160,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
if (jsa->isOk())
{
- ite->annotation().setK_act(UnicodeParsedString(jsa->getScript()));
+ ite->annotation().setK_act(QString::fromStdString(jsa->getScript()));
ite->annotation().setAAact(true);
ite->annotation().setFormat(5);
}
@@ -1175,7 +1175,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
if (jsa->isOk())
{
- ite->annotation().setV_act(UnicodeParsedString(jsa->getScript()));
+ ite->annotation().setV_act(QString::fromStdString(jsa->getScript()));
ite->annotation().setAAact(true);
}
}