python3-poetry-core: added patch from fedora
This commit is contained in:
parent
e0aeca92c8
commit
d3376576bd
@ -1,5 +1,6 @@
|
|||||||
untrusted comment: verify with /etc/ports/contrib.pub
|
untrusted comment: verify with /etc/ports/contrib.pub
|
||||||
RWSagIOpLGJF368mmVEesH92RZOzUF4M+CouwUYG7B6q+ggvspXbVDAfeDgFcdPLYE+2tzeokKpL5438ciFzlRgWmsw8H/nuGwU=
|
RWSagIOpLGJF3xN1/33IbQDsmTu4wWePm4ANtq5slD3A651btI6tk02EW8IeiOy1qM6ONasYFK7jGsd6gqBXmbMtkSAclIYw6wE=
|
||||||
SHA256 (Pkgfile) = a50384ef50945d5cdef85e8e0abf5778ba9f4fd508c400890279e4b7adc02a45
|
SHA256 (Pkgfile) = b90ac2320e8dbed260513511dccfeeb96d81d1f805436d8a32ba6840443f4df4
|
||||||
SHA256 (.footprint) = 3f42498c75abcc06e9a87ec5a683bd91cf31cbbb20ecae62d2416b90cf065544
|
SHA256 (.footprint) = 3f42498c75abcc06e9a87ec5a683bd91cf31cbbb20ecae62d2416b90cf065544
|
||||||
SHA256 (python3-poetry-core-1.0.7.tar.gz) = a4a99d2d0adb54d69acaa6d852bc9d41818b5a2d751aa23a9543e32bc4e6660d
|
SHA256 (python3-poetry-core-1.0.7.tar.gz) = a4a99d2d0adb54d69acaa6d852bc9d41818b5a2d751aa23a9543e32bc4e6660d
|
||||||
|
SHA256 (poetry-core-1.0.2-devendor.patch) = fea09474a042adb939bbb8628ec74c03888f75cf2f37ebf41f61809aafd41157
|
||||||
|
@ -5,11 +5,12 @@
|
|||||||
|
|
||||||
name=python3-poetry-core
|
name=python3-poetry-core
|
||||||
version=1.0.7
|
version=1.0.7
|
||||||
release=1
|
release=2
|
||||||
source=(https://github.com/python-poetry/poetry-core/archive/$version/$name-$version.tar.gz)
|
source=(https://github.com/python-poetry/poetry-core/archive/$version/$name-$version.tar.gz poetry-core-1.0.2-devendor.patch)
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd poetry-core-$version
|
cd poetry-core-$version
|
||||||
|
patch -Np1 -i $SRC/poetry-core-1.0.2-devendor.patch
|
||||||
sed -i '/^__version__/!d' poetry/core/__init__.py
|
sed -i '/^__version__/!d' poetry/core/__init__.py
|
||||||
rm -r poetry/core/_vendor
|
rm -r poetry/core/_vendor
|
||||||
rm poetry/__init__.py
|
rm poetry/__init__.py
|
||||||
|
32
python3-poetry-core/poetry-core-1.0.2-devendor.patch
Normal file
32
python3-poetry-core/poetry-core-1.0.2-devendor.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
diff --git a/pyproject.toml b/pyproject.toml
|
||||||
|
index d55b844..822c584 100644
|
||||||
|
--- a/pyproject.toml
|
||||||
|
+++ b/pyproject.toml
|
||||||
|
@@ -43,6 +43,13 @@ enum34 = {version = "^1.1.10", python = "~2.7"}
|
||||||
|
# required by tomlkit, jsonschema
|
||||||
|
functools32 = {version = "^3.2.3-2", python = "~2.7"}
|
||||||
|
|
||||||
|
+# moved here from vendors/pyproject.toml
|
||||||
|
+jsonschema = "^3.2.0"
|
||||||
|
+lark-parser = "^0.9.0"
|
||||||
|
+packaging = "*"
|
||||||
|
+pyrsistent = ">=0.16.0,<0.19.0"
|
||||||
|
+tomlkit = ">=0.7.0,<1.0.0"
|
||||||
|
+
|
||||||
|
[tool.poetry.dev-dependencies]
|
||||||
|
pre-commit = "^1.10"
|
||||||
|
pyrsistent = "^0.16.0"
|
||||||
|
diff --git a/vendors/pyproject.toml b/vendors/pyproject.toml
|
||||||
|
index 2671380..fb0b28e 100644
|
||||||
|
--- a/vendors/pyproject.toml
|
||||||
|
+++ b/vendors/pyproject.toml
|
||||||
|
@@ -20,9 +20,3 @@ classifiers = [
|
||||||
|
|
||||||
|
[tool.poetry.dependencies]
|
||||||
|
python = "^3.6"
|
||||||
|
-
|
||||||
|
-jsonschema = "^3.2.0"
|
||||||
|
-lark-parser = "^0.9.0"
|
||||||
|
-packaging = "^20.9"
|
||||||
|
-pyrsistent = "^0.16.0"
|
||||||
|
-tomlkit = ">=0.7.0,<1.0.0"
|
Loading…
x
Reference in New Issue
Block a user