cuda-fb: 11.5.1 -> 11.6.0

This commit is contained in:
Danny Rawlins 2022-02-20 02:28:50 +11:00
parent ccd6c7745a
commit d5a007fede
4 changed files with 526 additions and 2982 deletions

File diff suppressed because it is too large Load Diff

View File

@ -1,12 +1,11 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF3zuV/linSCWwVP+u8TMcPEt8dn3LMbbwgmtqfNlAr/qk54DobG7feq5icQeudCcjZJjGCAehXEHgtXLfUOufCwg=
SHA256 (Pkgfile) = 7fe6a46f15c15ebb47bba95a0a4dabf862f2101af9e734e71513e4dc22a1a60f
SHA256 (.footprint) = 653076b59f7d295320119439c7f4a787d72def55f2c613a4edd728a6f4d75812
SHA256 (cuda_11.5.1_495.29.05_linux.run) = 60bea2fc0fac95574015f865355afbf599422ec2c85554f5f052b292711a4bca
RWSagIOpLGJF35XC0dVZXcWaVhcY5fYRBLpLYbIGm9LLuWWeQyb8AfueiBUf/DtpbydhSYsH8Z61QVSWKCIRsf1Wrg6IFMwafgk=
SHA256 (Pkgfile) = 67fc08b7111edcff97850a128cdf4f92df2a30250d451d0bb3033b7bb375a337
SHA256 (.footprint) = 9f3c2f266894537356305a67a49b99db124fd14458f17cd288223c9c639f6685
SHA256 (cuda_11.6.0_510.39.01_linux.run) = 1783da6d63970786040980b57fa3cb6420142159fc7d0e66f8f05c4905d98c83
SHA256 (cuda.sh) = ab92658d9efa337f12da5b093d9a643c031c6067ffc30abd8e87bd7bedecf0c0
SHA256 (cuda.conf) = a65f7d96e2447eb40b1be9586b90eb0bd776a8938c93d21f9606d2880b548b28
SHA256 (cuda-fb.revdep) = b4beef4ac94f5fb418127b00cca7b011a6804d4e0d0a581986a5a028486aa349
SHA256 (cuda-findgllib_mk.diff) = bf0cfaf0462ceb7cd76185a07a97731a9b887b2dc935ae903910bd8aad64c927
SHA256 (accinj64.pc) = ec3d9bbf49dd9a0a549c6e44c3c2c6878ced2556e617f98c71745722c883586d
SHA256 (cublas.pc) = 72d18c1cfc6849c89d3046f7573f887bac1e42d0efb862814471151b679d4716
SHA256 (cuda.pc) = 1566130d367ae7ba253b54d7ab92f29d06053f7482382bee62aa03767d6fbabf

View File

@ -4,22 +4,16 @@
# Depends on: nvidia-fb lsb-release
name=cuda-fb
version=11.5.1
_driverver=495.29.05
release=2
version=11.6.0
_driverver=510.39.01
release=1
source=(http://developer.download.nvidia.com/compute/cuda/${version}/local_installers/cuda_${version}_${_driverver}_linux.run
cuda.sh cuda.conf $name.revdep
cuda-findgllib_mk.diff
*.pc)
build() {
sh cuda_${version}_${_driverver}_linux.run --target "${SRC}" --noexec
# Fix up samples that use findgllib_mk
for f in builds/cuda_samples/*/*/findgllib.mk; do
patch $f cuda-findgllib_mk.diff
done
cd builds
rm -r NVIDIA*.run bin
@ -41,8 +35,6 @@ build() {
# remove foreign archs
rm -r "${PKG}"/opt/cuda/nsight_compute/target/linux-desktop-glibc_2_19_0-ppc64le
rm -r "${PKG}"/opt/cuda/nsight_compute/target/linux-desktop-t210-a64
rm -r "${PKG}"/opt/cuda/nsight_systems/target-linux-armv8
rm "${PKG}"/opt/cuda/samples/common/lib/linux/{aarch64,armv7l}/libGLEW.a
# Define compilers for CUDA to use.
# This allows us to use older versions of GCC if we have to.

View File

@ -1,22 +0,0 @@
--- ./opt/cuda/samples/3_Imaging/bicubicTexture/findgllib.mk 2017-09-28 09:07:30.310563874 +0200
+++ findgllib.mk 2017-09-28 14:40:50.638930881 +0200
@@ -60,6 +60,7 @@
RHEL = $(shell echo $(DISTRO) | grep -i 'red\|rhel' >/dev/null 2>&1; echo $$?)
CENTOS = $(shell echo $(DISTRO) | grep -i centos >/dev/null 2>&1; echo $$?)
SUSE = $(shell echo $(DISTRO) | grep -i 'suse\|sles' >/dev/null 2>&1; echo $$?)
+ CRUX = $(shell echo $(DISTRO) | grep -i crux >/dev/null 2>&1; echo $$?)
ifeq ("$(UBUNTU)","0")
ifeq ($(HOST_ARCH)-$(TARGET_ARCH),x86_64-armv7l)
GLPATH := /usr/arm-linux-gnueabihf/lib
@@ -100,6 +101,11 @@
GLPATH ?= /usr/lib64/nvidia
GLLINK ?= -L/usr/lib64/nvidia
DFLT_PATH ?= /usr/lib64
+ endif
+ ifeq ("$(CRUX)","0")
+ GLPATH ?= /usr/lib/nvidia
+ GLLINK ?= -L/usr/lib/nvidia
+ DFLT_PATH ?= /usr/lib
endif
# find libGL, libGLU, libXi,