gcr: fixed build with gobject-introspection

This commit is contained in:
Tim Biermann 2022-02-27 20:53:32 +01:00
parent 039f15a167
commit df7bd8fc13
Signed by: tb
GPG Key ID: 42F8B4E30B673606
4 changed files with 70 additions and 22 deletions

View File

@ -74,10 +74,6 @@ drwxr-xr-x root/root usr/include/gcr-3/ui/
drwxr-xr-x root/root usr/lib/
-rwxr-xr-x root/root usr/lib/gcr-prompter
-rwxr-xr-x root/root usr/lib/gcr-ssh-askpass
drwxr-xr-x root/root usr/lib/girepository-1.0/
-rw-r--r-- root/root usr/lib/girepository-1.0/Gck-1.typelib
-rw-r--r-- root/root usr/lib/girepository-1.0/Gcr-3.typelib
-rw-r--r-- root/root usr/lib/girepository-1.0/GcrUi-3.typelib
lrwxrwxrwx root/root usr/lib/libgck-1.so -> libgck-1.so.0
lrwxrwxrwx root/root usr/lib/libgck-1.so.0 -> libgck-1.so.0.0.0
-rwxr-xr-x root/root usr/lib/libgck-1.so.0.0.0
@ -104,10 +100,6 @@ drwxr-xr-x root/root usr/share/dbus-1/
drwxr-xr-x root/root usr/share/dbus-1/services/
-rw-r--r-- root/root usr/share/dbus-1/services/org.gnome.keyring.PrivatePrompter.service
-rw-r--r-- root/root usr/share/dbus-1/services/org.gnome.keyring.SystemPrompter.service
drwxr-xr-x root/root usr/share/gir-1.0/
-rw-r--r-- root/root usr/share/gir-1.0/Gck-1.gir
-rw-r--r-- root/root usr/share/gir-1.0/Gcr-3.gir
-rw-r--r-- root/root usr/share/gir-1.0/GcrUi-3.gir
drwxr-xr-x root/root usr/share/glib-2.0/
drwxr-xr-x root/root usr/share/glib-2.0/schemas/
-rw-r--r-- root/root usr/share/glib-2.0/schemas/org.gnome.crypto.pgp.gschema.xml
@ -156,12 +148,3 @@ drwxr-xr-x root/root usr/share/icons/hicolor/48x48/apps/
drwxr-xr-x root/root usr/share/mime/
drwxr-xr-x root/root usr/share/mime/packages/
-rw-r--r-- root/root usr/share/mime/packages/gcr-crypto-types.xml
drwxr-xr-x root/root usr/share/vala/
drwxr-xr-x root/root usr/share/vala/vapi/
-rw-r--r-- root/root usr/share/vala/vapi/gck-1.deps
-rw-r--r-- root/root usr/share/vala/vapi/gck-1.vapi
-rw-r--r-- root/root usr/share/vala/vapi/gcr-3.deps
-rw-r--r-- root/root usr/share/vala/vapi/gcr-3.vapi
-rw-r--r-- root/root usr/share/vala/vapi/gcr-ui-3.deps
-rw-r--r-- root/root usr/share/vala/vapi/gcr-ui-3.vapi
-rw-r--r-- root/root usr/share/vala/vapi/pkcs11.vapi

View File

@ -1,5 +1,6 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF3zihsNfzfhF7Sfh9TL8cKSZnSFGoUuUokLvefRc6/8GLuosSUahMnqAxAI09UX/EFyUrSXjslEs7rjFvGbEOGg4=
SHA256 (Pkgfile) = 549311731da89694c87df4791e8ed0df65cd8738b4c92934406deb0864725b7a
SHA256 (.footprint) = b04d74c567e09f65d3a53dc094e083fa9b428632457a644e9019bdffe8a3fa27
RWSagIOpLGJF377PW5d8d1kUC74vMTpoHly2oc4w+LeX6OqE+hDrwM4ygpgmTinmE7w0X8leu4Y+Fjz66aaRDYSCUyLCOYyrYAI=
SHA256 (Pkgfile) = 774b7cec85f1fa479ed348cc57f8827032fabe4ad5b4f324d3be44ad18fe383d
SHA256 (.footprint) = 18e743378f7b515bea6ec8d9b3098f496f54d56bfc8c55079d3923d3da845ff0
SHA256 (gcr-3.40.0.tar.xz) = b9d3645a5fd953a54285cc64d4fc046736463dbd4dcc25caf5c7b59bed3027f5
SHA256 (fix-meson-invalid-kw-argument.patch) = 7f0d47b09170f988b226600c46241dcbd5bf3349f5ac6415a0030e401612a675

View File

@ -5,10 +5,13 @@
name=gcr
version=3.40.0
release=1
source=(https://download.gnome.org/sources/$name/${version:0:4}/$name-$version.tar.xz)
release=2
source=(https://download.gnome.org/sources/$name/${version:0:4}/$name-$version.tar.xz
fix-meson-invalid-kw-argument.patch)
build() {
patch -Np1 -d $name-$version -i $SRC/fix-meson-invalid-kw-argument.patch
meson setup build $name-$version \
--prefix=/usr \
--libexecdir=/usr/lib \

View File

@ -0,0 +1,61 @@
Patch-Source: https://gitlab.gnome.org/GNOME/gcr/-/merge_requests/81
From b3ca1d02bb0148ca787ac4aead164d7c8ce2c4d8 Mon Sep 17 00:00:00 2001
From: Jakub Jirutka <jakub@jirutka.cz>
Date: Wed, 12 Jan 2022 00:24:20 +0100
Subject: [PATCH] meson: Fix unknown kw argument in gnome.generate_gir
This argument has been removed in Meson 0.61.0:
gck/meson.build:130:2: ERROR: gnome.generate_gir got unknown keyword arguments "packages"
https://github.com/mesonbuild/meson/commit/f8fc5cb860465718fe7c79a1bf1fe00659f138de:
> The packages argument to gnome.generate_gir was allowed, but never did anything, so stop passing it.
Fixes #89
---
gck/meson.build | 1 -
gcr/meson.build | 1 -
ui/meson.build | 1 -
3 files changed, 3 deletions(-)
diff --git a/gck/meson.build b/gck/meson.build
index 756b486..a21a1e9 100644
--- a/gck/meson.build
+++ b/gck/meson.build
@@ -131,7 +131,6 @@ if get_option('introspection')
sources: gck_gir_sources,
namespace: 'Gck',
nsversion: '@0@'.format(gck_major_version),
- packages: gck_deps,
export_packages: 'gck-@0@'.format(gck_major_version),
includes: [ 'GObject-2.0', 'Gio-2.0' ],
header: 'gck/gck.h',
diff --git a/gcr/meson.build b/gcr/meson.build
index 2233a44..c83641b 100644
--- a/gcr/meson.build
+++ b/gcr/meson.build
@@ -190,7 +190,6 @@ if get_option('introspection')
sources: [ gcr_base_public_sources, gcr_base_headers ],
namespace: 'Gcr',
nsversion: '@0@'.format(gcr_major_version),
- packages: gcr_base_deps,
export_packages: 'gcr-base-@0@'.format(gcr_major_version),
includes: [
'GObject-2.0',
diff --git a/ui/meson.build b/ui/meson.build
index e656ea2..32ee057 100644
--- a/ui/meson.build
+++ b/ui/meson.build
@@ -152,7 +152,6 @@ if get_option('introspection')
export_packages: 'gcr-ui-@0@'.format(gcr_major_version),
identifier_prefix: 'Gcr',
symbol_prefix: 'gcr',
- packages: gcr_ui_deps,
includes: [
'GObject-2.0',
'Gio-2.0',
--
GitLab