python3-m2r: added patch to build against mistune0
This commit is contained in:
parent
b5c72c8e09
commit
e29a50d9b4
@ -5,13 +5,12 @@ drwxr-xr-x root/root usr/lib/
|
||||
drwxr-xr-x root/root usr/lib/python3.10/
|
||||
drwxr-xr-x root/root usr/lib/python3.10/site-packages/
|
||||
drwxr-xr-x root/root usr/lib/python3.10/site-packages/__pycache__/
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/__pycache__/m2r.cpython-310.pyc
|
||||
drwxr-xr-x root/root usr/lib/python3.10/site-packages/m2r-0.3.1-py3.10.egg-info/
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/m2r-0.3.1-py3.10.egg-info/PKG-INFO
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/m2r-0.3.1-py3.10.egg-info/SOURCES.txt
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/m2r-0.3.1-py3.10.egg-info/dependency_links.txt
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/m2r-0.3.1-py3.10.egg-info/entry_points.txt
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/m2r-0.3.1-py3.10.egg-info/not-zip-safe
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/m2r-0.3.1-py3.10.egg-info/requires.txt
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/m2r-0.3.1-py3.10.egg-info/top_level.txt
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/__pycache__/m2r.cpython-310.opt-2.pyc
|
||||
drwxr-xr-x root/root usr/lib/python3.10/site-packages/m2r-0.3.1.dist-info/
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/m2r-0.3.1.dist-info/LICENSE
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/m2r-0.3.1.dist-info/METADATA
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/m2r-0.3.1.dist-info/RECORD
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/m2r-0.3.1.dist-info/WHEEL
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/m2r-0.3.1.dist-info/entry_points.txt
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/m2r-0.3.1.dist-info/top_level.txt
|
||||
-rw-r--r-- root/root usr/lib/python3.10/site-packages/m2r.py
|
||||
|
@ -1,5 +1,6 @@
|
||||
untrusted comment: verify with /etc/ports/contrib.pub
|
||||
RWSagIOpLGJF38mZtW4K3nDJdkxo9uV9mcvs0v0dWSlpZe3yOrTZvSj3rBkcQGCejJwQtRhM5vHaZzXm6c36el0kndXPELmyagU=
|
||||
SHA256 (Pkgfile) = 7149d565c268138e9446c7837508f71c5ac26b749247f7ecd1e722fdc8c9ee5f
|
||||
SHA256 (.footprint) = 078d642a73066dd6c2ea2011792e1a61af014988977ef042cb8899c054e44ef5
|
||||
RWSagIOpLGJF36Rkh2JPwv9xv1eQK99ooAheQZA9cIEaXgVZjFv+/vvqttkfngSMhmDVCwVFOmdoGePbUBfF/XrW83ofPh2fwg0=
|
||||
SHA256 (Pkgfile) = dc608fc9254c7a6707535f5f0a740f803642703e0003225bc7d053ef88c9479f
|
||||
SHA256 (.footprint) = ccd4276763ff6bd7b92b5d6c00ec5e6b4f056bf261214207aa28a535abf6be0f
|
||||
SHA256 (python3-m2r-0.3.1.tar.gz) = db99105d3b43121ca31d543f561a2078c00d0b9d9d6a7062b64ca5d084a74288
|
||||
SHA256 (2003_mistune0.patch) = 5f6de275376c45438ae82cba4a4d233e249de4dd403dd294952c7ce181966759
|
||||
|
30
python3-m2r/2003_mistune0.patch
Normal file
30
python3-m2r/2003_mistune0.patch
Normal file
@ -0,0 +1,30 @@
|
||||
Description: use custom-named Python module mistune0
|
||||
Forwarded: not-needed
|
||||
Author: Jonas Smedegaard <dr@jones.dk>
|
||||
Bug-Debian: https://bugs.debian.org/1002163
|
||||
Bug-Debian: https://bugs.debian.org/1003571
|
||||
Last-Update: 2023-01-10
|
||||
---
|
||||
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
||||
--- a/m2r.py
|
||||
+++ b/m2r.py
|
||||
@@ -10,7 +10,7 @@
|
||||
from docutils import statemachine, nodes, io, utils
|
||||
from docutils.parsers import rst
|
||||
from docutils.utils import column_width
|
||||
-import mistune
|
||||
+import mistune0 as mistune
|
||||
from urllib.parse import urlparse
|
||||
|
||||
__version__ = '0.3.1'
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -16,7 +16,7 @@
|
||||
with open(readme_file) as f:
|
||||
readme = f.read()
|
||||
|
||||
-install_requires = ['mistune<2', 'docutils']
|
||||
+install_requires = ['mistune0', 'docutils']
|
||||
test_requirements = ['pygments']
|
||||
|
||||
setup(
|
@ -1,17 +1,19 @@
|
||||
# Description: Markdown to reStructuredText converter
|
||||
# URL: https://github.com/miyakogi/m2r
|
||||
# Maintainer: Tim Biermann, tbier at posteo dot de
|
||||
# Depends on: python3-docutils python3-mistune0
|
||||
# Depends on: python3-build python3-docutils python3-installer python3-mistune0 python3-wheel
|
||||
|
||||
name=python3-m2r
|
||||
version=0.3.1
|
||||
release=1
|
||||
source=(https://github.com/miyakogi/m2r/archive/v$version/$name-$version.tar.gz)
|
||||
source=(https://github.com/miyakogi/m2r/archive/v$version/$name-$version.tar.gz
|
||||
2003_mistune0.patch)
|
||||
|
||||
build() {
|
||||
cd m2r-$version
|
||||
/usr/bin/python3 setup.py build
|
||||
/usr/bin/python3 setup.py install --prefix=/usr \
|
||||
--root=$PKG \
|
||||
--skip-build
|
||||
|
||||
patch -Np1 -i $SRC/2003_mistune0.patch
|
||||
|
||||
/usr/bin/python3 -m build --wheel --skip-dependency-check --no-isolation
|
||||
/usr/bin/python3 -m installer --compile-bytecode 2 --destdir=$PKG dist/*.whl
|
||||
}
|
||||
|
Loading…
x
Reference in New Issue
Block a user