seahorse: fixed build with gnupg 2.4.0

This commit is contained in:
Tim Biermann 2022-12-28 12:49:58 +00:00
parent 7ed31e6b2e
commit e631c78ae1
3 changed files with 33 additions and 4 deletions

View File

@ -1,5 +1,6 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF3xsDgA6xxs4rAXl8ODBtbIPKzLMYR67huZxwUYWcElPsYn2x2AJxXPMEZ/oP9whkCILuNZERu0CidJHyikfBdwQ=
SHA256 (Pkgfile) = 85cd99e493f9f967065b6d0772a81acb2276b2b8c5791728901403e72aae04d2
RWSagIOpLGJF3/11kA543quAWyf05IUHQ1B7gPlmxRvIh/wvnjVKFaSSG78LNL4xwd4xCVq1sYORhJEP2lr5gUhV+75avtcL0A0=
SHA256 (Pkgfile) = cf49515c6bdaebbc4745d17e4818da5858d160dd345f8e8842662df7736eb9de
SHA256 (.footprint) = 51582fffa8800be19c93f2039234f7a925454c2aeac45460ec99e13de3ca28f6
SHA256 (seahorse-43.0.tar.bz2) = eb157d5275b385f0147af3f365ef69b55451ae7528df613c112d279106a22c9b
SHA256 (212.patch) = f6c52a137edb29246e5fd90d91bc87bd1fb4c8c48d0e14da7345aaed5caf2547

25
seahorse/212.patch Normal file
View File

@ -0,0 +1,25 @@
From 9260c74779be3d7a378db0671af862ffa3573d42 Mon Sep 17 00:00:00 2001
From: Xi Ruoyao <xry111@xry111.site>
Date: Wed, 21 Dec 2022 20:58:26 +0800
Subject: [PATCH] Allow building with GnuPG-2.4.x
---
meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index e29b5322..23d0b54f 100644
--- a/meson.build
+++ b/meson.build
@@ -26,7 +26,7 @@ endif
# Dependencies
min_glib_version = '2.66'
min_gcr_version = '3.38'
-accepted_gpg_versions = [ '2.2.0', '2.3.0' ]
+accepted_gpg_versions = [ '2.2.0', '2.3.0', '2.4.0' ]
gpg_check_version = find_program('build-aux' / 'gpg_check_version.py')
glib_deps = [
--
GitLab

View File

@ -6,14 +6,17 @@
name=seahorse
version=43.0
release=1
source=(https://gitlab.gnome.org/GNOME/seahorse/-/archive/$version/seahorse-$version.tar.bz2)
release=2
source=(https://gitlab.gnome.org/GNOME/seahorse/-/archive/$version/seahorse-$version.tar.bz2
212.patch)
build() {
prt-get isinst avahi || PKGMK_SEAHORSE+=' -D key-sharing=false'
prt-get isinst gpgme || PKGMK_SEAHORSE+=' -D pgp-support=false -D check-compatible-gpg=false'
prt-get isinst openldap || PKGMK_SEAHORSE+=' -D ldap-support=false -D hkp-support=false'
patch -Np1 -d $name-$version -i $SRC/212.patch
meson setup $name-$version build $PKGMK_SEAHORSE \
--prefix=/usr \
--libexecdir=/usr/lib/$name \