libva-vdpau-driver: dropped unmaintained port

This commit is contained in:
Tim Biermann 2023-09-24 09:32:53 +02:00
parent 7486d34d58
commit ef2b6369e3
Signed by: tb
GPG Key ID: 42F8B4E30B673606
8 changed files with 0 additions and 153 deletions

View File

@ -1,7 +0,0 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/lib/dri/
lrwxrwxrwx root/root usr/lib/dri/nvidia_drv_video.so -> vdpau_drv_video.so
lrwxrwxrwx root/root usr/lib/dri/s3g_drv_video.so -> vdpau_drv_video.so
-rwxr-xr-x root/root usr/lib/dri/vdpau_drv_video.la
-rwxr-xr-x root/root usr/lib/dri/vdpau_drv_video.so

View File

@ -1,10 +0,0 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF3+fl8AFPyPro2gcTsqSffzNG1G/XAl8ETpYTWJ5wA+uPL0xxNRrThC6Fzdyy7DooHNwDPZGnSn2ptUs+8Gw72QA=
SHA256 (Pkgfile) = 69682c84d2a60949cd88a9239e44661c15abce7460f134528b52a56274fe48ed
SHA256 (.footprint) = c5171012397e1889693c1bcabd77ad07959cde5d16fc1c020b3d1a5455d83f8d
SHA256 (libva-vdpau-driver-0.7.4.tar.bz2) = 155c1982f0ac3f5435ba20b221bcaa11be212c37db548cd1f2a030ffa17e9bb9
SHA256 (libva-vdpau-driver-0.7.4-glext-missing-definition.patch) = 776bfe4c101cdde396d8783029b288c6cd825d0cdbc782ca3d94a5f9ffb4558c
SHA256 (libva-vdpau-driver-0.7.4-libvdpau-0.8.patch) = 5e567b026b97dc0e207b6c05410cc1b7b77a58ceb5046801d0ea1a321cba3b9d
SHA256 (libva-vdpau-driver-0.7.4-VAEncH264VUIBufferType.patch) = 1ae32b8e5cca1717be4a63f09e8c6bd84a3e9b712b933816cdb32bb315dbda98
SHA256 (libva-vdpau-driver-0.7.4-sigfpe-crash.patch) = ef21397b0ed55f170e57fa1afef42b8b491491149af09b151f97ef3cc20ed0b7
SHA256 (libva-vdpau-driver-0.7.4-include-linux-videodev2.h.patch) = 0ddf889850c54ccace8ec61a232f04ab77495c495949f952363ad28e2fc9891d

View File

@ -1,34 +0,0 @@
# Description: VDPAU back-end for NVIDIA and VIA chipsets.
# URL: http://freedesktop.org/wiki/Software/vaapi
# Maintainer: unmaintained
# Depends on: libva libvdpau
name=libva-vdpau-driver
version=0.7.4
release=7
source=(https://www.freedesktop.org/software/vaapi/releases/$name/$name-$version.tar.bz2
libva-vdpau-driver-0.7.4-glext-missing-definition.patch
libva-vdpau-driver-0.7.4-libvdpau-0.8.patch
libva-vdpau-driver-0.7.4-VAEncH264VUIBufferType.patch
libva-vdpau-driver-0.7.4-sigfpe-crash.patch
libva-vdpau-driver-0.7.4-include-linux-videodev2.h.patch)
build() {
cd $name-$version
patch -p1 -i $SRC/libva-vdpau-driver-0.7.4-glext-missing-definition.patch
patch -p1 -i $SRC/libva-vdpau-driver-0.7.4-libvdpau-0.8.patch
patch -p1 -i $SRC/libva-vdpau-driver-0.7.4-VAEncH264VUIBufferType.patch
patch -p1 -i $SRC/libva-vdpau-driver-0.7.4-sigfpe-crash.patch
patch -p1 -i $SRC/libva-vdpau-driver-0.7.4-include-linux-videodev2.h.patch
sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac
autoreconf -i
./configure \
--prefix=/usr \
--enable-glx
make
make DESTDIR=$PKG install
}

View File

@ -1,29 +0,0 @@
>From fda3706eb74ba5ad874853969f3df3e372739c8d Mon Sep 17 00:00:00 2001
From: "Xiang, Haihao" <haihao.xiang@intel.com>
Date: Fri, 21 Jun 2013 12:55:30 +0800
Subject: [PATCH] VAEncH264VUIBufferType and VAEncH264SEIBufferType are
dropped from VA API
The driver doesn't use them indeed
Signed-off-by: Xiang, Haihao <haihao.xiang@intel.com>
---
src/vdpau_dump.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/src/vdpau_dump.c b/src/vdpau_dump.c
index 899888b..610e7cd 100644
--- a/src/vdpau_dump.c
+++ b/src/vdpau_dump.c
@@ -59,8 +59,6 @@ const char *string_of_VABufferType(VABufferType type)
_(VAEncSequenceParameterBufferType);
_(VAEncPictureParameterBufferType);
_(VAEncSliceParameterBufferType);
- _(VAEncH264VUIBufferType);
- _(VAEncH264SEIBufferType);
#endif
#if VA_CHECK_VERSION(0,31,1)
_(VAQMatrixBufferType);
--
1.7.9.5

View File

@ -1,16 +0,0 @@
--- a/src/utils_glx.h~ 2012-10-05 16:02:58.000000000 +0100
+++ b/src/utils_glx.h 2012-10-19 08:44:12.469642440 +0100
@@ -48,6 +48,13 @@
typedef void (*PFNGLXRELEASETEXIMAGEEXTPROC)(Display *, GLXDrawable, int);
#endif
+#if GL_GLEXT_VERSION >= 85
+/* XXX: PFNGLMULTITEXCOORD2FPROC got out of the GL_VERSION_1_3_DEPRECATED
+ block and is not defined if GL_VERSION_1_3 is defined in <GL/gl.h>
+ Redefine the type here as an interim solution */
+typedef void (*PFNGLMULTITEXCOORD2FPROC) (GLenum target, GLfloat s, GLfloat t);
+#endif
+
#ifndef GL_FRAMEBUFFER_BINDING
#define GL_FRAMEBUFFER_BINDING GL_FRAMEBUFFER_BINDING_EXT
#endif

View File

@ -1,25 +0,0 @@
https://bugs.gentoo.org/689530
libva commit 93c52a17b8d2 ("va_backend: remove unneeded
linux/videodev2.h include") removed an include that provided the
prototype of v4l2_format among other v4l2_* structs.
Without this or a forward declaration of 'struct v4l2_format', the prototype
and definition of vdpau_CreateSurfaceFromV4L2Buf() (which has a 'struct
v4l2_format *' parameter) are seen as conflicting.
Just include the removed header where we need it.
diff --git a/src/vdpau_driver.h b/src/vdpau_driver.h
index 6286d16..54d37fb 100644
--- a/src/vdpau_driver.h
+++ b/src/vdpau_driver.h
@@ -21,6 +21,8 @@
#ifndef VDPAU_DRIVER_H
#define VDPAU_DRIVER_H
+#include <linux/videodev2.h>
+
#include <va/va_backend.h>
#include "vaapi_compat.h"
#include "vdpau_gate.h"

View File

@ -1,11 +0,0 @@
--- a/src/vdpau_decode.c
+++ b/src/vdpau_decode.c
@@ -1289,7 +1289,7 @@
driver_data,
obj_context->vdp_decoder,
obj_surface->vdp_surface,
- (VdpPictureInfo)&obj_context->vdp_picture_info,
+ (VdpPictureInfo *)&obj_context->vdp_picture_info,
obj_context->vdp_bitstream_buffers_count,
obj_context->vdp_bitstream_buffers
);

View File

@ -1,21 +0,0 @@
Description: Fix a crash if a heap is destroyed before being initialized
Author: Sebastian Ramacher <sramacher@debian.org>
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=58836
Bug-Debian: http://bugs.debian.org/748294
Last-Update: 2014-06-02
--- vdpau-video-0.7.4.orig/src/object_heap.c
+++ vdpau-video-0.7.4/src/object_heap.c
@@ -272,8 +272,10 @@ object_heap_destroy(object_heap_p heap)
ASSERT(obj->next_free != ALLOCATED);
}
- for (i = 0; i < heap->heap_size / heap->heap_increment; i++) {
- free(heap->bucket[i]);
+ if (heap->bucket) {
+ for (i = 0; i < heap->heap_size / heap->heap_increment; i++) {
+ free(heap->bucket[i]);
+ }
}
pthread_mutex_destroy(&heap->mutex);