hnb: Initial commit

This commit is contained in:
James Mills 2006-11-14 06:43:10 +10:00
parent 727636db15
commit fea069f393
4 changed files with 53 additions and 0 deletions

6
hnb/.footprint Normal file
View File

@ -0,0 +1,6 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/hnb
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man1/
-r--r--r-- root/root usr/man/man1/hnb.1.gz

2
hnb/.md5sum Normal file
View File

@ -0,0 +1,2 @@
3a1fa5398be1111e5086008537a0d68e Makefile.patch
702867cb3f94936790493eb948c36412 hnb-1.9.18.tar.gz

22
hnb/Makefile.patch Normal file
View File

@ -0,0 +1,22 @@
--- Makefile 2003-03-10 12:22:23.000000000 +1000
+++ Makefile 2004-09-01 09:56:52.253390240 +1000
@@ -1,9 +1,17 @@
+prefix = /usr/local
+exec_prefix = ${prefix}
+
+bindir = ${exec_prefix}/bin
+mandir = ${prefix}/man
+
src/hnb: src/*.c src/*.h src/*.inc src/hnbrc.inc
(cd src;make)
+
install: src/hnb
- install -D src/hnb /usr/local/bin/hnb
- install -D -m444 doc/hnb.1 /usr/local/man/man1/hnb.1
+ install -D src/hnb ${bindir}/hnb
+ install -D -m444 doc/hnb.1 ${mandir}/man1/hnb.1
+
clean:
(cd src;make clean)
(cd util;make clean)

23
hnb/Pkgfile Normal file
View File

@ -0,0 +1,23 @@
# $Id: Pkgfile 1329 2006-11-13 20:42:18Z prologic $
# Description: Hierarchical notebook editor.
# URL: http://hnb.sourceforge.net/
# Packager: James Mills prologic at shortcircuit dot net dot au
# Maintainer: James Mills prologic at shortcircuit dot net dot au
#
# Depends on:
name=hnb
version=1.9.18
release=2
source=(http://hnb.sourceforge.net/.files/$name-$version.tar.gz \
Makefile.patch)
build () {
cd $name-$version
patch -i $SRC/Makefile.patch
sed -i "/^CFLAGS/s/-O2 -pipe/$CFLAGS/" Makefile
make
mkdir -p $PKG/usr/{bin,man/man1}
make prefix=$PKG/usr install
sed "s|$PKG||g" $SRC/$name-$version/doc/$name.1 > $PKG/usr/man/man1/$name.1
}