46 lines
1.7 KiB
Diff
46 lines
1.7 KiB
Diff
From 4b145ad444b8fc70b6cb375b6447e9c9793e2238 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Barnab=C3=A1s=20P=C5=91cze?= <pobrn@protonmail.com>
|
|
Date: Tue, 9 Jan 2024 19:22:07 +0100
|
|
Subject: [PATCH] spa: libcamera: bump minimum supported version to 0.2.0
|
|
|
|
---
|
|
spa/meson.build | 3 +--
|
|
spa/plugins/libcamera/libcamera-device.cpp | 2 --
|
|
2 files changed, 1 insertion(+), 4 deletions(-)
|
|
|
|
diff --git a/spa/meson.build b/spa/meson.build
|
|
index 841d27b409..ac20844ce3 100644
|
|
--- a/spa/meson.build
|
|
+++ b/spa/meson.build
|
|
@@ -96,9 +96,8 @@ if get_option('spa-plugins').allowed()
|
|
endif
|
|
summary({'Vulkan': have_vulkan}, bool_yn: true, section: 'Misc dependencies')
|
|
|
|
- libcamera_dep = dependency('libcamera', required: get_option('libcamera'))
|
|
+ libcamera_dep = dependency('libcamera', version: '>= 0.2.0', required: get_option('libcamera'))
|
|
summary({'libcamera': libcamera_dep.found()}, bool_yn: true, section: 'Backend')
|
|
- cdata.set('HAVE_LIBCAMERA_SYSTEM_DEVICES', libcamera_dep.version().version_compare('>= 0.1.0'))
|
|
|
|
compress_offload_option = get_option('compress-offload')
|
|
summary({'Compress-Offload': compress_offload_option.allowed()}, bool_yn: true, section: 'Backend')
|
|
diff --git a/spa/plugins/libcamera/libcamera-device.cpp b/spa/plugins/libcamera/libcamera-device.cpp
|
|
index 0abf2f6195..b25a4eb728 100644
|
|
--- a/spa/plugins/libcamera/libcamera-device.cpp
|
|
+++ b/spa/plugins/libcamera/libcamera-device.cpp
|
|
@@ -61,12 +61,10 @@ struct impl {
|
|
static const libcamera::Span<const int64_t> cameraDevice(
|
|
const Camera *camera)
|
|
{
|
|
-#ifdef HAVE_LIBCAMERA_SYSTEM_DEVICES
|
|
const ControlList &props = camera->properties();
|
|
|
|
if (auto devices = props.get(properties::SystemDevices))
|
|
return devices.value();
|
|
-#endif
|
|
|
|
return {};
|
|
}
|
|
--
|
|
GitLab
|
|
|