37 lines
1.6 KiB
Diff
37 lines
1.6 KiB
Diff
diff -Naur libreoffice-7.1.0.1.orig/Makefile.in libreoffice-7.1.0.1/Makefile.in
|
|
--- libreoffice-7.1.0.1.orig/Makefile.in 2021-01-02 15:03:18.306037152 +0000
|
|
+++ libreoffice-7.1.0.1/Makefile.in 2021-01-02 15:04:27.232129141 +0000
|
|
@@ -9,7 +9,7 @@
|
|
|
|
gb_Top_MODULE_CHECK_TARGETS := slowcheck unitcheck subsequentcheck perfcheck uicheck screenshot
|
|
|
|
-.PHONY : check-if-root bootstrap gbuild build build-non-l10n-only build-l10n-only check clean clean-build clean-host test-install distclean distro-pack-install docs download etags fetch get-submodules id install install-gdb-printers install-strip tags debugrun help showmodules translations packageinfo internal.clean $(gb_Top_MODULE_CHECK_TARGETS)
|
|
+.PHONY : bootstrap gbuild build build-non-l10n-only build-l10n-only check clean clean-build clean-host test-install distclean distro-pack-install docs download etags fetch get-submodules id install install-gdb-printers install-strip tags debugrun help showmodules translations packageinfo internal.clean $(gb_Top_MODULE_CHECK_TARGETS)
|
|
|
|
MAKECMDGOALS?=build
|
|
build_goal:=$(if $(filter build build-nocheck uicheck,$(MAKECMDGOALS)),build)\
|
|
@@ -58,14 +58,6 @@
|
|
|
|
.DEFAULT_GOAL := build
|
|
|
|
-check-if-root:
|
|
- @if test ! `uname` = 'Haiku' -a `id -u` = 0 && test -z $$container && ! grep -q 'lxc\|docker' /proc/self/cgroup && ! grep -q 'libpod_parent' /proc/self/cgroup; then \
|
|
- echo; \
|
|
- echo 'Building LibreOffice as root is a very bad idea, use a regular user.'; \
|
|
- echo; \
|
|
- exit 1; \
|
|
- fi
|
|
-
|
|
gb_Side ?= host
|
|
|
|
include $(BUILDDIR)/config_$(gb_Side).mk
|
|
@@ -268,7 +260,7 @@
|
|
#
|
|
# Bootstrap
|
|
#
|
|
-bootstrap: check-if-root compilerplugins
|
|
+bootstrap: compilerplugins
|
|
|
|
#
|
|
# Build
|