contrib/syslinux/dos_out.patch
2010-09-13 18:41:36 +02:00

38 lines
1.3 KiB
Diff

--- syslinux-4.01/Makefile 2010-07-02 18:19:39.000000000 +0000
+++ syslinux-4.01/Makefile.new 2010-07-16 19:02:01.987047109 +0000
@@ -43,9 +43,7 @@
mbr/mbr_c.bin mbr/altmbr_c.bin mbr/gptmbr_c.bin \
mbr/mbr_f.bin mbr/altmbr_f.bin mbr/gptmbr_f.bin \
core/pxelinux.0 core/isolinux.bin core/isolinux-debug.bin \
- gpxe/gpxelinux.0 dos/syslinux.com win32/syslinux.exe \
- dosutil/*.com dosutil/*.sys \
- $(MODULES)
+ gpxe/gpxelinux.0 $(MODULES)
# BSUBDIRs build the on-target binary components.
# ISUBDIRs build the installer (host) components.
@@ -54,7 +52,7 @@
# files that depend only on the B phase, but may have to be regenerated
# for "make installer".
BSUBDIRS = codepage com32 lzo core memdisk modules mbr memdump gpxe sample \
- libinstaller dos win32 dosutil
+ libinstaller
ITARGET =
IOBJECTS = $(ITARGET) \
utils/gethostip utils/isohybrid utils/mkdiskimage \
@@ -68,12 +66,11 @@
# Things to install in /usr/lib/syslinux
INSTALL_AUX = core/pxelinux.0 gpxe/gpxelinux.0 core/isolinux.bin \
core/isolinux-debug.bin \
- dos/syslinux.com win32/syslinux.exe \
mbr/*.bin $(MODULES)
-INSTALL_AUX_OPT = win32/syslinux.exe
+INSTALL_AUX_OPT =
# These directories manage their own installables
-INSTALLSUBDIRS = com32 utils dosutil
+INSTALLSUBDIRS = com32 utils
# Things to install in /boot/extlinux
EXTBOOTINSTALL = $(MODULES)