25 lines
1.0 KiB
Diff
25 lines
1.0 KiB
Diff
Description: [PATCH v2 5/5] docs: Run tbl preprocessor in manpage-check rule
|
|
Date: Fri, 4 Aug 2023 18:25:33 +0100
|
|
If we omit this, groff 1.23.0 warns:
|
|
.
|
|
tbl preprocessor failed, or it or soelim was not run; table(s) likely
|
|
not rendered (TE macro called with TW register undefined)
|
|
.
|
|
Author: Colin Watson <cjwatson@ubuntu.com>
|
|
Bug-Debian: https://bugs.debian.org/1042358
|
|
Last-Update: 2023-08-07
|
|
|
|
Index: openvswitch/Makefile.am
|
|
===================================================================
|
|
--- openvswitch.orig/Makefile.am
|
|
+++ openvswitch/Makefile.am
|
|
@@ -367,7 +367,7 @@ ALL_LOCAL += manpage-check
|
|
manpage-check: $(man_MANS) $(dist_man_MANS) $(noinst_man_MANS)
|
|
@error=false; \
|
|
for manpage in $?; do \
|
|
- LANG=en_US.UTF-8 groff -w mac -w delim -w escape -w input -w missing -w tab -T utf8 -man -p -z $$manpage >$@.tmp 2>&1; \
|
|
+ LANG=en_US.UTF-8 groff -t -w mac -w delim -w escape -w input -w missing -w tab -T utf8 -man -p -z $$manpage >$@.tmp 2>&1; \
|
|
if grep warning: $@.tmp; then error=:; fi; \
|
|
rm -f $@.tmp; \
|
|
done; \
|