contrib/distcc/distcc-2.18.3-install.patch
2008-05-18 02:31:52 +10:00

87 lines
3.0 KiB
Diff

diff -pruN distcc-2.18.3.orig/configure distcc-2.18.3/configure
--- distcc-2.18.3.orig/configure 2008-05-18 01:45:48.738143672 +1000
+++ distcc-2.18.3/configure 2008-05-18 01:46:11.810142374 +1000
@@ -342,9 +342,9 @@ bindir='${exec_prefix}/bin'
sbindir='${exec_prefix}/sbin'
libexecdir='${exec_prefix}/libexec'
datadir='${prefix}/share'
-sysconfdir='${prefix}/etc'
+sysconfdir='/etc'
sharedstatedir='${prefix}/com'
-localstatedir='${prefix}/var'
+localstatedir='/var'
libdir='${exec_prefix}/lib'
includedir='${prefix}/include'
oldincludedir='/usr/include'
diff -pruN distcc-2.18.3.orig/Makefile.in distcc-2.18.3/Makefile.in
--- distcc-2.18.3.orig/Makefile.in 2008-05-18 01:45:48.736140909 +1000
+++ distcc-2.18.3/Makefile.in 2008-05-18 01:47:29.487145051 +1000
@@ -289,10 +289,12 @@ popt_EXTRA = popt/README.popt popt/.stam
bin_PROGRAMS = \
distcc@EXEEXT@ \
- distccd@EXEEXT@ \
distccmon-text@EXEEXT@ \
@GNOME_BIN@
+sbin_PROGRAMS = \
+ distccd@EXEEXT@
+
check_PROGRAMS = \
h_argvtostr@EXEEXT@ \
h_exten@EXEEXT@ \
@@ -322,7 +324,7 @@ check_PROGRAMS = \
# We don't build the web pages by default, because many people will
# not have the tools to do it. Just use all-web if you want it.
-all: $(bin_PROGRAMS)
+all: $(bin_PROGRAMS) $(sbin_PROGRAMS)
all-web: all-latte
all-latte: $(latte_HTML)
@@ -432,7 +434,7 @@ man/distccmon_text_1.html: man/distccmon
######################################################################
## CHECK targets
-check_programs: $(check_PROGRAMS) $(bin_PROGRAMS)
+check_programs: $(check_PROGRAMS) $(bin_PROGRAMS) $(sbin_PROGRAMS)
# WARNING: This resets the path to avoid any confusion caused by
# having distcc masquerades already on the path. If you have gcc
@@ -440,7 +442,7 @@ check_programs: $(check_PROGRAMS) $(bin_
maintainer-check: check_programs
if test x$(PYTHON) != x; then \
$(PYTHON) -c 'import sys; print sys.version'; \
- PATH=`pwd`:/usr/local/bin:/bin:/usr/bin $(PYTHON) $(srcdir)/test/testdistcc.py; \
+ PATH=`pwd`:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/sbin:/usr/sbin $(PYTHON) $(srcdir)/test/testdistcc.py; \
else echo "WARNING: python not found; tests skipped"; \
fi
@@ -481,7 +483,7 @@ benchmark:
# Also clean binaries which are optionally built
clean: clean-autoconf clean-lzo
rm -f src/*.o popt/*.o
- rm -f $(check_PROGRAMS) $(bin_PROGRAMS)
+ rm -f $(check_PROGRAMS) $(bin_PROGRAMS) $(sbin_PROGRAMS)
rm -f distccmon-gnome
rm -rf testtmp
@@ -558,11 +560,15 @@ showpaths:
install: showpaths install-doc install-man install-programs install-example @INSTALL_GNOME@
-install-programs: $(bin_PROGRAMS)
+install-programs: $(bin_PROGRAMS) $(sbin_PROGRAMS)
$(mkinstalldirs) $(DESTDIR)$(bindir)
- for p in $^; do \
+ for p in $(bin_PROGRAMS); do \
$(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir) || exit 1; \
done
+ $(mkinstalldirs) $(DESTDIR)$(sbindir)
+ for p in $(sbin_PROGRAMS); do \
+ $(INSTALL_PROGRAM) $$p $(DESTDIR)$(sbindir) || exit 1; \
+ done
install-man: $(man1_MEN)
$(mkinstalldirs) $(DESTDIR)$(man1dir)