contrib/thin-provisioning-tools/0001-fix-build-with-testing-disabled.patch
2017-10-17 15:56:57 +11:00

36 lines
925 B
Diff

From 8d75be81120b9cf172c95d0153c5f845ed804234 Mon Sep 17 00:00:00 2001
From: Adam Sampson <ats-github@offog.org>
Date: Mon, 16 Oct 2017 13:07:36 +0100
Subject: [functional-tests] fix build with testing disabled (#88)
The rule for lib/libft.so is only enabled with --enable-testing,
so the default target shouldn't depend unconditionally on it.
With the default configure options, the build failed with:
make: *** No rule to make target 'lib/libft.so', needed by 'all'. Stop.
---
Makefile.in | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/Makefile.in b/Makefile.in
index e745739..02b75dd 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -21,8 +21,13 @@ V=@
PROGRAMS=\
bin/pdata_tools
+ifeq ("@TESTING@", "yes")
+TESTLIBS=\
+ lib/libft.so
+endif
+
.PHONY: all
-all: $(PROGRAMS) lib/libft.so
+all: $(PROGRAMS) $(TESTLIBS)
SOURCE=\
base/output_file_requirements.cc \
--
cgit v1.1-22-g1649