contrib/libreoffice/makefile.in.patch

39 lines
1.6 KiB
Diff

--- libreoffice-7.2.0.1.orig/Makefile.in 2021-07-16 20:47:21.615601263 +0200
+++ libreoffice-7.2.0.1/Makefile.in 2021-07-16 20:48:10.346072072 +0200
@@ -9,7 +9,7 @@
gb_Top_MODULE_CHECK_TARGETS := slowcheck unitcheck subsequentcheck perfcheck uicheck screenshot
-.PHONY : check-if-root bootstrap gbuild build build-non-l10n-only build-l10n-only check clean clean-build clean-host test-install distclean distro-pack-install docs download etags fetch get-submodules id install install-gdb-printers install-strip tags debugrun help showmodules translations packageinfo internal.clean $(gb_Top_MODULE_CHECK_TARGETS)
+.PHONY : bootstrap gbuild build build-non-l10n-only build-l10n-only check clean clean-build clean-host test-install distclean distro-pack-install docs download etags fetch get-submodules id install install-gdb-printers install-strip tags debugrun help showmodules translations packageinfo internal.clean $(gb_Top_MODULE_CHECK_TARGETS)
MAKECMDGOALS?=build
build_goal:=$(if $(filter build build-nocheck uicheck,$(MAKECMDGOALS)),build)\
@@ -58,17 +58,6 @@
.DEFAULT_GOAL := build
-check-if-root:
- @if test ! `uname` = 'Haiku' -a `id -u` = 0; then \
- # if the systemd-detect-virt command doesn't exist or it reports we're not in a container \
- if test ! -x "$$(command -v systemd-detect-virt)" || ! systemd-detect-virt -c -q; then \
- echo; \
- echo 'Building LibreOffice as root is a very bad idea, use a regular user.'; \
- echo; \
- exit 1; \
- fi \
- fi
-
gb_Side ?= host
include $(BUILDDIR)/config_$(gb_Side).mk
@@ -274,7 +263,7 @@
#
# Bootstrap
#
-bootstrap: check-if-root compilerplugins
+bootstrap: compilerplugins
#
# Build