contrib/wine-staging/x3daudio1_7-fix.patch

68 lines
2.7 KiB
Diff

From a1246b5e921ea950851e4a971fb3dae535d7b982 Mon Sep 17 00:00:00 2001
From: Zebediah Figura <z.figura12@gmail.com>
Date: Sat, 14 Mar 2020 11:52:09 -0500
Subject: [PATCH] xactengine-initial: Build an import library for x3daudio1_7.
Should fix test compilation.
---
.../0016-xaudio2_7-tests-Add-more-tests.patch | 22 ++++++++++++++-----
1 file changed, 17 insertions(+), 5 deletions(-)
diff --git a/patches/xactengine-initial/0016-xaudio2_7-tests-Add-more-tests.patch b/patches/xactengine-initial/0016-xaudio2_7-tests-Add-more-tests.patch
index b9b8a2141..942f54e6b 100644
--- a/patches/xactengine-initial/0016-xaudio2_7-tests-Add-more-tests.patch
+++ b/patches/xactengine-initial/0016-xaudio2_7-tests-Add-more-tests.patch
@@ -1,19 +1,31 @@
-From 26d4f62fcf18beb2ffc6b5bdd55b058b375f5c54 Mon Sep 17 00:00:00 2001
+From 7212b91306542f5a71fe51a99b012a402db700ab Mon Sep 17 00:00:00 2001
From: Alistair Leslie-Hughes <leslie_alistair@hotmail.com>
Date: Sat, 18 Jan 2020 18:50:34 +1100
Subject: [PATCH] xaudio2_7/tests: Add more tests
---
+ dlls/x3daudio1_7/Makefile.in | 1 +
dlls/xaudio2_7/tests/Makefile.in | 5 +-
dlls/xaudio2_7/tests/globals.xgs | Bin 0 -> 440 bytes
dlls/xaudio2_7/tests/rsrc.rc | 22 +++++++
dlls/xaudio2_7/tests/xact.c | 99 ++++++++++++++++++++++++++-----
- 4 files changed, 111 insertions(+), 15 deletions(-)
+ 5 files changed, 112 insertions(+), 15 deletions(-)
create mode 100644 dlls/xaudio2_7/tests/globals.xgs
create mode 100644 dlls/xaudio2_7/tests/rsrc.rc
+diff --git a/dlls/x3daudio1_7/Makefile.in b/dlls/x3daudio1_7/Makefile.in
+index 267a93fd6..5438bc6d8 100644
+--- a/dlls/x3daudio1_7/Makefile.in
++++ b/dlls/x3daudio1_7/Makefile.in
+@@ -1,5 +1,6 @@
+ EXTRADEFS = -DX3DAUDIO1_VER=7 -DXAUDIO2_VER=7
+ MODULE = x3daudio1_7.dll
++IMPORTLIB = x3daudio1_7
+ PARENTSRC = ../xaudio2_7
+ EXTRALIBS = $(FAUDIO_LIBS)
+ EXTRAINCL = $(FAUDIO_CFLAGS)
diff --git a/dlls/xaudio2_7/tests/Makefile.in b/dlls/xaudio2_7/tests/Makefile.in
-index ecd728d659..1bb39cc562 100644
+index ecd728d65..1bb39cc56 100644
--- a/dlls/xaudio2_7/tests/Makefile.in
+++ b/dlls/xaudio2_7/tests/Makefile.in
@@ -1,6 +1,9 @@
@@ -44,7 +56,7 @@ HcmV?d00001
diff --git a/dlls/xaudio2_7/tests/rsrc.rc b/dlls/xaudio2_7/tests/rsrc.rc
new file mode 100644
-index 0000000000..2c1961c727
+index 000000000..2c1961c72
--- /dev/null
+++ b/dlls/xaudio2_7/tests/rsrc.rc
@@ -0,0 +1,22 @@
@@ -71,7 +83,7 @@ index 0000000000..2c1961c727
+/* @makedep: globals.xgs*/
+globals.xgs RCDATA "globals.xgs"
diff --git a/dlls/xaudio2_7/tests/xact.c b/dlls/xaudio2_7/tests/xact.c
-index afe8e4d83a..881513668b 100644
+index afe8e4d83..881513668 100644
--- a/dlls/xaudio2_7/tests/xact.c
+++ b/dlls/xaudio2_7/tests/xact.c
@@ -18,14 +18,25 @@