gcc: update to 4.2.1
This commit is contained in:
parent
3bec2ca40a
commit
038aa9529f
1194
gcc/.footprint
1194
gcc/.footprint
File diff suppressed because it is too large
Load Diff
10
gcc/.md5sum
10
gcc/.md5sum
@ -1,5 +1,5 @@
|
||||
30e33e6ecedfc346f48240589414aa92 gcc-4.1.2-fixinc.patch
|
||||
36fb6ec15a5f2a6572da0b02a3cf9d66 gcc-4.1.2-nocheck-fixincludes.patch
|
||||
2af3fb599635219171c6ae1f3034888a gcc-core-4.1.2.tar.bz2
|
||||
75c6d5fa3415d614314caf0f509e8933 gcc-g++-4.1.2.tar.bz2
|
||||
abda05c0ab99059e8f9e7a625361fd87 gcc-objc-4.1.2.tar.bz2
|
||||
839458a2fcff05c785b2b5d104397396 gcc-4.2.1-fixinc.patch
|
||||
a617c4d3fa11e0c9410ac213eb061677 gcc-4.2.1-nocheck-fixincludes.patch
|
||||
88007169104d247eccb07dc5de2e0137 gcc-core-4.2.1.tar.bz2
|
||||
0aca4ef04eb57d9f356c431496bdad0b gcc-g++-4.2.1.tar.bz2
|
||||
9e0a37826d496541afe2d453fd831a8a gcc-objc-4.2.1.tar.bz2
|
||||
|
@ -4,7 +4,7 @@
|
||||
# Maintainer: CRUX System Team, core-ports at crux dot nu
|
||||
|
||||
name=gcc
|
||||
version=4.1.2
|
||||
version=4.2.1
|
||||
release=1
|
||||
source=(ftp://sources.redhat.com/pub/gcc/releases/$name-$version/$name-{core,g++,objc}-$version.tar.bz2
|
||||
$name-$version-nocheck-fixincludes.patch
|
||||
@ -30,7 +30,7 @@ build() {
|
||||
--with-x=no
|
||||
make bootstrap
|
||||
make check
|
||||
make DESTDIR=$PKG install
|
||||
make -j1 DESTDIR=$PKG install
|
||||
|
||||
mkdir $PKG/lib
|
||||
ln -sf ../usr/bin/cpp $PKG/lib/cpp
|
||||
|
@ -1,16 +0,0 @@
|
||||
--- gcc-4.1-20060505/gcc/Makefile.in.orig 2006-05-12 12:50:13.051496504 +0200
|
||||
+++ gcc-4.1-20060505/gcc/Makefile.in 2006-05-12 12:51:05.218565904 +0200
|
||||
@@ -3178,12 +3178,7 @@
|
||||
fi
|
||||
rm -rf include; mkdir include
|
||||
-chmod a+rx include
|
||||
- (TARGET_MACHINE='$(target)'; srcdir=`cd $(srcdir); ${PWD_COMMAND}`; \
|
||||
- SHELL='$(SHELL)'; MACRO_LIST=`${PWD_COMMAND}`/macro_list ; \
|
||||
- export TARGET_MACHINE srcdir SHELL MACRO_LIST && \
|
||||
- cd $(build_objdir)/fixincludes && \
|
||||
- $(SHELL) ./fixinc.sh ../../gcc/include \
|
||||
- $(SYSTEM_HEADER_DIR) $(OTHER_FIXINCLUDES_DIRS) )
|
||||
+ cd $(build_objdir)/fixincludes
|
||||
rm -f include/syslimits.h
|
||||
if [ -f include/limits.h ]; then \
|
||||
mv include/limits.h include/syslimits.h; \
|
@ -1,14 +0,0 @@
|
||||
diff -Nru gcc-4.0.3-old/fixincludes/Makefile.in gcc-4.0.3/fixincludes/Makefile.in
|
||||
--- gcc-4.0.3-old/fixincludes/Makefile.in 2006-03-14 02:13:34.000000000 +0100
|
||||
+++ gcc-4.0.3/fixincludes/Makefile.in 2006-03-14 02:17:39.000000000 +0100
|
||||
@@ -163,9 +163,7 @@
|
||||
cp $(srcdir)/../gcc/aclocal.m4 .
|
||||
|
||||
check : all
|
||||
- autogen -T $(srcdir)/check.tpl $(srcdir)/inclhack.def
|
||||
- $(SHELL) ./check.sh $(srcdir)/tests/base
|
||||
- @rm -f ./check.sh
|
||||
+ echo "No check here.."
|
||||
|
||||
install : all
|
||||
-rm -rf $(DESTDIR)$(itoolsdir)
|
16
gcc/gcc-4.2.1-fixinc.patch
Normal file
16
gcc/gcc-4.2.1-fixinc.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -Nru gcc-4.2.1.orig/gcc/Makefile.in gcc-4.2.1/gcc/Makefile.in
|
||||
--- gcc-4.2.1.orig/gcc/Makefile.in 2007-08-15 13:45:59.000000000 +0200
|
||||
+++ gcc-4.2.1/gcc/Makefile.in 2007-08-15 14:57:32.000000000 +0200
|
||||
@@ -3251,12 +3251,6 @@
|
||||
$(MAKE) real-$(INSTALL_HEADERS_DIR) DESTDIR=`pwd`/../gcc/ \
|
||||
libsubdir=. ; \
|
||||
else \
|
||||
- (TARGET_MACHINE='$(target)'; srcdir=`cd $(srcdir); ${PWD_COMMAND}`; \
|
||||
- SHELL='$(SHELL)'; MACRO_LIST=`${PWD_COMMAND}`/macro_list ; \
|
||||
- export TARGET_MACHINE srcdir SHELL MACRO_LIST && \
|
||||
- cd $(build_objdir)/fixincludes && \
|
||||
- $(SHELL) ./fixinc.sh ../../gcc/include \
|
||||
- $(SYSTEM_HEADER_DIR) $(OTHER_FIXINCLUDES_DIRS) ); \
|
||||
rm -f include/syslimits.h; \
|
||||
if [ -f include/limits.h ]; then \
|
||||
mv include/limits.h include/syslimits.h; \
|
14
gcc/gcc-4.2.1-nocheck-fixincludes.patch
Normal file
14
gcc/gcc-4.2.1-nocheck-fixincludes.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -Nru gcc-4.2.1.orig/fixincludes/Makefile.in gcc-4.2.1/fixincludes/Makefile.in
|
||||
--- gcc-4.2.1.orig/fixincludes/Makefile.in 2007-08-15 13:45:59.000000000 +0200
|
||||
+++ gcc-4.2.1/fixincludes/Makefile.in 2007-08-15 14:21:16.000000000 +0200
|
||||
@@ -169,9 +169,7 @@
|
||||
cp $(srcdir)/../gcc/aclocal.m4 .
|
||||
|
||||
check : all
|
||||
- autogen -T $(srcdir)/check.tpl $(srcdir)/inclhack.def
|
||||
- $(SHELL) ./check.sh $(srcdir)/tests/base
|
||||
- @rm -f ./check.sh
|
||||
+ echo "No check here.."
|
||||
|
||||
install : all
|
||||
-rm -rf $(DESTDIR)$(itoolsdir)
|
Loading…
x
Reference in New Issue
Block a user