tzdata: update to 2013f

This commit is contained in:
Juergen Daubert 2013-09-28 10:39:49 +02:00
parent faeb8ab4a1
commit 06dca7439a
3 changed files with 71 additions and 45 deletions

View File

@ -1,3 +1,3 @@
f30150b95f6e7fbb8ccc04f26955d300 tzcode-makefile.patch
4616a9560270f180eeb9a08540636890 tzcode2013d.tar.gz
65b6818162230fc02f86f293376c73df tzdata2013d.tar.gz
3aa477d19959a7e27b9d669406306189 tzcode-makefile.patch
0cca1a29a3734935e7dd44e86fa3bbd5 tzcode2013f.tar.gz
6d35470a6090e741c39aa9bc9cd103e3 tzdata2013f.tar.gz

View File

@ -3,7 +3,7 @@
# Maintainer: CRUX System Team, core-ports at crux dot nu
name=tzdata
version=2013d
version=2013f
release=1
source=(ftp://ftp.iana.org/tz/releases/$name$version.tar.gz
ftp://ftp.iana.org/tz/releases/tzcode$version.tar.gz

View File

@ -1,19 +1,31 @@
diff -urN tzcode.orig/Makefile tzcode/Makefile
--- tzcode.orig/Makefile 2013-07-05 09:38:01.000000000 -0500
+++ tzcode/Makefile 2013-07-08 09:21:43.660000054 -0500
@@ -45,20 +45,20 @@
# http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-libs/timezone-data/files/2013f-makefile.patch
# added some fixes for the file-layout (jue)
#
# - Support env CC
# - Don't build/install libtz.a
# - Don't install man-pages provided by man-pages
# - Move zic, zdump to sbin and tzselect to bin ala glibc
# - Install posix zoneinfo into zoneinfo/posix/ instead of zoneinfo-posix/ ala glibc
# - Install leaps zoneinfo into zoneinfo/right/ ala glibc
diff -Nru tzcode.orig/Makefile tzcode/Makefile
--- tzcode.orig/Makefile 2013-09-27 09:43:52.314987908 +0200
+++ tzcode/Makefile 2013-09-27 11:01:46.512438118 +0200
@@ -45,21 +45,21 @@
# Everything gets put in subdirectories of. . .
-TOPDIR= /usr/local
+TOPDIR= $(DESTDIR)/usr
+TOPDIR= /usr
# "Compiled" time zone information is placed in the "TZDIR" directory
# (and subdirectories).
# Use an absolute path name for TZDIR unless you're just testing the software.
-TZDIR= $(TOPDIR)/etc/zoneinfo
+TZDIR= $(TOPDIR)/share/zoneinfo
TZDIR_BASENAME= zoneinfo
-TZDIR= $(TOPDIR)/etc/$(TZDIR_BASENAME)
+TZDIR= $(TOPDIR)/share/$(TZDIR_BASENAME)
# Types to try, as an alternative to time_t. int64_t should be first.
TIME_T_ALTERNATIVES= int64_t int32_t uint32_t uint64_t
@ -25,60 +37,74 @@ diff -urN tzcode.orig/Makefile tzcode/Makefile
# If you "make INSTALL", the "date" command gets installed in. . .
@@ -292,8 +292,10 @@
@@ -294,8 +294,10 @@
###############################################################################
-cc= cc
-CC= $(cc) -DTZDIR=\"$(TZDIR)\"
+CC+= -DTZDIR=\"$(TZDIR)\"
+CC+= -DTZDIR=\"$(TZDIR)\"
+ifeq ($(NLS),1)
+CC += -DHAVE_GETTEXT=1 -DTZ_DOMAIN=\"libc\"
+CC+= -DHAVE_GETTEXT=1 -DTZ_DOMAIN=\"libc\"
+endif
TZCSRCS= zic.c localtime.c asctime.c scheck.c ialloc.c
TZCOBJS= zic.o localtime.o asctime.o scheck.o ialloc.o
@@ -334,13 +336,15 @@
@@ -338,14 +340,16 @@
ALL: all date
-install: all $(DATA) $(REDO) $(TZLIB) $(MANS) $(TABDATA)
+install: all $(DATA) $(REDO) $(MANS) $(TABDATA)
-install: all $(DATA) $(REDO) $(DESTDIR)$(TZLIB) $(MANS)
+install: all $(DATA) $(REDO) $(MANS)
$(ZIC) -y $(YEARISTYPE) \
-d $(TZDIR) -l $(LOCALTIME) -p $(POSIXRULES)
-rm -f $(TZDIR)/iso3166.tab $(TZDIR)/zone.tab
cp iso3166.tab zone.tab $(TZDIR)/.
- -mkdir $(TOPDIR) $(ETCDIR)
- cp tzselect zic zdump $(ETCDIR)/.
+ -mkdir $(TOPDIR) $(SBINDIR)
+ cp zic zdump $(SBINDIR)/.
+ -mkdir $(TOPDIR) $(BINDIR)
+ cp tzselect $(BINDIR)/.
-mkdir $(TOPDIR) $(MANDIR) \
$(MANDIR)/man3 $(MANDIR)/man5 $(MANDIR)/man8
-rm -f $(MANDIR)/man3/newctime.3 \
@@ -350,8 +354,6 @@
$(MANDIR)/man8/zdump.8 \
$(MANDIR)/man8/zic.8
cp newctime.3 newtzset.3 $(MANDIR)/man3/.
- cp tzfile.5 $(MANDIR)/man5/.
- cp tzselect.8 zdump.8 zic.8 $(MANDIR)/man8/.
-d $(DESTDIR)$(TZDIR) -l $(LOCALTIME) -p $(POSIXRULES)
-rm -f $(DESTDIR)$(TZDIR)/iso3166.tab \
$(DESTDIR)$(TZDIR)/zone.tab
cp iso3166.tab zone.tab $(DESTDIR)$(TZDIR)/.
- -mkdir $(DESTDIR)$(TOPDIR) $(DESTDIR)$(ETCDIR)
- cp tzselect zic zdump $(DESTDIR)$(ETCDIR)/.
+ -mkdir $(DESTDIR)$(TOPDIR) $(DESTDIR)$(SBINDIR)
+ cp zic zdump $(DESTDIR)$(SBINDIR)/.
+ -mkdir $(DESTDIR)$(TOPDIR) $(DESTDIR)$(BINDIR)
+ cp tzselect $(DESTDIR)$(BINDIR)/.
-mkdir $(DESTDIR)$(TOPDIR) $(DESTDIR)$(MANDIR) \
$(DESTDIR)$(MANDIR)/man3 $(DESTDIR)$(MANDIR)/man5 \
$(DESTDIR)$(MANDIR)/man8
@@ -356,8 +360,6 @@
$(DESTDIR)$(MANDIR)/man8/zdump.8 \
$(DESTDIR)$(MANDIR)/man8/zic.8
cp newctime.3 newtzset.3 $(DESTDIR)$(MANDIR)/man3/.
- cp tzfile.5 $(DESTDIR)$(MANDIR)/man5/.
- cp tzselect.8 zdump.8 zic.8 $(DESTDIR)$(MANDIR)/man8/.
INSTALL: ALL install date.1
-mkdir $(TOPDIR) $(BINDIR)
@@ -391,9 +393,9 @@
-mkdir $(DESTDIR)$(TOPDIR) $(DESTDIR)$(BINDIR)
@@ -403,19 +405,17 @@
# You must replace all of $(TZDIR) to switch from not using leap seconds
# to using them, or vice versa.
other_two: zic leapseconds $(TDATA)
- $(ZIC) -y $(YEARISTYPE) -d $(TZDIR)-posix -L /dev/null $(TDATA)
+ $(ZIC) -y $(YEARISTYPE) -d $(TZDIR)/posix -L /dev/null $(TDATA)
$(ZIC) -y $(YEARISTYPE) \
- -d $(TZDIR)-leaps -L leapseconds $(TDATA)
+ -d $(TZDIR)/right -L leapseconds $(TDATA)
right_posix: right_only leapseconds
- rm -fr $(DESTDIR)$(TZDIR)-leaps
- ln -s $(TZDIR_BASENAME) $(DESTDIR)$(TZDIR)-leaps || \
- $(ZIC) -y $(YEARISTYPE) -d $(DESTDIR)$(TZDIR)-leaps \
+ rm -fr $(DESTDIR)$(TZDIR)/right
+ $(ZIC) -y $(YEARISTYPE) -d $(DESTDIR)$(TZDIR)/right \
-L leapseconds $(TDATA)
- $(ZIC) -y $(YEARISTYPE) -d $(DESTDIR)$(TZDIR)-posix \
+ $(ZIC) -y $(YEARISTYPE) -d $(DESTDIR)$(TZDIR)/posix \
-L /dev/null $(TDATA)
posix_right: posix_only other_two
posix_right: posix_only leapseconds
rm -fr $(DESTDIR)$(TZDIR)-posix
- ln -s $(TZDIR_BASENAME) $(DESTDIR)$(TZDIR)-posix || \
- $(ZIC) -y $(YEARISTYPE) -d $(DESTDIR)$(TZDIR)-posix \
+ $(ZIC) -y $(YEARISTYPE) -d $(DESTDIR)$(TZDIR)/posix \
-L /dev/null $(TDATA)
- $(ZIC) -y $(YEARISTYPE) -d $(DESTDIR)$(TZDIR)-leaps \
+ $(ZIC) -y $(YEARISTYPE) -d $(DESTDIR)$(TZDIR)/right \
-L leapseconds $(TDATA)
@@ -421,7 +423,7 @@
zones: $(REDO)
@@ -440,7 +440,7 @@
<$? >$@
chmod +x $@