sudo: updated to 1.8.11p1
This commit is contained in:
parent
4b13e63618
commit
131a8d8fda
@ -1,2 +1 @@
|
||||
9a642cf6aca5375f8569a2961f44d0f3 sudo-1.8.11.tar.gz
|
||||
bf556f3e3a4d711ee347a010f8887386 sudo-shadow.diff
|
||||
5065deec62e8cd514fb04d1d1253db03 sudo-1.8.11p1.tar.gz
|
||||
|
@ -4,16 +4,13 @@
|
||||
# Depends on: zlib
|
||||
|
||||
name=sudo
|
||||
version=1.8.11
|
||||
version=1.8.11p1
|
||||
release=1
|
||||
source=(http://www.sudo.ws/$name/dist/$name-$version.tar.gz
|
||||
$name-shadow.diff)
|
||||
source=(http://www.sudo.ws/$name/dist/$name-$version.tar.gz)
|
||||
|
||||
build() {
|
||||
cd $name-$version
|
||||
|
||||
patch -p1 -i $SRC/$name-shadow.diff
|
||||
|
||||
./configure --prefix=/usr \
|
||||
--libexecdir=/usr/lib \
|
||||
--mandir=/usr/man \
|
||||
|
@ -1,101 +0,0 @@
|
||||
# http://www.sudo.ws/bugs/show_bug.cgi?id=667
|
||||
|
||||
diff -r fe06a2448c53 configure
|
||||
--- a/configure Fri Sep 26 21:03:22 2014 -0600
|
||||
+++ b/configure Sat Sep 27 10:09:38 2014 -0600
|
||||
@@ -3070,7 +3070,6 @@
|
||||
shadow_defs=
|
||||
shadow_funcs=
|
||||
shadow_libs=
|
||||
-shadow_libs_optional=
|
||||
CONFIGURE_ARGS="$@"
|
||||
|
||||
RTLD_PRELOAD_VAR="LD_PRELOAD"
|
||||
@@ -14733,9 +14732,7 @@
|
||||
;;
|
||||
*-*-linux*|*-*-k*bsd*-gnu)
|
||||
OSDEFS="${OSDEFS} -D_GNU_SOURCE"
|
||||
- # Some Linux versions need to link with -lshadow
|
||||
shadow_funcs="getspnam"
|
||||
- shadow_libs_optional="-lshadow"
|
||||
test -z "$with_pam" && AUTH_EXCL_DEF="PAM"
|
||||
;;
|
||||
*-*-gnu*)
|
||||
@@ -21323,24 +21320,6 @@
|
||||
fi
|
||||
done
|
||||
|
||||
- if test "$found" = "yes" -a -n "$shadow_libs_optional"; then
|
||||
- LIBS="$LIBS $shadow_libs_optional"
|
||||
- for ac_func in $shadow_funcs
|
||||
-do :
|
||||
- as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
|
||||
-ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
|
||||
-if eval test \"x\$"$as_ac_var"\" = x"yes"; then :
|
||||
- cat >>confdefs.h <<_ACEOF
|
||||
-#define `$as_echo "HAVE_$ac_func" | $as_tr_cpp` 1
|
||||
-_ACEOF
|
||||
- found=yes
|
||||
-fi
|
||||
-done
|
||||
-
|
||||
- if test "$found" = "yes"; then
|
||||
- shadow_libs="$shadow_libs $shadow_libs_optional"
|
||||
- fi
|
||||
- fi
|
||||
if test "$found" = "yes"; then
|
||||
case "$shadow_funcs" in
|
||||
*getprpwnam*) SECUREWARE=1;;
|
||||
@@ -21377,7 +21356,7 @@
|
||||
return 0;
|
||||
}
|
||||
_ACEOF
|
||||
-for ac_lib in '' gen; do
|
||||
+for ac_lib in '' gen shadow; do
|
||||
if test -z "$ac_lib"; then
|
||||
ac_res="none required"
|
||||
else
|
||||
diff -r fe06a2448c53 configure.ac
|
||||
--- a/configure.ac Fri Sep 26 21:03:22 2014 -0600
|
||||
+++ b/configure.ac Sat Sep 27 10:09:38 2014 -0600
|
||||
@@ -226,7 +226,6 @@
|
||||
shadow_defs=
|
||||
shadow_funcs=
|
||||
shadow_libs=
|
||||
-shadow_libs_optional=
|
||||
CONFIGURE_ARGS="$@"
|
||||
|
||||
dnl
|
||||
@@ -1908,9 +1907,7 @@
|
||||
;;
|
||||
*-*-linux*|*-*-k*bsd*-gnu)
|
||||
OSDEFS="${OSDEFS} -D_GNU_SOURCE"
|
||||
- # Some Linux versions need to link with -lshadow
|
||||
shadow_funcs="getspnam"
|
||||
- shadow_libs_optional="-lshadow"
|
||||
test -z "$with_pam" && AUTH_EXCL_DEF="PAM"
|
||||
;;
|
||||
*-*-gnu*)
|
||||
@@ -3430,13 +3427,6 @@
|
||||
LIBS="$LIBS $shadow_libs"
|
||||
found=no
|
||||
AC_CHECK_FUNCS($shadow_funcs, [found=yes])
|
||||
- if test "$found" = "yes" -a -n "$shadow_libs_optional"; then
|
||||
- LIBS="$LIBS $shadow_libs_optional"
|
||||
- AC_CHECK_FUNCS($shadow_funcs, [found=yes])
|
||||
- if test "$found" = "yes"; then
|
||||
- shadow_libs="$shadow_libs $shadow_libs_optional"
|
||||
- fi
|
||||
- fi
|
||||
if test "$found" = "yes"; then
|
||||
case "$shadow_funcs" in
|
||||
*getprpwnam*) SECUREWARE=1;;
|
||||
@@ -3449,7 +3439,7 @@
|
||||
LIBS="$_LIBS"
|
||||
fi
|
||||
if test "$CHECKSHADOW" = "true"; then
|
||||
- AC_SEARCH_LIBS([getspnam], [gen], [AC_DEFINE(HAVE_GETSPNAM)] [CHECKSHADOW=false; test -n "$ac_lib" && shadow_libs="${shadow_libs} $ac_res"])
|
||||
+ AC_SEARCH_LIBS([getspnam], [gen shadow], [AC_DEFINE(HAVE_GETSPNAM)] [CHECKSHADOW=false; test -n "$ac_lib" && shadow_libs="${shadow_libs} $ac_res"])
|
||||
fi
|
||||
if test "$CHECKSHADOW" = "true"; then
|
||||
AC_SEARCH_LIBS([getprpwnam], [sec security prot], [AC_DEFINE(HAVE_GETPRPWNAM)] [CHECKSHADOW=false; SECUREWARE=1; test -n "$ac_lib" && shadow_libs="${shadow_libs} $ac_res"])
|
Loading…
x
Reference in New Issue
Block a user