iptables: applied man-page fixes from gentoo

This commit is contained in:
Juergen Daubert 2011-07-20 16:08:04 +02:00
parent 3566b2299f
commit 145a5e8d90
3 changed files with 26 additions and 2 deletions

View File

@ -1 +1,2 @@
171f040be8d0467820c8313e47fa7635 iptables-1.4.11.1-man-fixes.patch
7de6e1ae7ed8a2025f184763a6a24b9a iptables-1.4.11.1.tar.bz2

View File

@ -4,12 +4,16 @@
name=iptables
version=1.4.11.1
release=1
source=(ftp://ftp.netfilter.org/pub/iptables/$name-$version.tar.bz2)
release=2
source=(ftp://ftp.netfilter.org/pub/iptables/$name-$version.tar.bz2
$name-$version-man-fixes.patch)
build () {
cd $name-$version
patch -p1 -i $SRC/$name-$version-man-fixes.patch
automake
./configure --prefix=/usr \
--mandir=/usr/man \
--libexecdir=/usr/lib \

View File

@ -0,0 +1,19 @@
# http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-firewall/iptables/files/iptables-1.4.11.1-man-fixes.patch?revision=1.1
diff --git a/iptables/Makefile.am b/iptables/Makefile.am
index 13cca9c..a068278 100644
--- a/iptables/Makefile.am
+++ b/iptables/Makefile.am
@@ -51,10 +51,10 @@ v6_sbin_links = ip6tables ip6tables-restore ip6tables-save
endif
iptables.8: ${srcdir}/iptables.8.in ../extensions/matches4.man ../extensions/targets4.man
- ${AM_VERBOSE_GEN} sed -e 's/@PACKAGE_AND_VERSION@/${PACKAGE} ${PACKAGE_VERSION}/g' -e '/@MATCH@/ r extensions/matches4.man' -e '/@TARGET@/ r extensions/targets4.man' $< >$@;
+ ${AM_VERBOSE_GEN} sed -e 's/@PACKAGE_AND_VERSION@/${PACKAGE} ${PACKAGE_VERSION}/g' -e '/@MATCH@/ r ../extensions/matches4.man' -e '/@TARGET@/ r ../extensions/targets4.man' $< >$@;
ip6tables.8: ${srcdir}/ip6tables.8.in ../extensions/matches6.man ../extensions/targets6.man
- ${AM_VERBOSE_GEN} sed -e 's/@PACKAGE_AND_VERSION@/${PACKAGE} ${PACKAGE_VERSION}/g' -e '/@MATCH@/ r extensions/matches6.man' -e '/@TARGET@/ r extensions/targets6.man' $< >$@;
+ ${AM_VERBOSE_GEN} sed -e 's/@PACKAGE_AND_VERSION@/${PACKAGE} ${PACKAGE_VERSION}/g' -e '/@MATCH@/ r ../extensions/matches6.man' -e '/@TARGET@/ r ../extensions/targets6.man' $< >$@;
pkgconfig_DATA = xtables.pc