iproute2: update to 2.6.26

This commit is contained in:
Juergen Daubert 2008-09-19 12:09:41 +02:00
parent 238f1c4b04
commit 24a38d3e8f
4 changed files with 27 additions and 32 deletions

View File

@ -8,6 +8,12 @@ drwxr-xr-x root/root etc/iproute2/
-rw-r--r-- root/root etc/iproute2/rt_tables
drwxr-xr-x root/root etc/rc.d/
-rwxr-xr-x root/root etc/rc.d/net
drwxr-xr-x root/root lib/
drwxr-xr-x root/root lib/tc/
-rwxr-xr-x root/root lib/tc/experimental.dist
-rwxr-xr-x root/root lib/tc/normal.dist
-rwxr-xr-x root/root lib/tc/pareto.dist
-rwxr-xr-x root/root lib/tc/paretonormal.dist
drwxr-xr-x root/root sbin/
-rwxr-xr-x root/root sbin/arpd
lrwxrwxrwx root/root sbin/ctstat -> lnstat
@ -26,20 +32,20 @@ lrwxrwxrwx root/root sbin/rtstat -> lnstat
-rwxr-xr-x root/root sbin/ss
-rwxr-xr-x root/root sbin/tc
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/lib/tc/
-rwxr-xr-x root/root usr/lib/tc/experimental.dist
-rwxr-xr-x root/root usr/lib/tc/normal.dist
-rwxr-xr-x root/root usr/lib/tc/pareto.dist
-rwxr-xr-x root/root usr/lib/tc/paretonormal.dist
-rwxr-xr-x root/root usr/lib/tc/q_netem.so
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man3/
-rw-r--r-- root/root usr/man/man3/libnetlink.3.gz
drwxr-xr-x root/root usr/man/man8/
-rw-r--r-- root/root usr/man/man8/arpd.8.gz
lrwxrwxrwx root/root usr/man/man8/ctstat.8.gz -> lnstat.8.gz
-rw-r--r-- root/root usr/man/man8/ip.8.gz
-rw-r--r-- root/root usr/man/man8/lnstat.8.gz
lrwxrwxrwx root/root usr/man/man8/nstat.8.gz -> rtacct.8.gz
lrwxrwxrwx root/root usr/man/man8/routef.8.gz -> routel.8.gz
-rw-r--r-- root/root usr/man/man8/routel.8.gz
-rw-r--r-- root/root usr/man/man8/rtacct.8.gz
-rw-r--r-- root/root usr/man/man8/rtmon.8.gz
lrwxrwxrwx root/root usr/man/man8/rtstat.8.gz -> lnstat.8.gz
-rw-r--r-- root/root usr/man/man8/ss.8.gz
-rw-r--r-- root/root usr/man/man8/tc-bfifo.8.gz
-rw-r--r-- root/root usr/man/man8/tc-cbq-details.8.gz

View File

@ -1,3 +1,2 @@
20ef2767896a0f156b6fbabd47936f79 iproute2-2.6.22-070710.tar.gz
ebea778def07e2ca13495117f6e0910e iproute2-netem.patch
7d221e735cba05709341cd46401c4ecd iproute2-2.6.26.tar.bz2
0b01b0404718d043adf55cfa314c80bd net.iproute2

View File

@ -1,18 +1,19 @@
# Description: a collection of utilites for controlling TCP/IP networking and traffic in Linux
# URL: http://linux-net.osdl.org/index.php/Iproute2
# Maintainer: Simone Rota, sip at crux dot nu
# Packager: Mikhail Kolesnik, mike at openbunker dot org
# Description: A collection of utilites for controlling TCP/IP networking and traffic in Linux
# URL: http://linux-net.osdl.org/index.php/Iproute2
# Maintainer: CRUX System Team, core-ports at crux dot nu
# Depends on: db
name=iproute2
version=2.6.22-070710
version=2.6.26
release=1
source=(http://developer.osdl.org/dev/iproute2/download/$name-$version.tar.gz \
net.iproute2 $name-netem.patch)
source=(http://developer.osdl.org/dev/iproute2/download/$name-$version.tar.bz2 \
net.iproute2)
build() {
patch -p1 < $name-netem.patch
make KERNEL_INCLUDE="/lib/modules/`uname -r`/source/include"
make SBINDIR=/sbin MANDIR=/usr/man DESTDIR=$PKG install
rm -rf $PKG/usr/share
install -D -o root -g root -m 0755 $SRC/net.iproute2 $PKG/etc/rc.d/net
cd $name-$version
sed -i "s|local/lib/iptables|lib/xtables|" include/iptables.h
make
make SBINDIR=/sbin MANDIR=/usr/man DESTDIR=$PKG install
rm -r $PKG/share
install -D -m 0755 $SRC/net.iproute2 $PKG/etc/rc.d/net
}

View File

@ -1,11 +0,0 @@
diff -Nru netem.orig/tc/Makefile netem/tc/Makefile
--- netem.orig/tc/Makefile 2007-10-11 23:56:11.348686771 +0200
+++ netem/tc/Makefile 2007-10-11 23:58:27.436441970 +0200
@@ -46,6 +46,7 @@
CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PROB
TCSO :=
+TCSO += q_netem.so
ifeq ($(TC_CONFIG_ATM),y)
TCSO += q_atm.so
endif