lilo: update to 22.8
This commit is contained in:
parent
f561828009
commit
4e9c496960
@ -1,3 +1,3 @@
|
||||
3e05c2b0e0d30e821509eaaec0bbd47c lilo-22.7.3.patch
|
||||
a3aacf90482e0c07492623042b901503 lilo-22.7.3.src.tar.gz
|
||||
72765f2aafd20e23ecf07ebd22baeec7 lilo-22.8.src.tar.gz
|
||||
3bda453de1a93934d270d19e083c3d2c lilo-config.patch
|
||||
82b2a823f77c646dcc75fb1bf6a115b6 lilo.conf
|
||||
|
13
lilo/Pkgfile
13
lilo/Pkgfile
@ -3,17 +3,16 @@
|
||||
# Maintainer: CRUX System Team, core-ports at crux dot nu
|
||||
|
||||
name=lilo
|
||||
version=22.7.3
|
||||
release=3
|
||||
version=22.8
|
||||
release=1
|
||||
source=(http://home.san.rr.com/johninsd/pub/linux/lilo/$name-$version.src.tar.gz \
|
||||
$name-$version.patch lilo.conf)
|
||||
$name-config.patch lilo.conf)
|
||||
|
||||
build() {
|
||||
cd $name-$version
|
||||
patch -p0 < ../$name-$version.patch
|
||||
patch -p1 -i $SRC/$name-config.patch
|
||||
make all
|
||||
make ROOT=$PKG install
|
||||
install -m 644 ../lilo.conf $PKG/etc
|
||||
rm -rf $PKG/sbin/mkrescue \
|
||||
$PKG/usr/man/man8/mkrescue.8
|
||||
install -m 644 $SRC/lilo.conf $PKG/etc
|
||||
rm $PKG/{sbin/mkrescue,usr/man/man8/mkrescue.8}
|
||||
}
|
||||
|
@ -1,15 +1,25 @@
|
||||
--- Makefile.orig 2006-08-12 11:27:22.726223250 +0200
|
||||
+++ Makefile 2006-08-12 11:28:32.070557000 +0200
|
||||
diff -Nru lilo-22.8.orig/Makefile lilo-22.8/Makefile
|
||||
--- lilo-22.8.orig/Makefile 2007-02-19 18:15:10.000000000 +0100
|
||||
+++ lilo-22.8/Makefile 2007-02-20 15:19:21.000000000 +0100
|
||||
@@ -65,7 +65,7 @@
|
||||
# XL_SECS=n Support for extra large (non-standard) floppies.
|
||||
|
||||
CONFIG=-DBDATA -DDSECS=3 -DEVMS -DIGNORECASE -DLVM -DNOKEYBOARD -DONE_SHOT \
|
||||
- -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVERSION -DVIRTUAL \
|
||||
+ -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVIRTUAL \
|
||||
-DMDPRAID
|
||||
-DMDPRAID -DDEVMAPPER
|
||||
|
||||
|
||||
# set the following if you wish LILO.COM to be installed
|
||||
@@ -162,7 +162,7 @@
|
||||
@@ -80,7 +80,7 @@
|
||||
#
|
||||
MAN_DIR=`if [ -f /usr/bin/manpath ]; then \
|
||||
manpath | sed "s/:.*//"; else echo /usr/share/man; fi`
|
||||
-#MAN_DIR=/usr/share/man
|
||||
+MAN_DIR=/usr/man
|
||||
|
||||
# set the compiler optimization level
|
||||
|
||||
@@ -165,7 +165,7 @@
|
||||
#
|
||||
# everything needed to run, just short of installation
|
||||
#
|
Loading…
x
Reference in New Issue
Block a user