Merge branch '2.3' of crux:/home/crux/scm/ports/core into 2.3

This commit is contained in:
Simone Rota 2006-11-26 02:13:53 +00:00
commit 5ae0241d33
18 changed files with 309 additions and 111 deletions

View File

@ -16,15 +16,15 @@ drwxr-xr-x root/root usr/include/
-rw-r--r-- root/root usr/include/db_185.h
-rw-r--r-- root/root usr/include/db_cxx.h
drwxr-xr-x root/root usr/lib/
-rw-r--r-- root/root usr/lib/libdb-4.5.a
-rw-r--r-- root/root usr/lib/libdb-4.5.la
-rwxr-xr-x root/root usr/lib/libdb-4.5.so
lrwxrwxrwx root/root usr/lib/libdb-4.so -> libdb-4.5.so
-rw-r--r-- root/root usr/lib/libdb-4.4.a
-rw-r--r-- root/root usr/lib/libdb-4.4.la
-rwxr-xr-x root/root usr/lib/libdb-4.4.so
lrwxrwxrwx root/root usr/lib/libdb-4.so -> libdb-4.4.so
-rw-r--r-- root/root usr/lib/libdb.a
lrwxrwxrwx root/root usr/lib/libdb.so -> libdb-4.5.so
-rw-r--r-- root/root usr/lib/libdb_cxx-4.5.a
-rw-r--r-- root/root usr/lib/libdb_cxx-4.5.la
-rwxr-xr-x root/root usr/lib/libdb_cxx-4.5.so
lrwxrwxrwx root/root usr/lib/libdb_cxx-4.so -> libdb_cxx-4.5.so
lrwxrwxrwx root/root usr/lib/libdb.so -> libdb-4.4.so
-rw-r--r-- root/root usr/lib/libdb_cxx-4.4.a
-rw-r--r-- root/root usr/lib/libdb_cxx-4.4.la
-rwxr-xr-x root/root usr/lib/libdb_cxx-4.4.so
lrwxrwxrwx root/root usr/lib/libdb_cxx-4.so -> libdb_cxx-4.4.so
-rw-r--r-- root/root usr/lib/libdb_cxx.a
lrwxrwxrwx root/root usr/lib/libdb_cxx.so -> libdb_cxx-4.5.so
lrwxrwxrwx root/root usr/lib/libdb_cxx.so -> libdb_cxx-4.4.so

View File

@ -1,3 +1,5 @@
3154c250247b1c2bf6f91ab6a3365961 db-4.5.20.1.patch
fd1ec2d2c6eee9ff7a7f5f19b663440e db-4.5.20.2.patch
b0f1c777708cb8e9d37fb47e7ed3312d db-4.5.20.tar.gz
d84dff288a19186b136b0daf7067ade3 db-4.4.20.tar.gz
66584d621355df055b6e05b4a02e9c3e patch.4.4.20.1
85df93a0867f6cace3501671cdeb6ed1 patch.4.4.20.2
88ee91889ebf5498b22b2e7bed945d41 patch.4.4.20.3
c2ef7b3e59460c35950fab5f2faa3fc0 patch.4.4.20.4

View File

@ -1,17 +1,16 @@
# Description: Berkeley DB
# URL: http://www.oracle.com/technology/products/berkeley-db/
# URL: http://www.sleepycat.com/products/db.shtml
# Maintainer: Per Lidén, core-ports at crux dot nu
name=db
version=4.5.20
release=1
version=4.4.20
release=2
source=(http://download.oracle.com/berkeley-db/$name-$version.tar.gz \
db-4.5.20.1.patch db-4.5.20.2.patch)
http://www.oracle.com/technology/products/berkeley-db/db/update/4.4.20/patch.4.4.20.{1,2,3,4})
build() {
cd $name-$version
patch -p1 -i $SRC/db-4.5.20.1.patch
patch -p1 -i $SRC/db-4.5.20.2.patch
cat $SRC/patch.4.4.20.{1,2,3,4} | patch -p0
cd build_unix
LDFLAGS="-lpthread" \
../dist/configure --prefix=/usr \

View File

@ -1,32 +0,0 @@
diff -Nru db-4.5.20.orig/sequence/sequence.c db-4.5.20/sequence/sequence.c
--- db-4.5.20.orig/sequence/sequence.c 2006-11-18 10:37:11.000000000 +0100
+++ db-4.5.20/sequence/sequence.c 2006-11-18 10:44:31.000000000 +0100
@@ -228,6 +228,9 @@
seq->seq_data.ulen = seq->seq_data.size = sizeof(seq->seq_record);
seq->seq_rp = &seq->seq_record;
+ if ((ret = __dbt_usercopy(dbenv, keyp)) != 0)
+ goto err;
+
memset(&seq->seq_key, 0, sizeof(DBT));
if ((ret = __os_malloc(dbenv, keyp->size, &seq->seq_key.data)) != 0)
goto err;
@@ -365,6 +368,7 @@
ret = t_ret;
ENV_LEAVE(dbenv, ip);
+ __dbt_userfree(dbenv, keyp, NULL, NULL);
return (ret);
}
@@ -765,6 +769,10 @@
{
SEQ_ILLEGAL_BEFORE_OPEN(seq, "DB_SEQUENCE->get_key");
+ if (F_ISSET(key, DB_DBT_USERCOPY))
+ return (__db_retcopy(seq->seq_dbp->dbenv, key,
+ seq->seq_key.data, seq->seq_key.size, NULL, 0));
+
key->data = seq->seq_key.data;
key->size = key->ulen = seq->seq_key.size;
key->flags = seq->seq_key.flags;

View File

@ -1,52 +0,0 @@
diff -Nru db-4.5.20.orig/rep/rep_method.c db-4.5.20/rep/rep_method.c
--- db-4.5.20.orig/rep/rep_method.c 2006-11-18 10:37:10.000000000 +0100
+++ db-4.5.20/rep/rep_method.c 2006-11-18 10:47:38.000000000 +0100
@@ -526,10 +526,12 @@
* will allow the client to either perform recovery or
* simply join in.
*/
- if (announce)
+ if (announce) {
+ if ((ret = __dbt_usercopy(dbenv, dbt)) != 0)
+ goto err;
(void)__rep_send_message(dbenv,
DB_EID_BROADCAST, REP_NEWCLIENT, NULL, dbt, 0, 0);
- else
+ } else
(void)__rep_send_message(dbenv,
DB_EID_BROADCAST, REP_ALIVE_REQ, NULL, NULL, 0, 0);
}
@@ -553,6 +555,7 @@
}
if (pending_event != DB_EVENT_NO_SUCH_EVENT)
DB_EVENT(dbenv, pending_event, NULL);
+ __dbt_userfree(dbenv, dbt, NULL, NULL);
return (ret);
}
diff -Nru db-4.5.20.orig/rep/rep_record.c db-4.5.20/rep/rep_record.c
--- db-4.5.20.orig/rep/rep_record.c 2006-11-18 10:37:10.000000000 +0100
+++ db-4.5.20/rep/rep_record.c 2006-11-18 10:47:38.000000000 +0100
@@ -163,6 +163,14 @@
return (EINVAL);
}
+ if ((ret = __dbt_usercopy(dbenv, control)) != 0 ||
+ (ret = __dbt_usercopy(dbenv, rec)) != 0) {
+ __dbt_userfree(dbenv, control, rec, NULL);
+ __db_errx(dbenv,
+ "DB_ENV->rep_process_message: error retrieving DBT contents");
+ return ret;
+ }
+
ret = 0;
db_rep = dbenv->rep_handle;
rep = db_rep->region;
@@ -621,6 +629,7 @@
*ret_lsnp = rp->lsn;
ret = DB_REP_NOTPERM;
}
+ __dbt_userfree(dbenv, control, rec, NULL);
return (ret);
}

38
exim/.footprint Normal file
View File

@ -0,0 +1,38 @@
drwxr-xr-x root/root etc/
drwxr-xr-x root/root etc/exim/
-rw-r--r-- root/root etc/exim/aliases
-rw-r--r-- root/root etc/exim/exim.conf
drwxr-xr-x root/root etc/rc.d/
-rwxr-xr-x root/root etc/rc.d/exim
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
lrwxrwxrwx root/root usr/bin/mailq -> ../sbin/exim-4.63-1
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man8/
-rw-r--r-- root/root usr/man/man8/exim.8.gz
drwxr-xr-x root/root usr/sbin/
-rwxr-xr-x root/root usr/sbin/exicyclog
-rwxr-xr-x root/root usr/sbin/exigrep
lrwxrwxrwx root/root usr/sbin/exim -> exim-4.63-1
-rwsr-xr-x root/root usr/sbin/exim-4.63-1
-rwxr-xr-x root/root usr/sbin/exim_checkaccess
-rwxr-xr-x root/root usr/sbin/exim_dbmbuild
-rwxr-xr-x root/root usr/sbin/exim_dumpdb
-rwxr-xr-x root/root usr/sbin/exim_fixdb
-rwxr-xr-x root/root usr/sbin/exim_lock
-rwxr-xr-x root/root usr/sbin/exim_tidydb
-rwxr-xr-x root/root usr/sbin/eximstats
-rwxr-xr-x root/root usr/sbin/exinext
-rwxr-xr-x root/root usr/sbin/exipick
-rwxr-xr-x root/root usr/sbin/exiqgrep
-rwxr-xr-x root/root usr/sbin/exiqsumm
-rwxr-xr-x root/root usr/sbin/exiwhat
lrwxrwxrwx root/root usr/sbin/sendmail -> exim-4.63-1
drwxr-xr-x root/root var/
drwxr-xr-x root/root var/log/
drwxr-x--- mail/mail var/log/exim/
-rw-r----- mail/mail var/log/exim/exim_mainlog (EMPTY)
-rw-r----- mail/mail var/log/exim/exim_paniclog (EMPTY)
-rw-r----- mail/mail var/log/exim/exim_rejectlog (EMPTY)
drwxr-xr-x root/root var/spool/
drwxr-x--- mail/mail var/spool/exim/

3
exim/.md5sum Normal file
View File

@ -0,0 +1,3 @@
f1682811a7fd2897153c5b0e33177509 exim
dde2d5f7106d51607409af94174db46c exim-4.63.tar.bz2
acc159b50022cb2e1574df1bde2d9784 exim-config.patch

33
exim/Pkgfile Normal file
View File

@ -0,0 +1,33 @@
# Description: Mail transfer agent
# URL: http://www.exim.org
# Maintainer: Juergen Daubert, juergen dot daubert at t-online dot de
# Depends on: db, openssl
name=exim
version=4.63
release=2
source=(ftp://ftp.exim.org/pub/exim/exim4/$name-$version.tar.bz2 \
$name $name-config.patch)
build() {
cd $name-$version
sed "s/#CFLAGS#/$CFLAGS/" $SRC/$name-config.patch | patch -p1
cp src/EDITME Local/Makefile
make
make DESTDIR=$PKG install
install -D -m 755 $SRC/exim $PKG/etc/rc.d/exim
install -D -m 644 doc/exim.8 $PKG/usr/man/man8/exim.8
install -d $PKG/var/{log,spool} $PKG/usr/bin
install -d -m 0750 -o mail -g mail $PKG/var/{log,spool}/exim
touch $PKG/var/log/exim/exim_{mainlog,paniclog,rejectlog}
chown mail:mail $PKG/var/log/exim/*
chmod 640 $PKG/var/log/exim/*
ln -sf $name-$version-1 $PKG/usr/sbin/sendmail
ln -sf ../sbin/$name-$version-1 $PKG/usr/bin/mailq
}

26
exim/exim Normal file
View File

@ -0,0 +1,26 @@
#!/bin/sh
#
# /etc/rc.d/exim: start/stop exim daemon
#
case $1 in
start)
/usr/sbin/exim -bd -q15m
;;
stop)
killall -q /usr/sbin/exim
;;
restart)
$0 stop
sleep 2
$0 start
;;
reload)
kill -s SIGHUP `pidof exim`
;;
*)
echo "usage: $0 [start|stop|restart|reload]"
;;
esac
# End of file

178
exim/exim-config.patch Normal file
View File

@ -0,0 +1,178 @@
diff -Nru exim-4.63.orig/src/EDITME exim-4.63/src/EDITME
--- exim-4.63.orig/src/EDITME 2006-11-10 17:10:12.000000000 +0100
+++ exim-4.63/src/EDITME 2006-11-10 17:10:25.000000000 +0100
@@ -74,7 +74,7 @@
# this would be wanted.
###############################################################################
-
+CFLAGS=#CFLAGS#
###############################################################################
# THESE ARE THINGS YOU MUST SPECIFY #
@@ -100,7 +100,7 @@
# /usr/local/sbin. The installation script will try to create this directory,
# and any superior directories, if they do not exist.
-BIN_DIRECTORY=/usr/exim/bin
+BIN_DIRECTORY=/usr/sbin
#------------------------------------------------------------------------------
@@ -116,7 +116,7 @@
# don't exist. It will also install a default runtime configuration if this
# file does not exist.
-CONFIGURE_FILE=/usr/exim/configure
+CONFIGURE_FILE=/etc/exim/exim.conf
# It is possible to specify a colon-separated list of files for CONFIGURE_FILE.
# In this case, Exim will use the first of them that exists when it is run.
@@ -134,7 +134,7 @@
# owner of a local mailbox.) Specifying these values as root is very strongly
# discouraged.
-EXIM_USER=
+EXIM_USER=ref:mail
# If you specify EXIM_USER as a name, this is looked up at build time, and the
# uid number is built into the binary. However, you can specify that this
@@ -244,7 +244,7 @@
# MBX, is included only when requested. If you do not know what this is about,
# leave these settings commented out.
-# SUPPORT_MAILDIR=yes
+SUPPORT_MAILDIR=yes
# SUPPORT_MAILSTORE=yes
# SUPPORT_MBX=yes
@@ -261,9 +261,9 @@
LOOKUP_DBM=yes
LOOKUP_LSEARCH=yes
-# LOOKUP_CDB=yes
+LOOKUP_CDB=yes
# LOOKUP_DNSDB=yes
-# LOOKUP_DSEARCH=yes
+LOOKUP_DSEARCH=yes
# LOOKUP_IBASE=yes
# LOOKUP_LDAP=yes
# LOOKUP_MYSQL=yes
@@ -320,7 +320,7 @@
# files are defaulted in the OS/Makefile-Default file, but can be overridden in
# local OS-specific make files.
-EXIM_MONITOR=eximon.bin
+# EXIM_MONITOR=eximon.bin
#------------------------------------------------------------------------------
@@ -473,9 +473,9 @@
# included in the Exim binary. You will then need to set up the run time
# configuration to make use of the mechanism(s) selected.
-# AUTH_CRAM_MD5=yes
+AUTH_CRAM_MD5=yes
# AUTH_CYRUS_SASL=yes
-# AUTH_PLAINTEXT=yes
+AUTH_PLAINTEXT=yes
# AUTH_SPA=yes
@@ -562,10 +562,10 @@
# leave these settings commented out.
# This setting is required for any TLS support (either OpenSSL or GnuTLS)
-# SUPPORT_TLS=yes
+SUPPORT_TLS=yes
# Uncomment this setting if you are using OpenSSL
-# TLS_LIBS=-lssl -lcrypto
+TLS_LIBS=-lssl -lcrypto
# Uncomment these settings if you are using GnuTLS
# USE_GNUTLS=yes
@@ -629,7 +629,7 @@
# %s. This will be replaced by one of the strings "main", "panic", or "reject"
# to form the final file names. Some installations may want something like this:
-# LOG_FILE_PATH=/var/log/exim_%slog
+LOG_FILE_PATH=/var/log/exim/exim_%slog
# which results in files with names /var/log/exim_mainlog, etc. The directory
# in which the log files are placed must exist; Exim does not try to create
@@ -678,7 +678,7 @@
# files. Both the name of the command and the suffix that it adds to files
# need to be defined here. See also the EXICYCLOG_MAX configuration.
-COMPRESS_COMMAND=/usr/bin/gzip
+COMPRESS_COMMAND=/bin/gzip
COMPRESS_SUFFIX=gz
@@ -686,7 +686,7 @@
# If the exigrep utility is fed compressed log files, it tries to uncompress
# them using this command.
-ZCAT_COMMAND=/usr/bin/zcat
+ZCAT_COMMAND=/bin/zcat
#------------------------------------------------------------------------------
@@ -796,9 +796,9 @@
# You may well also have to specify a local "include" file and an additional
# library for TCP wrappers, so you probably need something like this:
#
-# USE_TCP_WRAPPERS=yes
+USE_TCP_WRAPPERS=yes
# CFLAGS=-O -I/usr/local/include
-# EXTRALIBS_EXIM=-L/usr/local/lib -lwrap
+EXTRALIBS_EXIM=-lwrap
#
# but of course there may need to be other things in CFLAGS and EXTRALIBS_EXIM
# as well.
@@ -824,7 +824,7 @@
# aliases). The following setting can be changed to specify a different
# location for the system alias file.
-SYSTEM_ALIASES_FILE=/etc/aliases
+SYSTEM_ALIASES_FILE=/etc/exim/aliases
#------------------------------------------------------------------------------
@@ -870,10 +870,10 @@
# haven't got Perl, Exim will still build and run; you just won't be able to
# use those utilities.
-# CHOWN_COMMAND=/usr/bin/chown
-# CHGRP_COMMAND=/usr/bin/chgrp
-# MV_COMMAND=/bin/mv
-# RM_COMMAND=/bin/rm
+CHOWN_COMMAND=/bin/chown
+CHGRP_COMMAND=/bin/chgrp
+MV_COMMAND=/bin/mv
+RM_COMMAND=/bin/rm
# PERL_COMMAND=/usr/bin/perl
@@ -1068,7 +1068,7 @@
# (process id) to a file so that it can easily be identified. The path of the
# file can be specified here. Some installations may want something like this:
-# PID_FILE_PATH=/var/lock/exim.pid
+PID_FILE_PATH=/var/run/exim.pid
# If PID_FILE_PATH is not defined, Exim writes a file in its spool directory
# using the name "exim-daemon.pid".
diff -Nru exim-4.63.orig/src/configure.default exim-4.63/src/configure.default
--- exim-4.63.orig/src/configure.default 2006-11-10 17:10:12.000000000 +0100
+++ exim-4.63/src/configure.default 2006-11-10 17:11:00.000000000 +0100
@@ -56,7 +56,7 @@
# +local_domains, +relay_to_domains, and +relay_from_hosts, respectively. They
# are all colon-separated lists:
-domainlist local_domains = @
+domainlist local_domains = @ : localhost
domainlist relay_to_domains =
hostlist relay_from_hosts = 127.0.0.1

View File

@ -1,9 +1,9 @@
0ddfec662cbd2cc3b53f61cb9a5a72a0 fstab
3ebcb005449f69c2ef58fd54b23125ba group
3f2325551b8eb5d7a55a54b08fe967db group
6cef6f5ab23244460cdf13c98e68b010 issue
346ede8d637940e2898cd29c56a37d30 mime.types
d41d8cd98f00b204e9800998ecf8427e motd
aa183b009b52291616573c8071db792a passwd
a76a49d1c8ec2c3b3acbe7b17842fb9f passwd
4faaa4e1ba24038f8638a0cae5046cfb securetty
0034d284ea9b44efb750535ab3f15837 shadow
4e223e60eeeed7d04eca5c0473ac8984 shadow
87f6864e24d24c8fb8718ed70269309c shells

View File

@ -3,8 +3,8 @@
# Maintainer: Per Lidén, core-ports at crux dot nu
name=filesystem
version=2.2
release=2
version=2.3
release=1
source=(issue motd shells group passwd shadow securetty fstab mime.types)
build() {

View File

@ -12,5 +12,6 @@ wheel::10:root
ftp::11:
mail::12:
slocate::13:
www::15:
nobody::99:
users::100:

View File

@ -3,4 +3,5 @@ bin:x:1:1:bin:/bin:
daemon:x:2:2:daemon:/sbin:
mail:x:8:12:mail:/var/spool/mail:
ftp:x:14:11:ftp:/var/ftp:
www:x:15:15:www:/var/www:/bin/false
nobody:x:99:99:nobody:/:

View File

@ -3,4 +3,5 @@ bin:x:0::::::
daemon:x:0::::::
mail:x:0::::::
ftp:x:0::::::
www:x:0::::::
nobody:x:0::::::

View File

@ -1,3 +1,3 @@
3e05c2b0e0d30e821509eaaec0bbd47c lilo-22.7.3.patch
a3aacf90482e0c07492623042b901503 lilo-22.7.3.src.tar.gz
e4be19b729f2c848e0838a937f960e1b lilo.conf
82b2a823f77c646dcc75fb1bf6a115b6 lilo.conf

View File

@ -4,7 +4,7 @@
name=lilo
version=22.7.3
release=2
release=3
source=(http://home.san.rr.com/johninsd/pub/linux/lilo/$name-$version.src.tar.gz \
$name-$version.patch lilo.conf)

View File

@ -5,7 +5,7 @@
lba32
install=text
boot=/dev/#DEVICE#
image=/vmlinuz
image=/boot/vmlinuz
label=CRUX
root=/dev/#ROOT_DEVICE#
read-only