Merge branch '2.4' into 2.5

This commit is contained in:
Juergen Daubert 2008-09-27 10:40:34 +02:00
commit 8faa0909ae
19 changed files with 171 additions and 153 deletions

View File

@ -1,4 +1,5 @@
drwxr-xr-x root/root etc/
drwxr-xr-x root/root etc/cron.d/
drwxr-xr-x root/root etc/cron/
drwxr-xr-x root/root etc/cron/daily/
drwxr-xr-x root/root etc/cron/monthly/

View File

@ -1,5 +1,5 @@
3540f192c0d50dbc566211ac7052f39e crond
1a208f09e660c72f0117185289b2c109 crond
3e71eb70863bea6491bf4b3ac291a7b0 crontab
d0d819a48773b4f3f9f2f8322ca64097 dcron-2.3.3.patch
537cda2dff7dfaf87660fee91b2cf78f dcron-2.3.3.tar.gz
adf3ad8cb05ea391b9a9169ddcccaba4 dcron-3.2.patch
c2c816deb389b4bfb00761f26afe3efd dcron32.tgz
d80b27b1b9532890136c14d30e2a0d2b runjobs

View File

@ -1,23 +1,29 @@
# Description: Multi-user cron daemon
# URL: http://freshmeat.net/projects/dcron/
# URL: http://apollo.backplane.com/FreeSrc
# Maintainer: CRUX System Team, core-ports at crux dot nu
name=dcron
version=2.3.3
release=10
source=(http://www.ibiblio.org/pub/linux/system/daemons/cron/$name-$version.tar.gz \
crontab runjobs crond $name-$version.patch)
version=3.2
release=1
source=(http://apollo.backplane.com/FreeSrc/dcron32.tgz \
crontab runjobs crond $name-$version.patch)
build() {
cd $name-$version
patch -p1 < ../$name-$version.patch
cd $name
patch -p1 -i $SRC/$name-$version.patch
make
make DESTDIR=$PKG install
mkdir -p $PKG/var/{spool,log} $PKG/etc/cron/{daily,weekly,monthly}
install -D -m 600 ../crontab $PKG/var/spool/cron/crontabs/root
install -D -m 755 ../crond $PKG/etc/rc.d/crond
install -D -m 755 ../runjobs $PKG/usr/sbin/runjobs
chmod 0700 $PKG/var/spool/cron/crontabs
install -d $PKG/var/{spool/cron,log}
install -d $PKG/etc/{cron.d,cron/{daily,weekly,monthly}}
install -d -m 700 $PKG/var/spool/cron/crontabs
install -m 600 $SRC/crontab $PKG/var/spool/cron/crontabs/root
ln -s ../var/spool/cron/crontabs/root $PKG/etc/crontab
install -D -m 755 $SRC/crond $PKG/etc/rc.d/crond
install -D -m 755 $SRC/runjobs $PKG/usr/sbin/runjobs
touch $PKG/var/log/cron
}

View File

@ -5,7 +5,7 @@
case $1 in
start)
/usr/sbin/crond &> /var/log/cron
/usr/sbin/crond >> /var/log/cron 2>&1
;;
stop)
killall -q /usr/sbin/crond

View File

@ -1,91 +0,0 @@
diff -ru dcron-2.3.3/Makefile dcron-2.3.3-new/Makefile
--- dcron-2.3.3/Makefile Fri Sep 5 21:42:44 1997
+++ dcron-2.3.3-new/Makefile Thu Aug 9 22:23:34 2001
@@ -1,8 +1,9 @@
# Makefile for dillon's cron and crontab
#
+DESTDIR =
CC = gcc
-CFLAGS = -O2 -Wall -Wstrict-prototypes
+CFLAGS += -Wall -Wstrict-prototypes
LIB =
SRCS = main.c subs.c database.c job.c
OBJS = main.o subs.o database.o job.o
@@ -13,12 +14,10 @@
all: ${PROTOS} crond crontab
crond: ${OBJS}
- ${CC} ${CFLAGS} -o crond ${OBJS} ${LIB}
- strip crond
+ ${CC} ${CFLAGS} -o crond ${OBJS} ${LIB} ${LDFLAGS}
crontab: ${D_OBJS}
- ${CC} ${CFLAGS} -o crontab ${D_OBJS}
- strip crontab
+ ${CC} ${CFLAGS} -o crontab ${D_OBJS} ${LDFLAGS}
protos.h: ${SRCS} ${D_SRCS}
fgrep -h Prototype ${SRCS} ${D_SRCS} >protos.h
@@ -30,10 +29,10 @@
rm -f *.o dcron.tgz $(PROTOS)
install: crond crontab
- install -o root -g root -m 0755 crond /usr/sbin
- install -o root -g root -m 4755 crontab /usr/bin
- install -o root -g root crontab.1 /usr/man/man1
- install -o root -g root crond.8 /usr/man/man8
+ install -o root -g root -m 0755 -D crond $(DESTDIR)/usr/sbin/crond
+ install -o root -g root -m 4755 -D crontab $(DESTDIR)/usr/bin/crontab
+ install -o root -g root -m 0644 -D crontab.1 $(DESTDIR)/usr/man/man1/crontab.1
+ install -o root -g root -m 0644 -D crond.8 $(DESTDIR)/usr/man/man8/crond.8
tar: cleano
(cd ..; tar cvf - dcron | gzip -9 >dcron.tgz.tmp)
diff -ru dcron-2.3.3/defs.h dcron-2.3.3-new/defs.h
--- dcron-2.3.3/defs.h Fri Sep 5 21:44:32 1997
+++ dcron-2.3.3-new/defs.h Thu Aug 9 22:23:53 2001
@@ -35,7 +35,7 @@
#define OPEN_MAX 256
#endif
#ifndef SENDMAIL
-#define SENDMAIL "/usr/lib/sendmail"
+#define SENDMAIL "/usr/sbin/sendmail"
#endif
#ifndef SENDMAIL_ARGS
#define SENDMAIL_ARGS "-t", "-oem", "-i"
diff -ru dcron-2.3.3/subs.c dcron-2.3.3-new/subs.c
--- dcron-2.3.3/subs.c Mon Feb 16 20:35:10 1998
+++ dcron-2.3.3-new/subs.c Thu Aug 9 22:23:34 2001
@@ -15,7 +15,7 @@
Prototype int ChangeUser(const char *user, short dochdir);
Prototype void vlog(int level, int fd, const char *ctl, va_list va);
Prototype int slog(char *buf, size_t sz, const char *ctl, va_list va, short useDate);
-Prototype char *strdup(const char *);
+/*Prototype char *strdup(const char *);*/
void
log9(const char *ctl, ...)
@@ -80,7 +80,7 @@
buf[0] = 0;
if (useDate)
- strftime(buf, 128, "%d-%b-%y %H:%M ", tp);
+ strftime(buf, 128, "%d-%b-%Y %H:%M ", tp);
vsnprintf(buf + strlen(buf), sz - strlen(buf), ctl, va);
return(strlen(buf));
}
@@ -131,6 +131,7 @@
return(pas->pw_uid);
}
+/*
char *
strdup(const char *str)
{
@@ -140,4 +141,4 @@
strcpy(ptr, str);
return(ptr);
}
-
+*/

54
dcron/dcron-3.2.patch Normal file
View File

@ -0,0 +1,54 @@
diff -Nru dcron.orig/Makefile dcron/Makefile
--- dcron.orig/Makefile 2008-09-24 10:10:19.000000000 +0200
+++ dcron/Makefile 2008-09-24 14:48:17.000000000 +0200
@@ -3,7 +3,7 @@
DESTDIR ?= /usr/local
CC = gcc
-CFLAGS = -O2 -Wall -Wstrict-prototypes
+CFLAGS += -Wall -Wstrict-prototypes -D_GNU_SOURCE -DSENDMAIL="\"/usr/sbin/sendmail\""
LIB =
SRCS = main.c subs.c database.c job.c
OBJS = main.o subs.o database.o job.o
@@ -15,12 +15,10 @@
all: ${PROTOS} crond crontab
crond: ${OBJS}
- ${CC} ${CFLAGS} -o crond ${OBJS} ${LIB}
- strip crond
+ ${CC} ${CFLAGS} -o crond ${OBJS} ${LIB} ${LDFLAGS}
crontab: ${D_OBJS}
- ${CC} ${CFLAGS} -o crontab ${D_OBJS}
- strip crontab
+ ${CC} ${CFLAGS} -o crontab ${D_OBJS} ${LDFLAGS}
protos.h: ${SRCS} ${D_SRCS}
fgrep -h Prototype ${SRCS} ${D_SRCS} >protos.h
@@ -32,10 +30,10 @@
rm -f *.o dcron.tgz ${PROTOS}
install:
- install -o root -g wheel -m 0755 crond ${DESTDIR}/sbin/crond
- install -o root -g wheel -m 4755 crontab ${DESTDIR}/bin/crontab
- install -o root -g wheel -m 0644 crontab.1 ${DESTDIR}/man/man1/crontab.1
- install -o root -g wheel -m 0644 crond.8 ${DESTDIR}/man/man8/crond.8
+ install -o root -g root -m 0755 -D crond $(DESTDIR)/usr/sbin/crond
+ install -o root -g root -m 4755 -D crontab $(DESTDIR)/usr/bin/crontab
+ install -o root -g root -m 0644 -D crontab.1 $(DESTDIR)/usr/man/man1/crontab.1
+ install -o root -g root -m 0644 -D crond.8 $(DESTDIR)/usr/man/man8/crond.8
# dillon-specific
#
diff -Nru dcron.orig/subs.c dcron/subs.c
--- dcron.orig/subs.c 2008-09-24 10:10:19.000000000 +0200
+++ dcron/subs.c 2008-09-24 14:44:30.000000000 +0200
@@ -79,7 +79,7 @@
buf[0] = 0;
if (useDate)
- strftime(buf, 128, "%d-%b-%y %H:%M ", tp);
+ strftime(buf, 128, "%d-%b-%Y %H:%M ", tp);
vsnprintf(buf + strlen(buf), nmax, ctl, va);
return(strlen(buf));
}

View File

@ -1,2 +1,2 @@
83144fa7e0e63647f920b77650ea1836 e2fsprogs-1.41.0.tar.gz
ddf13b3c9ece247c457db20ca9a10c3c e2fsprogs-1.41.1.tar.gz
2c91cdc74bbbb198135e0c8911d7eadd e2fsprogs-symlink.patch

View File

@ -3,7 +3,7 @@
# Maintainer: CRUX System Team, core-ports at crux dot nu
name=e2fsprogs
version=1.41.0
version=1.41.1
release=1
source=(http://dl.sourceforge.net/sourceforge/$name/$name-$version.tar.gz \
$name-symlink.patch)

View File

@ -1124,6 +1124,7 @@ drwxr-xr-x root/root usr/man/man3/
-rw-r--r-- root/root usr/man/man3/fmtmsg.3.gz
-rw-r--r-- root/root usr/man/man3/fnmatch.3.gz
-rw-r--r-- root/root usr/man/man3/fopen.3.gz
-rw-r--r-- root/root usr/man/man3/fopencookie.3.gz
-rw-r--r-- root/root usr/man/man3/forkpty.3.gz
-rw-r--r-- root/root usr/man/man3/fpathconf.3.gz
-rw-r--r-- root/root usr/man/man3/fpclassify.3.gz
@ -3193,6 +3194,7 @@ drwxr-xr-x root/root usr/man/man5/
-rw-r--r-- root/root usr/man/man5/issue.5.gz
-rw-r--r-- root/root usr/man/man5/locale.5.gz
-rw-r--r-- root/root usr/man/man5/motd.5.gz
-rw-r--r-- root/root usr/man/man5/networks.5.gz
-rw-r--r-- root/root usr/man/man5/nologin.5.gz
-rw-r--r-- root/root usr/man/man5/nscd.conf.5.gz
-rw-r--r-- root/root usr/man/man5/nsswitch.conf.5.gz

View File

@ -1,2 +1,2 @@
4d6340a002d7ab05d9690b54273aafc7 man-pages-3.08.tar.bz2
cc5c9da5a24d65df071b12505ec5a445 man-pages-3.10.tar.bz2
7c78aff03c0a6767ba483d34f19e4b09 man-pages-posix-2003-a.tar.bz2

View File

@ -4,7 +4,7 @@
# Depends on: man
name=man-pages
version=3.08
version=3.10
release=1
source=(http://www.kernel.org/pub/linux/docs/man-pages/$name-$version.tar.bz2 \
http://www.kernel.org/pub/linux/docs/man-pages/man-pages-posix/man-pages-posix-2003-a.tar.bz2)

View File

@ -1,18 +1,19 @@
drwxr-xr-x root/root sbin/
-rwxr-xr-x root/root sbin/debugreiserfs
lrwxrwxrwx root/root sbin/fsck.reiserfs -> reiserfsck
lrwxrwxrwx root/root sbin/mkfs.reiserfs -> mkreiserfs
-rwxr-xr-x root/root sbin/mkreiserfs
-rwxr-xr-x root/root sbin/reiserfsck
-rwxr-xr-x root/root sbin/reiserfstune
-rwxr-xr-x root/root sbin/resize_reiserfs
-rwxr-xr-x root/root sbin/debugfs.reiserfs
lrwxrwxrwx root/root sbin/debugreiserfs -> debugfs.reiserfs
-rwxr-xr-x root/root sbin/fsck.reiserfs
-rwxr-xr-x root/root sbin/mkfs.reiserfs
lrwxrwxrwx root/root sbin/mkreiserfs -> mkfs.reiserfs
lrwxrwxrwx root/root sbin/reiserfsck -> fsck.reiserfs
lrwxrwxrwx root/root sbin/reiserfstune -> tunefs.reiserfs
lrwxrwxrwx root/root sbin/resize_reiserfs -> resizefs.reiserfs
-rwxr-xr-x root/root sbin/resizefs.reiserfs
-rwxr-xr-x root/root sbin/tunefs.reiserfs
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man8/
-rw-r--r-- root/root usr/man/man8/debugreiserfs.8.gz
lrwxrwxrwx root/root usr/man/man8/fsck.reiserfs.8.gz -> reiserfsck.8.gz
lrwxrwxrwx root/root usr/man/man8/mkfs.reiserfs.8.gz -> mkreiserfs.8.gz
-rw-r--r-- root/root usr/man/man8/mkreiserfs.8.gz
-rw-r--r-- root/root usr/man/man8/reiserfsck.8.gz
-rw-r--r-- root/root usr/man/man8/reiserfstune.8.gz
-rw-r--r-- root/root usr/man/man8/resize_reiserfs.8.gz
-rw-r--r-- root/root usr/man/man8/debugfs.reiserfs.8.gz
-rw-r--r-- root/root usr/man/man8/fsck.reiserfs.8.gz
-rw-r--r-- root/root usr/man/man8/mkfs.reiserfs.8.gz
-rw-r--r-- root/root usr/man/man8/resizefs.reiserfs.8.gz
-rw-r--r-- root/root usr/man/man8/tunefs.reiserfs.8.gz

View File

@ -1,2 +1,2 @@
a94fcb84e10daa45e7e04b9673a28a66 reiserfsprogs-3.6.19.patch
b42cf15f6651c3ceff5cb84996c0d539 reiserfsprogs-3.6.19.tar.gz
3b3392f59c5d302cf858bc4cf194b258 reiserfsprogs-3.6.20.tar.gz
095ba28e01f2192b0f52533d5959ca62 reiserfsprogs-symlink.patch

View File

@ -4,19 +4,15 @@
# Depends on: e2fsprogs
name=reiserfsprogs
version=3.6.19
version=3.6.20
release=1
source=(http://fresh.t-systems-sfr.com/linux/src/$name-$version.tar.gz \
$name-$version.patch)
$name-symlink.patch)
build () {
cd $name-$version
patch -p1 < ../$name-$version.patch
patch -p1 -i $SRC/$name-symlink.patch
./configure --prefix=/ --mandir=/usr/man
make
make DESTDIR=$PKG install
ln -sf mkreiserfs $PKG/sbin/mkfs.reiserfs
ln -sf mkreiserfs.8.gz $PKG/usr/man/man8/mkfs.reiserfs.8.gz
ln -sf reiserfsck $PKG/sbin/fsck.reiserfs
ln -sf reiserfsck.8.gz $PKG/usr/man/man8/fsck.reiserfs.8.gz
make
make -j1 DESTDIR=$PKG install
}

View File

@ -1,13 +0,0 @@
diff -ru reiserfsprogs-3.6.19/include/reiserfs_fs.h reiserfsprogs-3.6.19-new/include/reiserfs_fs.h
--- reiserfsprogs-3.6.19/include/reiserfs_fs.h 2004-09-16 09:49:05.000000000 +0200
+++ reiserfsprogs-3.6.19-new/include/reiserfs_fs.h 2004-10-19 22:56:51.086278496 +0200
@@ -38,7 +38,8 @@
# define extern_inline
#endif
-#include <asm/unaligned.h>
+#define get_unaligned(ptr) (*(ptr))
+#define put_unaligned(val, ptr) ((void)( *(ptr) = (val)))
#ifndef get_unaligned
#if defined(__ppc__) || defined(ppc) || defined(__ppc) || \

View File

@ -0,0 +1,60 @@
diff -Nru reiserfsprogs-3.6.20.orig/utils/debugfs/Makefile.in reiserfsprogs-3.6.20/utils/debugfs/Makefile.in
--- reiserfsprogs-3.6.20.orig/utils/debugfs/Makefile.in 2008-09-26 23:49:24.000000000 +0200
+++ reiserfsprogs-3.6.20/utils/debugfs/Makefile.in 2008-09-26 23:54:12.000000000 +0200
@@ -590,7 +590,7 @@
install-debugreiserfs:
if test -f $(DESTDIR)$(sbindir)/debugfs.reiserfs; then \
rm -f $(DESTDIR)$(sbindir)/debugreiserfs; \
- ln $(DESTDIR)$(sbindir)/debugfs.reiserfs $(DESTDIR)$(sbindir)/debugreiserfs; \
+ ln -s debugfs.reiserfs $(DESTDIR)$(sbindir)/debugreiserfs; \
fi;
install-data-local: install-debugreiserfs
diff -Nru reiserfsprogs-3.6.20.orig/utils/fsck/Makefile.in reiserfsprogs-3.6.20/utils/fsck/Makefile.in
--- reiserfsprogs-3.6.20.orig/utils/fsck/Makefile.in 2008-09-26 23:49:24.000000000 +0200
+++ reiserfsprogs-3.6.20/utils/fsck/Makefile.in 2008-09-26 23:54:22.000000000 +0200
@@ -778,7 +778,7 @@
install-reiserfsck:
if test -f $(DESTDIR)$(sbindir)/fsck.reiserfs; then \
rm -f $(DESTDIR)$(sbindir)/reiserfsck; \
- ln $(DESTDIR)$(sbindir)/fsck.reiserfs $(DESTDIR)$(sbindir)/reiserfsck; \
+ ln -s fsck.reiserfs $(DESTDIR)$(sbindir)/reiserfsck; \
fi;
install-data-local: install-reiserfsck
diff -Nru reiserfsprogs-3.6.20.orig/utils/mkfs/Makefile.in reiserfsprogs-3.6.20/utils/mkfs/Makefile.in
--- reiserfsprogs-3.6.20.orig/utils/mkfs/Makefile.in 2008-09-26 23:49:24.000000000 +0200
+++ reiserfsprogs-3.6.20/utils/mkfs/Makefile.in 2008-09-26 23:54:32.000000000 +0200
@@ -491,7 +491,7 @@
install-mkreiserfs:
if test -f $(DESTDIR)$(sbindir)/mkfs.reiserfs; then \
rm -f $(DESTDIR)$(sbindir)/mkreiserfs; \
- ln $(DESTDIR)$(sbindir)/mkfs.reiserfs $(DESTDIR)$(sbindir)/mkreiserfs; \
+ ln -s mkfs.reiserfs $(DESTDIR)$(sbindir)/mkreiserfs; \
fi;
install-data-local: install-mkreiserfs
diff -Nru reiserfsprogs-3.6.20.orig/utils/resizer/Makefile.in reiserfsprogs-3.6.20/utils/resizer/Makefile.in
--- reiserfsprogs-3.6.20.orig/utils/resizer/Makefile.in 2008-09-26 23:49:24.000000000 +0200
+++ reiserfsprogs-3.6.20/utils/resizer/Makefile.in 2008-09-26 23:54:42.000000000 +0200
@@ -523,7 +523,7 @@
install-resize_reiserfs:
if test -f $(DESTDIR)$(sbindir)/resizefs.reiserfs; then \
rm -f $(DESTDIR)$(sbindir)/resize_reiserfs; \
- ln $(DESTDIR)$(sbindir)/resizefs.reiserfs $(DESTDIR)$(sbindir)/resize_reiserfs; \
+ ln -s resizefs.reiserfs $(DESTDIR)$(sbindir)/resize_reiserfs; \
fi;
install-data-local: install-resize_reiserfs
diff -Nru reiserfsprogs-3.6.20.orig/utils/tune/Makefile.in reiserfsprogs-3.6.20/utils/tune/Makefile.in
--- reiserfsprogs-3.6.20.orig/utils/tune/Makefile.in 2008-09-26 23:49:24.000000000 +0200
+++ reiserfsprogs-3.6.20/utils/tune/Makefile.in 2008-09-26 23:54:50.000000000 +0200
@@ -491,7 +491,7 @@
install-reiserfstune:
if test -f $(DESTDIR)$(sbindir)/tunefs.reiserfs; then \
rm -f $(DESTDIR)$(sbindir)/reiserfstune; \
- ln $(DESTDIR)$(sbindir)/tunefs.reiserfs $(DESTDIR)$(sbindir)/reiserfstune; \
+ ln -s tunefs.reiserfs $(DESTDIR)$(sbindir)/reiserfstune; \
fi;
install-data-local: install-reiserfstune

View File

@ -34,7 +34,6 @@ drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/column
-rwxr-xr-x root/root usr/bin/cytune
-rwxr-xr-x root/root usr/bin/ddate
-rwxr-xr-x root/root usr/bin/fdformat
-rwxr-xr-x root/root usr/bin/flock
-rwxr-xr-x root/root usr/bin/getopt
-rwxr-xr-x root/root usr/bin/hexdump
@ -115,6 +114,7 @@ drwxr-xr-x root/root usr/man/man8/
-rw-r--r-- root/root usr/man/man8/hwclock.8.gz
-rw-r--r-- root/root usr/man/man8/i386.8.gz
-rw-r--r-- root/root usr/man/man8/isosize.8.gz
-rw-r--r-- root/root usr/man/man8/ldattach.8.gz
-rw-r--r-- root/root usr/man/man8/linux32.8.gz
-rw-r--r-- root/root usr/man/man8/linux64.8.gz
-rw-r--r-- root/root usr/man/man8/losetup.8.gz
@ -135,6 +135,8 @@ drwxr-xr-x root/root usr/man/man8/
-rw-r--r-- root/root usr/man/man8/umount.8.gz
-rw-r--r-- root/root usr/man/man8/vidmode.8.gz
drwxr-xr-x root/root usr/sbin/
-rwxr-xr-x root/root usr/sbin/fdformat
-rwxr-xr-x root/root usr/sbin/ldattach
lrwxrwxrwx root/root usr/sbin/ramsize -> rdev
-rwxr-xr-x root/root usr/sbin/rdev
-rwxr-xr-x root/root usr/sbin/readprofile

View File

@ -1 +1 @@
b6c891284f875b01be1b4d012c03736e util-linux-ng-2.13.1.tar.gz
17bafd53cf242accd716d2306a2c6582 util-linux-ng-2.14.1.tar.gz

View File

@ -4,9 +4,9 @@
# Depends on: e2fsprogs, ncurses, zlib
name=util-linux-ng
version=2.13.1
version=2.14.1
release=1
source=(http://www.kernel.org/pub/linux/utils/$name/v2.13/$name-$version.tar.gz)
source=(http://www.kernel.org/pub/linux/utils/$name/v2.14/$name-$version.tar.gz)
build() {
cd $name-$version