glibc: remove old patches

This commit is contained in:
Juergen Daubert 2012-09-15 18:14:17 +02:00
parent 113150d0b3
commit 91a964cad6
3 changed files with 0 additions and 129 deletions

View File

@ -1,63 +0,0 @@
This is the important part of 8f4a5048eea6536ee85c0f2670adbb97d71e427d.
Unfortunately the assertion fails in statically linked binaries.
diff --git a/sysdeps/unix/sysv/linux/getpagesize.c b/sysdeps/unix/sysv/linux/getpagesize.c
index 6d03b3b..0866079 100644
--- a/sysdeps/unix/sysv/linux/getpagesize.c
+++ b/sysdeps/unix/sysv/linux/getpagesize.c
@@ -1,4 +1,4 @@
-/* Copyright (C) 1991,1992,1995-1997,2000,2002,2004
+/* Copyright (C) 1991,1992,1995-1997,2000,2002,2004,2010
Free Software Foundation, Inc.
This file is part of the GNU C Library.
@@ -17,30 +17,37 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
+#include <assert.h>
#include <unistd.h>
#include <sys/param.h>
#include <ldsodefs.h>
+#include <kernel-features.h>
/* Return the system page size. */
int
__getpagesize ()
{
+#ifdef __ASSUME_AT_PAGESIZE
+ assert (GLRO(dl_pagesize) != 0);
+ return GLRO(dl_pagesize);
+#else
if (GLRO(dl_pagesize) != 0)
return GLRO(dl_pagesize);
-#ifdef EXEC_PAGESIZE
+# ifdef EXEC_PAGESIZE
return EXEC_PAGESIZE;
-#else /* No EXEC_PAGESIZE. */
-#ifdef NBPG
-#ifndef CLSIZE
-#define CLSIZE 1
-#endif /* No CLSIZE. */
+# else /* No EXEC_PAGESIZE. */
+# ifdef NBPG
+# ifndef CLSIZE
+# define CLSIZE 1
+# endif /* No CLSIZE. */
return NBPG * CLSIZE;
-#else /* No NBPG. */
+# else /* No NBPG. */
return NBPC;
-#endif /* NBPG. */
-#endif /* EXEC_PAGESIZE. */
+# endif /* NBPG. */
+# endif /* EXEC_PAGESIZE. */
+#endif
}
libc_hidden_def (__getpagesize)
weak_alias (__getpagesize, getpagesize)
--
1.7.2.1

View File

@ -1,40 +0,0 @@
# http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=3aba072d90b500e76f7f1cb06c659fb3cf02c6b8
# 2010-08-03: reapplied for glibc 2.12.1
commit 3aba072d90b500e76f7f1cb06c659fb3cf02c6b8
Author: Jakub Jelinek <jakub@redhat.com>
Date: Wed Jul 22 13:23:08 2009 +0200
Undefine __i686 on x86.
diff -Nru glibc-2.12.1.orig/Makeconfig glibc-2.12.1/Makeconfig
--- glibc-2.12.1.orig/Makeconfig 2010-07-27 13:34:39.000000000 +0200
+++ glibc-2.12.1/Makeconfig 2010-08-03 23:10:22.519954554 +0200
@@ -789,12 +789,12 @@
# The assembler can generate debug information too.
ifndef ASFLAGS
ifeq ($(have-cpp-asm-debuginfo),yes)
-ASFLAGS := $(filter -g% -fdebug-prefix-map=%,$(CFLAGS))
+ASFLAGS = $(filter -g% -fdebug-prefix-map=%,$(CFLAGS))
else
-ASFLAGS :=
+ASFLAGS =
endif
endif
-ASFLAGS += $(ASFLAGS-config) $(asflags-cpu)
+ASFLAGS += $(ASFLAGS-config) $(asflags-cpu) $(sysdep-ASFLAGS)
ifndef BUILD_CC
BUILD_CC = $(CC)
diff -Nru glibc-2.12.1.orig/sysdeps/i386/Makefile glibc-2.12.1/sysdeps/i386/Makefile
--- glibc-2.12.1.orig/sysdeps/i386/Makefile 2010-07-27 13:34:39.000000000 +0200
+++ glibc-2.12.1/sysdeps/i386/Makefile 2010-08-03 23:12:02.319954272 +0200
@@ -2,6 +2,8 @@
# Every i386 port in use uses gas syntax (I think).
asm-CPPFLAGS += -DGAS_SYNTAX
+sysdep-ASFLAGS += -U__i686
+
# The i386 `long double' is a distinct type we support.
long-double-fcts = yes

View File

@ -1,26 +0,0 @@
# http://sourceware.org/ml/libc-hacker/2010-12/msg00001.html
# new fix for http://seclists.org/fulldisclosure/2010/Oct/257
2010-12-09 Andreas Schwab <schwab@redhat.com>
* elf/dl-object.c (_dl_new_object): Ignore origin of privileged
program.
---
elf/dl-object.c | 3 +++
1 files changed, 3 insertions(+), 0 deletions(-)
diff --git a/elf/dl-object.c b/elf/dl-object.c
index 5d15ce1..a34e902 100644
--- a/elf/dl-object.c
+++ b/elf/dl-object.c
@@ -220,6 +220,9 @@ _dl_new_object (char *realname, const char *libname, int type,
out:
new->l_origin = origin;
}
+ else if (INTUSE(__libc_enable_secure) && type == lt_executable)
+ /* The origin of a privileged program cannot be trusted. */
+ new->l_origin = (char *) -1;
return new;
}