exim: added openssl patch

This commit is contained in:
Simone Rota 2007-02-28 20:41:58 +00:00
parent ad4efb8f74
commit 93e3658574
3 changed files with 21 additions and 2 deletions

View File

@ -1,3 +1,4 @@
f1682811a7fd2897153c5b0e33177509 exim
01288e44919d8abdde5a7bd2c200449b exim-4.66.tar.bz2
f9edb79bd90e2b6e8233b2ef26e95aa9 exim-config.patch
600d6448d11289c479da7a7ce600ce31 exim-openssl.patch

View File

@ -5,13 +5,14 @@
name=exim
version=4.66
release=1
release=2
source=(ftp://ftp.exim.org/pub/exim/exim4/$name-$version.tar.bz2 \
$name $name-config.patch)
$name $name-config.patch $name-openssl.patch)
build() {
cd $name-$version
patch -p1 < ../$name-openssl.patch
sed "s/#CFLAGS#/$CFLAGS/" $SRC/$name-config.patch | patch -p1
cp src/EDITME Local/Makefile

17
exim/exim-openssl.patch Normal file
View File

@ -0,0 +1,17 @@
diff -Nru exim-4.66.orig/src/tls-openssl.c exim-4.66/src/tls-openssl.c
--- exim-4.66.orig/src/tls-openssl.c 2007-02-28 20:33:35.527246099 +0000
+++ exim-4.66/src/tls-openssl.c 2007-02-28 20:34:47.751361917 +0000
@@ -343,8 +343,11 @@
/* Set up the information callback, which outputs if debugging is at a suitable
level. */
-if (!(SSL_CTX_set_info_callback(ctx, (void (*)())info_callback)))
- return tls_error(US"SSL_CTX_set_info_callback", host);
+/* if (!(SSL_CTX_set_info_callback(ctx, (void (*)())info_callback)))
+ return tls_error(US"SSL_CTX_set_info_callback", host); */
+
+SSL_CTX_set_info_callback(ctx, (void (*)())info_callback);
+
/* The following patch was supplied by Robert Roselius */