lilo: update to 23.0

This commit is contained in:
Juergen Daubert 2010-07-19 16:12:57 +02:00
parent 27219efe6c
commit 96233d679d
4 changed files with 49 additions and 28 deletions

View File

@ -8,6 +8,7 @@ drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man5/
-rw-r--r-- root/root usr/man/man5/lilo.conf.5.gz
drwxr-xr-x root/root usr/man/man8/
-rw-r--r-- root/root usr/man/man8/keytab-lilo.8.gz
-rw-r--r-- root/root usr/man/man8/lilo.8.gz
drwxr-xr-x root/root usr/sbin/
-rwxr-xr-x root/root usr/sbin/keytab-lilo.pl
-rwxr-xr-x root/root usr/sbin/keytab-lilo

View File

@ -1,3 +1,3 @@
72765f2aafd20e23ecf07ebd22baeec7 lilo-22.8.src.tar.gz
3bda453de1a93934d270d19e083c3d2c lilo-config.patch
72f9b547393c0d0fb48b4b1c23f85f50 lilo-23.0.tar.gz
6c47c14c4adcd896e637accfc776afc4 lilo-config.patch
33ffc1bb0b8ff0b67236cd074f14fcf9 lilo.conf

View File

@ -1,19 +1,18 @@
# Description: LInux boot LOader
# URL: http://tldp.org/HOWTO/LILO.html
# URL: http://lilo.alioth.debian.org/
# Maintainer: CRUX System Team, core-ports at crux dot nu
# Depends on: libdevmapper
name=lilo
version=22.8
release=2
source=(http://www.ibiblio.org/pub/Linux/system/boot/lilo/$name-$version.src.tar.gz \
version=23.0
release=1
source=(http://alioth.debian.org/frs/download.php/3315/$name-$version.tar.gz \
$name-config.patch lilo.conf)
build() {
cd $name-$version
patch -p1 -i $SRC/$name-config.patch
make all
make ROOT=$PKG install
make DESTDIR=$PKG install
install -m 644 $SRC/lilo.conf $PKG/etc
rm $PKG/{sbin/mkrescue,usr/man/man8/mkrescue.8}
}

View File

@ -1,30 +1,51 @@
diff -Nru lilo-22.8.orig/Makefile lilo-22.8/Makefile
--- lilo-22.8.orig/Makefile 2007-02-19 18:15:10.000000000 +0100
+++ lilo-22.8/Makefile 2007-02-20 15:19:21.000000000 +0100
@@ -65,7 +65,7 @@
# XL_SECS=n Support for extra large (non-standard) floppies.
diff -Nru lilo-23.0.orig/make.vars lilo-23.0/make.vars
--- lilo-23.0.orig/make.vars 2010-07-15 21:39:54.965407096 +0200
+++ lilo-23.0/make.vars 2010-07-15 21:40:57.575406190 +0200
@@ -64,14 +64,14 @@
# XL_SECS=n Support for extra large (non-standard) floppies.
CONFIG=-DBDATA -DDSECS=3 -DEVMS -DIGNORECASE -DLVM -DNOKEYBOARD -DONE_SHOT \
- -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVERSION -DVIRTUAL \
+ -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVIRTUAL \
-DMDPRAID -DDEVMAPPER
- -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVERSION -DVIRTUAL \
+ -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVIRTUAL \
-DMDPRAID -DDEVMAPPER
# set the following if you wish LILO.COM to be installed
DOS_DIR=/dosC/boot
@@ -80,7 +80,7 @@
#
MAN_DIR=`if [ -f /usr/bin/manpath ]; then \
manpath | sed "s/:.*//"; else echo /usr/share/man; fi`
-#MAN_DIR=/usr/share/man
# select place for man pages
-MAN_DIR=/usr/share/man
+MAN_DIR=/usr/man
# set the compiler optimization level
OPT=-Os
diff -Nru lilo-23.0.orig/man/Makefile lilo-23.0/man/Makefile
--- lilo-23.0.orig/man/Makefile 2010-07-15 21:39:54.965407096 +0200
+++ lilo-23.0/man/Makefile 2010-07-15 21:52:36.175405918 +0200
@@ -8,7 +8,6 @@
install:
mkdir -p $$DESTDIR$(MAN_DIR)/man5 $$DESTDIR$(MAN_DIR)/man8
cp lilo.8 $$DESTDIR$(MAN_DIR)/man8
- cp mkrescue.8 $$DESTDIR$(MAN_DIR)/man8
cp lilo.conf.5 $$DESTDIR$(MAN_DIR)/man5
cp keytab-lilo.8 $$DESTDIR$(MAN_DIR)/man8
@@ -165,7 +165,7 @@
diff -Nru lilo-23.0.orig/src/Makefile lilo-23.0/src/Makefile
--- lilo-23.0.orig/src/Makefile 2010-07-15 21:39:54.985406163 +0200
+++ lilo-23.0/src/Makefile 2010-07-15 21:52:55.195406033 +0200
@@ -41,7 +41,7 @@
#
# everything needed to run, just short of installation
#
-all: lilo bootsect.b diag1.img # OBSOLETE: $(BOOTS) edit dparam.com activate
+all: lilo bootsect.b # diag1.img OBSOLETE: $(BOOTS) edit dparam.com activate
if [ -x /usr/bin/bcc -o -x /usr/local/bin/bcc ]; then \
make diagnostic; \
make dosexe; fi
-all: lilo bootsect.b diag1.img
+all: lilo
#
# everything above plus the statically linked version
@@ -257,7 +257,6 @@
rm -f $$DESTDIR$(BOOT_DIR)/boot.b; fi
cp lilo $$DESTDIR$(SBIN_DIR)/lilo
strip $$DESTDIR$(SBIN_DIR)/lilo
- cp ../mkrescue $$DESTDIR$(USRSBIN_DIR)/mkrescue
cp ../keytab-lilo.pl $$DESTDIR$(USRSBIN_DIR)/keytab-lilo
insobs: