openssl: fix build with -jN, N > 1

This commit is contained in:
Johannes Winkelmann 2006-09-06 10:10:20 +00:00
parent b8793aac92
commit 975dabaa97
3 changed files with 29 additions and 1 deletions

View File

@ -1,2 +1,3 @@
9d0df57845af8acd1027a7df5c18d017 mksslcert.sh
58daa890c3bc19bd6ce3451b2e5e335c openssl-0.9.8b-parallel-build.patch
78454bec556bcb4c45129428a766c886 openssl-0.9.8c.tar.gz

View File

@ -6,10 +6,11 @@ name=openssl
version=0.9.8c
release=1
source=(http://www.openssl.org/source/$name-$version.tar.gz \
mksslcert.sh)
mksslcert.sh openssl-0.9.8b-parallel-build.patch)
build() {
cd $name-$version
patch -p1 < $SRC/openssl-0.9.8b-parallel-build.patch
./config --prefix=/usr --openssldir=/etc/ssl shared
make
make INSTALL_PREFIX=$PKG MANDIR=/usr/man MANSUFFIX=ssl install

View File

@ -0,0 +1,26 @@
Parallel make fix, from
http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-libs/openssl/files/
--- openssl-0.9.8b/Makefile.org
+++ openssl-0.9.8b/Makefile.org
@@ -229,15 +229,15 @@
build_crypto:
@dir=crypto; target=all; $(BUILD_ONE_CMD)
-build_ssl:
+build_ssl: build_crypto
@dir=ssl; target=all; $(BUILD_ONE_CMD)
-build_engines:
+build_engines: build_crypto
@dir=engines; target=all; $(BUILD_ONE_CMD)
-build_apps:
+build_apps: build_libs
@dir=apps; target=all; $(BUILD_ONE_CMD)
-build_tests:
+build_tests: build_libs
@dir=test; target=all; $(BUILD_ONE_CMD)
-build_tools:
+build_tools: build_libs
@dir=tools; target=all; $(BUILD_ONE_CMD)
all_testapps: build_libs build_testapps