bzip: updated to 1.0.4

This commit is contained in:
Tilman Sauerbeck 2007-01-06 13:01:48 +01:00 committed by Simone Rota
parent c25f340c97
commit 99e1cd61a5
4 changed files with 33 additions and 33 deletions

View File

@ -16,8 +16,8 @@ drwxr-xr-x root/root usr/include/
drwxr-xr-x root/root usr/lib/
-rw-r--r-- root/root usr/lib/libbz2.a
lrwxrwxrwx root/root usr/lib/libbz2.so -> libbz2.so.1.0
lrwxrwxrwx root/root usr/lib/libbz2.so.1.0 -> libbz2.so.1.0.3
-rwxr-xr-x root/root usr/lib/libbz2.so.1.0.3
lrwxrwxrwx root/root usr/lib/libbz2.so.1.0 -> libbz2.so.1.0.4
-rwxr-xr-x root/root usr/lib/libbz2.so.1.0.4
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man1/
lrwxrwxrwx root/root usr/man/man1/bunzip2.1.gz -> bzip2.1.gz

View File

@ -1,2 +1,2 @@
d64c8510a3f3e0ba5e821fc7df83997d bzip2-1.0.3.patch
8a716bebecb6e647d2e8a29ea5d8447f bzip2-1.0.3.tar.gz
fc310b254f6ba5fbb5da018f04533688 bzip2-1.0.4.tar.gz
589eeb94dad93f69b366e711ef328cb5 bzip2.patch

View File

@ -3,15 +3,15 @@
# Maintainer: Tilman Sauerbeck, tilman at crux dot nu
name=bzip2
version=1.0.3
release=2
version=1.0.4
release=1
source=(http://www.bzip.org/$version/$name-$version.tar.gz \
$name-$version.patch)
$name.patch)
build() {
cd $name-$version
patch -Np1 -i $SRC/$name-$version.patch
patch -Np1 -i $SRC/$name.patch
make
make PREFIX=$PKG/usr install

View File

@ -1,16 +1,16 @@
diff -aur bzip2-1.0.3.orig/Makefile bzip2-1.0.3/Makefile
--- bzip2-1.0.3.orig/Makefile 2005-02-17 12:28:24.000000000 +0100
+++ bzip2-1.0.3/Makefile 2006-12-06 20:56:42.971829461 +0100
@@ -8,7 +8,7 @@
diff -aur bzip2-1.0.4.orig/Makefile bzip2-1.0.4/Makefile
--- bzip2-1.0.4.orig/Makefile 2007-01-03 04:49:21.000000000 +0100
+++ bzip2-1.0.4/Makefile 2007-01-06 12:48:28.735127995 +0100
@@ -21,7 +21,7 @@
LDFLAGS=
BIGFILES=-D_FILE_OFFSET_BITS=64
-CFLAGS=-Wall -Winline -O -g $(BIGFILES)
-CFLAGS=-Wall -Winline -O2 -g $(BIGFILES)
+CFLAGS+=-Wall -Winline $(BIGFILES)
# Where you want it installed when you do 'make install'
PREFIX=/usr
@@ -57,43 +57,36 @@
PREFIX=/usr/local
@@ -70,43 +70,36 @@
@cat words3
install: bzip2 bzip2recover
@ -34,14 +34,14 @@ diff -aur bzip2-1.0.3.orig/Makefile bzip2-1.0.3/Makefile
- cp -f libbz2.a $(PREFIX)/lib
- chmod a+r $(PREFIX)/lib/libbz2.a
- cp -f bzgrep $(PREFIX)/bin/bzgrep
- ln $(PREFIX)/bin/bzgrep $(PREFIX)/bin/bzegrep
- ln $(PREFIX)/bin/bzgrep $(PREFIX)/bin/bzfgrep
- ln -s -f $(PREFIX)/bin/bzgrep $(PREFIX)/bin/bzegrep
- ln -s -f $(PREFIX)/bin/bzgrep $(PREFIX)/bin/bzfgrep
- chmod a+x $(PREFIX)/bin/bzgrep
- cp -f bzmore $(PREFIX)/bin/bzmore
- ln $(PREFIX)/bin/bzmore $(PREFIX)/bin/bzless
- ln -s -f $(PREFIX)/bin/bzmore $(PREFIX)/bin/bzless
- chmod a+x $(PREFIX)/bin/bzmore
- cp -f bzdiff $(PREFIX)/bin/bzdiff
- ln $(PREFIX)/bin/bzdiff $(PREFIX)/bin/bzcmp
- ln -s -f $(PREFIX)/bin/bzdiff $(PREFIX)/bin/bzcmp
- chmod a+x $(PREFIX)/bin/bzdiff
- cp -f bzgrep.1 bzmore.1 bzdiff.1 $(PREFIX)/man/man1
- chmod a+r $(PREFIX)/man/man1/bzgrep.1
@ -84,34 +84,34 @@ diff -aur bzip2-1.0.3.orig/Makefile bzip2-1.0.3/Makefile
clean:
rm -f *.o libbz2.a bzip2 bzip2recover \
diff -aur bzip2-1.0.3.orig/Makefile-libbz2_so bzip2-1.0.3/Makefile-libbz2_so
--- bzip2-1.0.3.orig/Makefile-libbz2_so 2004-10-17 19:32:13.000000000 +0200
+++ bzip2-1.0.3/Makefile-libbz2_so 2006-12-06 20:57:09.201468711 +0100
@@ -9,7 +9,7 @@
diff -aur bzip2-1.0.4.orig/Makefile-libbz2_so bzip2-1.0.4/Makefile-libbz2_so
--- bzip2-1.0.4.orig/Makefile-libbz2_so 2007-01-03 03:00:55.000000000 +0100
+++ bzip2-1.0.4/Makefile-libbz2_so 2007-01-06 12:46:33.363917744 +0100
@@ -24,7 +24,7 @@
SHELL=/bin/sh
CC=gcc
BIGFILES=-D_FILE_OFFSET_BITS=64
-CFLAGS=-fpic -fPIC -Wall -Winline -O -g
+CFLAGS+=-fpic -fPIC -Wall -Winline
-CFLAGS=-fpic -fPIC -Wall -Winline -O2 -g $(BIGFILES)
+CFLAGS+=-fpic -fPIC -Wall -Winline $(BIGFILES)
OBJS= blocksort.o \
huffman.o \
@@ -22,11 +22,15 @@
@@ -37,11 +37,15 @@
all: $(OBJS)
$(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.3 $(OBJS)
$(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.3
$(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.4 $(OBJS)
$(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.4
- rm -f libbz2.so.1.0
- ln -s libbz2.so.1.0.3 libbz2.so.1.0
- ln -s libbz2.so.1.0.4 libbz2.so.1.0
+
+install:
+ install -d $(PREFIX)/lib
+ install -m 755 libbz2.so.1.0.3 $(PREFIX)/lib
+ ln -sf libbz2.so.1.0.3 $(PREFIX)/lib/libbz2.so.1.0
+ install -m 755 libbz2.so.1.0.4 $(PREFIX)/lib
+ ln -sf libbz2.so.1.0.4 $(PREFIX)/lib/libbz2.so.1.0
+ ln -sf libbz2.so.1.0 $(PREFIX)/lib/libbz2.so
clean:
- rm -f $(OBJS) bzip2.o libbz2.so.1.0.3 libbz2.so.1.0 bzip2-shared
+ rm -f $(OBJS) bzip2.o libbz2.so.1.0.3 bzip2-shared
- rm -f $(OBJS) bzip2.o libbz2.so.1.0.4 libbz2.so.1.0 bzip2-shared
+ rm -f $(OBJS) bzip2.o libbz2.so.1.0.4 bzip2-shared
blocksort.o: blocksort.c
$(CC) $(CFLAGS) -c blocksort.c