gdbm: fix linking of gdbm_compat
This commit is contained in:
parent
8ce96ebbe7
commit
a5cf37f1f4
@ -1,8 +1,10 @@
|
||||
drwxr-xr-x root/root usr/
|
||||
drwxr-xr-x root/root usr/include/
|
||||
-rw-r--r-- root/root usr/include/dbm.h
|
||||
-rw-r--r-- root/root usr/include/gdbm.h
|
||||
-rw-r--r-- root/root usr/include/ndbm.h
|
||||
lrwxrwxrwx root/root usr/include/gdbm.h -> gdbm/gdbm.h
|
||||
drwxr-xr-x root/root usr/include/gdbm/
|
||||
-rw-r--r-- root/root usr/include/gdbm/dbm.h
|
||||
-rw-r--r-- root/root usr/include/gdbm/gdbm.h
|
||||
-rw-r--r-- root/root usr/include/gdbm/ndbm.h
|
||||
drwxr-xr-x root/root usr/lib/
|
||||
-rw-r--r-- root/root usr/lib/libgdbm.a
|
||||
-rwxr-xr-x root/root usr/lib/libgdbm.la
|
||||
|
@ -1 +1,2 @@
|
||||
13a8dfda02d8f0d1db1a982cd9950e7f gdbm-1.8.3-compat-linking.patch
|
||||
1d1b1d5c0245b1c00aff92da751e9aa1 gdbm-1.8.3.tar.gz
|
||||
|
21
gdbm/Pkgfile
21
gdbm/Pkgfile
@ -4,15 +4,22 @@
|
||||
|
||||
name=gdbm
|
||||
version=1.8.3
|
||||
release=1
|
||||
source=(http://ftp.gnu.org/gnu/$name/$name-$version.tar.gz)
|
||||
release=2
|
||||
source=(http://ftp.gnu.org/gnu/$name/$name-$version.tar.gz
|
||||
$name-$version-compat-linking.patch)
|
||||
|
||||
build() {
|
||||
cd $name-$version
|
||||
./configure --prefix=/usr
|
||||
make prefix=/usr
|
||||
make prefix=$PKG/usr install
|
||||
make prefix=$PKG/usr install-compat
|
||||
rm -rf $PKG/usr/info
|
||||
|
||||
patch -p1 -i $SRC/$name-$version-compat-linking.patch
|
||||
|
||||
./configure --prefix=/usr \
|
||||
--includedir=/usr/include/gdbm
|
||||
|
||||
make
|
||||
make -j1 INSTALL_ROOT=$PKG install install-compat
|
||||
ln -sf gdbm/gdbm.h $PKG/usr/include/gdbm.h
|
||||
|
||||
rm -r $PKG/usr/info
|
||||
chown -R root.root $PKG
|
||||
}
|
||||
|
19
gdbm/gdbm-1.8.3-compat-linking.patch
Normal file
19
gdbm/gdbm-1.8.3-compat-linking.patch
Normal file
@ -0,0 +1,19 @@
|
||||
Since libgdbm_compat uses libgdbm, make sure we link it in.
|
||||
|
||||
http://bugs.gentoo.org/165263
|
||||
|
||||
--- gdbm-1.8.3/Makefile.in
|
||||
+++ gdbm-1.8.3/Makefile.in
|
||||
@@ -161,10 +161,10 @@
|
||||
$(LIBTOOL) --mode=link $(CC) -o libgdbm.la -rpath $(libdir) \
|
||||
-version-info $(SHLIB_VER) $(LOBJS)
|
||||
|
||||
-libgdbm_compat.la: $(C_LOBJS) gdbm.h
|
||||
+libgdbm_compat.la: $(C_LOBJS) gdbm.h libgdbm.la
|
||||
rm -f libgdbm_compat.la
|
||||
$(LIBTOOL) --mode=link $(CC) -o libgdbm_compat.la -rpath $(libdir) \
|
||||
- -version-info $(SHLIB_VER) $(C_LOBJS)
|
||||
+ -version-info $(SHLIB_VER) $(C_LOBJS) libgdbm.la
|
||||
|
||||
gdbm.h: gdbm.proto gdbmerrno.h gdbm.proto2
|
||||
rm -f gdbm.h
|
Loading…
x
Reference in New Issue
Block a user