exim: added patch for openssl 3

This commit is contained in:
Tim Biermann 2021-12-11 19:33:34 +01:00
parent 0399a7a7c8
commit a87941c2b3
Signed by: tb
GPG Key ID: 42F8B4E30B673606
3 changed files with 29 additions and 4 deletions

View File

@ -1,7 +1,8 @@
untrusted comment: verify with /etc/ports/core.pub
RWRJc1FUaeVequbjWeT48jNQ7x4Sdtr9mra1gQQtNIJDdCJa1ITdC2OLzMjwPt0M6KYvxUnhnPZ7EVe7L8zZ/MnNdk/0U5xmLwM=
SHA256 (Pkgfile) = 7248b3c3c87972a224e095308cd2f26b57c3ea40b7f1130bf1187b18441516de
RWRJc1FUaeVeqkut1gnxUFXwF0WPkAg3wEynncwLzl0I5Zb+dcbRoT59QYGU6muY3ntjvsG0dEyacqddJw8VpmNcEjgwbPq26As=
SHA256 (Pkgfile) = c2f55a04a64d60beb56137e9f67469430b78a788754c32222e5b5f86a0c828a6
SHA256 (.footprint) = 3e5fe8471a7a9057c0c7486c016ea2ed1dc5ebd72adc13c23f432ef468d2fc5d
SHA256 (exim-4.95.tar.xz) = cc9cb653fff2ea947c3702680b59c99ac0bd1bbf19976d37e22a463cd804f167
SHA256 (exim) = 850f72cb4d069dc8d15ce138623e6b6a7fe33f5daebe37fbf93c7801fa2d6134
SHA256 (exim-config.patch) = 9b634234d24679b689a1fb664ddaab98d8f80f9563244dbebbf8a81eeedd541e
SHA256 (exim-4.95-openssl30-build-fix.patch) = 86408bbe358d4d074a10e427e62afc0b4e82f17472512317b92fe62e51f25262

View File

@ -5,13 +5,15 @@
name=exim
version=4.95
release=1
release=2
source=(https://ftp.exim.org/pub/exim/exim4/$name-$version.tar.xz \
$name $name-config.patch)
$name $name-config.patch exim-4.95-openssl30-build-fix.patch)
build() {
cd $name-$version
patch -Np1 -i $SRC/exim-4.95-openssl30-build-fix.patch
sed "s/#CFLAGS#/$CFLAGS/" $SRC/$name-config.patch | patch -p1
cp src/EDITME Local/Makefile

View File

@ -0,0 +1,22 @@
diff --git a/src/tls-openssl.c b/src/tls-openssl.c
index bc454c8..c6da62c 100644
--- a/src/tls-openssl.c
+++ b/src/tls-openssl.c
@@ -232,10 +232,14 @@ static exim_openssl_option exim_openssl_options[] = {
{ US"no_tlsv1", SSL_OP_NO_TLSv1 },
#endif
#ifdef SSL_OP_NO_TLSv1_1
-# if SSL_OP_NO_TLSv1_1 == 0x00000400L
+# if OPENSSL_VERSION_NUMBER < 0x30000000L
+# if SSL_OP_NO_TLSv1_1 == 0x00000400L
/* Error in chosen value in 1.0.1a; see first item in CHANGES for 1.0.1b */
-# warning OpenSSL 1.0.1a uses a bad value for SSL_OP_NO_TLSv1_1, ignoring
-# else
+# warning OpenSSL 1.0.1a uses a bad value for SSL_OP_NO_TLSv1_1, ignoring
+# define NO_SSL_OP_NO_TLSv1_1
+# endif
+# endif
+# ifndef NO_SSL_OP_NO_TLSv1_1
{ US"no_tlsv1_1", SSL_OP_NO_TLSv1_1 },
# endif
#endif